cosmosex shared drive not working

General discussions or ideas about hardware.
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2878
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: cosmosex shared drive not working

Post by rubber_jonnie » Mon Jul 20, 2020 9:26 am

exxos wrote:
Sun Jul 19, 2020 11:58 pm
rubber_jonnie wrote:
Sun Jul 19, 2020 11:53 pm
@exxos can you post a pic of the CosmosEx shared drive config please
viewtopic.php?f=29&t=1991&start=10#p44739
Thanks, I presume you have tried setting up the share with a specific set of credentials rather than guest? I think Tom suggested similar? It works for me under Windows 7.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 11806
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: cosmosex shared drive not working

Post by exxos » Mon Jul 20, 2020 9:30 am

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2878
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: cosmosex shared drive not working

Post by rubber_jonnie » Mon Jul 20, 2020 9:45 am

exxos wrote:
Mon Jul 20, 2020 9:30 am
I've got these..

viewtopic.php?f=29&t=1991&start=20#p44757
Ok, I keep asking questions you seem to have answered before, let me have a read back. :dizzy:
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2878
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: cosmosex shared drive not working

Post by rubber_jonnie » Mon Jul 20, 2020 10:17 am

@exxos Here: viewtopic.php?f=29&t=1991&start=20#p44747 the error message shows a source of '//192.168.0.6/CHRIS-PC/atarishared', so I'm not surprised that it doesn't work, since it has both the IP of your PC then the PC name.

Can I suggest the following, since you posted that on your PC you can see the atarishared if you enter \\CHRIS-PC\atarishared

1. Configure a username/password on your PC, and give that user full access rights to the atarishared share.
2. Configure the CosmosEx as you have (IP address of your PC not the name), atarishared as the shared folder.
3. Add in the username and password configured at step 1 and save.

You shouldn't need to reboot, if I make a change to mine it comes back right away. If it doesn't work, try changing the sharename to something shorter like just atari in case the CosmosEx doesn't like the long sharename.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 11806
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: cosmosex shared drive not working

Post by exxos » Mon Jul 20, 2020 12:09 pm

I've tried with and without "CHRIS-PC" anyway.

Oddly I can now view \\CHRIS-PC\atarishared in chrome , it wasn't working last night.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

Atarian Computing
Posts: 392
Joined: Tue Aug 22, 2017 4:27 am

Re: cosmosex shared drive not working

Post by Atarian Computing » Mon Jul 20, 2020 12:30 pm

Are you on Wi-Fi or LAN? Try LAN as WiFi is flakey for me.

I think mikro meant the Linux console from within the CosmosEx settings.

User avatar
Cyprian
Posts: 204
Joined: Fri Dec 22, 2017 9:16 am
Location: Poland

Re: cosmosex shared drive not working

Post by Cyprian » Mon Jul 20, 2020 12:48 pm

would be worth to check whether you can see your PC from CosmosEx.
You can log into CosmosEx Linux and just ping your host and try to access it.
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/

User avatar
exxos
Site Admin
Site Admin
Posts: 11806
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: cosmosex shared drive not working

Post by exxos » Mon Jul 20, 2020 12:55 pm

This is all wired LAN.

Though when I change settings on my PC via the web interface, the cosmosex MOUNT.ERR log changes in file size, so its not like the link isn't working.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

Tomswork
Posts: 414
Joined: Fri Nov 22, 2019 10:05 pm

Re: cosmosex shared drive not working

Post by Tomswork » Mon Jul 20, 2020 2:54 pm

I agree with creating an account with username and password will help

Tom

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2878
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: cosmosex shared drive not working

Post by rubber_jonnie » Sat Jul 25, 2020 5:34 pm

exxos wrote:
Fri Dec 06, 2019 6:46 pm
I'm updating the firmware on the ST, see what happens.. though it got the latest update, so its not like its a network error, just cosmo refuses to "see" the shared drive for some reason :(
I tested with a non domain Windows 7 PC today,and you must use a username and password or it doesn't work.

Set the share up to allow "Everyone" access, then use the login name you use on your PC and your password on the CosmosEx. This worked for me no problem.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

Locked

Return to “HARDWARE DISCUSSIONS”