STE mods

General discussions or ideas about hardware.
Post Reply
User avatar
HigashiJun
Posts: 54
Joined: Fri Jun 19, 2020 7:21 am

STE mods

Post by HigashiJun » Sat Aug 29, 2020 10:48 am

As promised in another thread, here are some pics of the internal mods I made in my 1040 STE during my short summer vacation:

TOS.jpeg
TOS.jpeg (378.88 KiB) Viewed 1665 times
HD.jpeg
HD.jpeg (335.87 KiB) Viewed 1665 times
PSU.jpeg
PSU.jpeg (414.83 KiB) Viewed 1665 times
US.jpeg
US.jpeg (400.99 KiB) Viewed 1665 times
Everything works like a charm.

Next step will be to install the STE booster, but it's another story...

Cheers.

joelolzen
Posts: 7
Joined: Thu May 23, 2019 6:58 pm

Re: STE mods

Post by joelolzen » Sat Aug 29, 2020 3:05 pm

Looks great ! Could you give more detail on the internal satan Install please?

User avatar
HigashiJun
Posts: 54
Joined: Fri Jun 19, 2020 7:21 am

Re: STE mods

Post by HigashiJun » Sun Aug 30, 2020 3:27 am

joelolzen wrote:
Sat Aug 29, 2020 3:05 pm
Looks great ! Could you give more detail on the internal satan Install please?
Thanks !

Here's a picture from another forum which will help you connect the Ultra Satan internally:

InternalUS.jpg
InternalUS.jpg (323.36 KiB) Viewed 1601 times

If you plan to install Exxos' HD fdd kit, you'll have to move the flat cable on the left side, as seen in my previous pics.

Have fun !

User avatar
HigashiJun
Posts: 54
Joined: Fri Jun 19, 2020 7:21 am

Re: STE mods

Post by HigashiJun » Sat Sep 12, 2020 1:49 am

Next steps done...

CPU is now socketed
CPU.jpeg
CPU.jpeg (221.63 KiB) Viewed 1513 times

and tested... Everything works fine. :D

Exxos booster is stripped off and ready for a fit:
Booster.jpeg
Booster.jpeg (422.08 KiB) Viewed 1513 times

But I'll have to replace the SIL resistors on the STE board first.

Need to find more free time to get the job done.

User avatar
exxos
Site Admin
Site Admin
Posts: 13206
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: STE mods

Post by exxos » Sat Sep 12, 2020 8:38 am

The booster won't fit on motherboards where the cpu is/was soldered to the motherboard..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
HigashiJun
Posts: 54
Joined: Fri Jun 19, 2020 7:21 am

Re: STE mods

Post by HigashiJun » Sat Sep 12, 2020 8:51 am

Yes, I know that soldered CPUs were not compatible with your booster.

I just plan to mod my STE as IngoQ did and that's why I had to strip your booster off.

User avatar
exxos
Site Admin
Site Admin
Posts: 13206
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: STE mods

Post by exxos » Sat Sep 12, 2020 9:00 am

It is not recommend or approved a reliable method of installing the booster. Just because ingo got it working doesn't mean its reliable or will work on any other machines.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
HigashiJun
Posts: 54
Joined: Fri Jun 19, 2020 7:21 am

Re: STE mods

Post by HigashiJun » Sat Sep 12, 2020 10:13 am

No problem if it doesn't work, I won't blame you...

User avatar
IngoQ
Site Admin
Site Admin
Posts: 1005
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: STE mods

Post by IngoQ » Mon Sep 14, 2020 1:21 pm

exxos wrote:
Sat Sep 12, 2020 9:00 am
It is not recommend or approved a reliable method of installing the booster. Just because ingo got it working doesn't mean its reliable or will work on any other machines.
I ended up keeping the 1.5 STF-Booster in my STE, since it had such a nice small footprint. But the STE booster worked very well too.
Ingo :geek:

| Atari 1040STE@32MHz | Amiga 1200 (ACA1220) | Atari 800XL (U1MB, SIDE2) | Atari 130XL (Sophia DVI) | C64 (1541 Ultimate II, Rev3 RFMod Replacement) | TI 99/4A (F18A, 32k, FlashROM 99) | Sinclair ZX Spectrum 128 (Stereo, DivMMC) | Amstrad CPC664 (512k, M4 Wifi) | ... |

User avatar
HigashiJun
Posts: 54
Joined: Fri Jun 19, 2020 7:21 am

Re: STE mods

Post by HigashiJun » Mon Sep 14, 2020 2:08 pm

IngoQ wrote:
Mon Sep 14, 2020 1:21 pm
exxos wrote:
Sat Sep 12, 2020 9:00 am
It is not recommend or approved a reliable method of installing the booster. Just because ingo got it working doesn't mean its reliable or will work on any other machines.
I ended up keeping the 1.5 STF-Booster in my STE, since it had such a nice small footprint. But the STE booster worked very well too.
Sure it has, but as Exxos doesn't sell it anymore, the only way for me was the STE booster.

Anyway, I'd like to thank you for your great post. It saves me from doing all the research you did (connections, traces, etc.). 8-)

Cheers.

Post Reply

Return to “HARDWARE DISCUSSIONS”