Old Glue and MMU compatibility

General discussions or ideas about hardware.
User avatar
PhilC
Moderator
Moderator
Posts: 3781
Joined: Fri Mar 23, 2018 8:22 pm

Old Glue and MMU compatibility

Post by PhilC » Mon Oct 19, 2020 9:47 pm

Evening All,

Just a quick question. I've got a Rev C C070243 with the -20 glue and mmu. I think the mmu has died. Are these compatible with the -38 versions?
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 12613
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Old Glue and MMU compatibility

Post by exxos » Mon Oct 19, 2020 9:49 pm

Never heard of a -20 glue ?
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 3781
Joined: Fri Mar 23, 2018 8:22 pm

Re: Old Glue and MMU compatibility

Post by PhilC » Mon Oct 19, 2020 9:54 pm

exxos wrote:
Mon Oct 19, 2020 9:49 pm
Never heard of a -20 glue ?
Here ya go. Writing is out 90 degrees
16031408554562903774850732169506.jpg
16031408554562903774850732169506.jpg (235.78 KiB) Viewed 1084 times
If it ain't broke, test it to Destruction.

czietz
Posts: 338
Joined: Sun Jan 14, 2018 1:02 pm

Re: Old Glue and MMU compatibility

Post by czietz » Mon Oct 19, 2020 9:54 pm

Yes, they are compatible.
exxos wrote:
Mon Oct 19, 2020 9:49 pm
Never heard of a -20 glue ?
The first STs has a chipset made by Universal Semiconductors: https://temlib.org/AtariForumWiki/image ... jokker.jpg

User avatar
PhilC
Moderator
Moderator
Posts: 3781
Joined: Fri Mar 23, 2018 8:22 pm

Re: Old Glue and MMU compatibility

Post by PhilC » Mon Oct 19, 2020 9:56 pm

@czietz thanks, it did look like they would be but wanted to check.
If it ain't broke, test it to Destruction.

czietz
Posts: 338
Joined: Sun Jan 14, 2018 1:02 pm

Re: Old Glue and MMU compatibility

Post by czietz » Mon Oct 19, 2020 9:58 pm

In case it's really broken, do you mind -- instead of tossing it into the bin -- sending it to me? (I can pay for the postage.) I always wanted to (try to) decap a -20 IC, but they're so rare...

User avatar
PhilC
Moderator
Moderator
Posts: 3781
Joined: Fri Mar 23, 2018 8:22 pm

Re: Old Glue and MMU compatibility

Post by PhilC » Mon Oct 19, 2020 10:21 pm

czietz wrote:
Mon Oct 19, 2020 9:58 pm
In case it's really broken, do you mind -- instead of tossing it into the bin -- sending it to me? (I can pay for the postage.) I always wanted to (try to) decap a -20 IC, but they're so rare...
If its really broken then no problem, will do as long as you share the results :D might throw in a -20 glue as well.
If it ain't broke, test it to Destruction.

troed
Moderator
Moderator
Posts: 710
Joined: Mon Aug 21, 2017 10:27 pm

Re: Old Glue and MMU compatibility

Post by troed » Tue Oct 20, 2020 9:50 am

The -20 GLUE has "short top border" (PAL screen starts higher up on the TV/monitor than on the later revision)

A lot of demos will fail to remove upper border/start fullscreen on those machines.

/Troed

czietz
Posts: 338
Joined: Sun Jan 14, 2018 1:02 pm

Re: Old Glue and MMU compatibility

Post by czietz » Wed Oct 21, 2020 6:24 pm

PhilC wrote:
Mon Oct 19, 2020 10:21 pm
If its really broken then no problem, will do as long as you share the results :D might throw in a -20 glue as well.
Sure, if it's not broken, please keep it. In that case it can be better used than for decapping.

W.r.t. sharing the results: It depends on what you expect. I cannot take beautiful high-res die photos like ijor did for the Ricoh (-38) chips (https://www.fpgaarcade.com/wp4/wp-conte ... OP-50X.jpg) because the good microscope lacks a camera and my USB microscope lacks the magnification. Still, I would like to find out if these chips are really Universal Semiconductor gate arrays and thus I'm hoping for a logo and/or part number on the die.

EDIT: So my die pictures tend to look like this (non-Atari chip):
WIN_20200723_19_05_25_Pro.jpg
WIN_20200723_19_05_25_Pro.jpg (131.59 KiB) Viewed 989 times

User avatar
PhilC
Moderator
Moderator
Posts: 3781
Joined: Fri Mar 23, 2018 8:22 pm

Re: Old Glue and MMU compatibility

Post by PhilC » Mon Nov 02, 2020 8:30 pm

Finally got this machine working, although its stuck in mono mode so got to fix that.

Now I know that the early glue and mmu SHOULD be compatible with the -20 versions as we've discussed earlier in this topic BUT after fixing other issues with the ST I finally got the white border with black foreground, ie memory fault.

I swapped out the -38 mmu and glue for the originals and the machine booted up just fine. So it appears there are differences between the old and current version. No idea what yet though.
If it ain't broke, test it to Destruction.

Post Reply

Return to “HARDWARE DISCUSSIONS”