Page 1 of 2

Old Glue and MMU compatibility

Posted: Mon Oct 19, 2020 9:47 pm
by PhilC
Evening All,

Just a quick question. I've got a Rev C C070243 with the -20 glue and mmu. I think the mmu has died. Are these compatible with the -38 versions?

Re: Old Glue and MMU compatibility

Posted: Mon Oct 19, 2020 9:49 pm
by exxos
Never heard of a -20 glue ?

Re: Old Glue and MMU compatibility

Posted: Mon Oct 19, 2020 9:54 pm
by PhilC
exxos wrote:
Mon Oct 19, 2020 9:49 pm
Never heard of a -20 glue ?
Here ya go. Writing is out 90 degrees
16031408554562903774850732169506.jpg
16031408554562903774850732169506.jpg (235.78 KiB) Viewed 1253 times

Re: Old Glue and MMU compatibility

Posted: Mon Oct 19, 2020 9:54 pm
by czietz
Yes, they are compatible.
exxos wrote:
Mon Oct 19, 2020 9:49 pm
Never heard of a -20 glue ?
The first STs has a chipset made by Universal Semiconductors: https://temlib.org/AtariForumWiki/image ... jokker.jpg

Re: Old Glue and MMU compatibility

Posted: Mon Oct 19, 2020 9:56 pm
by PhilC
@czietz thanks, it did look like they would be but wanted to check.

Re: Old Glue and MMU compatibility

Posted: Mon Oct 19, 2020 9:58 pm
by czietz
In case it's really broken, do you mind -- instead of tossing it into the bin -- sending it to me? (I can pay for the postage.) I always wanted to (try to) decap a -20 IC, but they're so rare...

Re: Old Glue and MMU compatibility

Posted: Mon Oct 19, 2020 10:21 pm
by PhilC
czietz wrote:
Mon Oct 19, 2020 9:58 pm
In case it's really broken, do you mind -- instead of tossing it into the bin -- sending it to me? (I can pay for the postage.) I always wanted to (try to) decap a -20 IC, but they're so rare...
If its really broken then no problem, will do as long as you share the results :D might throw in a -20 glue as well.

Re: Old Glue and MMU compatibility

Posted: Tue Oct 20, 2020 9:50 am
by troed
The -20 GLUE has "short top border" (PAL screen starts higher up on the TV/monitor than on the later revision)

A lot of demos will fail to remove upper border/start fullscreen on those machines.

/Troed

Re: Old Glue and MMU compatibility

Posted: Wed Oct 21, 2020 6:24 pm
by czietz
PhilC wrote:
Mon Oct 19, 2020 10:21 pm
If its really broken then no problem, will do as long as you share the results :D might throw in a -20 glue as well.
Sure, if it's not broken, please keep it. In that case it can be better used than for decapping.

W.r.t. sharing the results: It depends on what you expect. I cannot take beautiful high-res die photos like ijor did for the Ricoh (-38) chips (https://www.fpgaarcade.com/wp4/wp-conte ... OP-50X.jpg) because the good microscope lacks a camera and my USB microscope lacks the magnification. Still, I would like to find out if these chips are really Universal Semiconductor gate arrays and thus I'm hoping for a logo and/or part number on the die.

EDIT: So my die pictures tend to look like this (non-Atari chip):
WIN_20200723_19_05_25_Pro.jpg
WIN_20200723_19_05_25_Pro.jpg (131.59 KiB) Viewed 1158 times

Re: Old Glue and MMU compatibility

Posted: Mon Nov 02, 2020 8:30 pm
by PhilC
Finally got this machine working, although its stuck in mono mode so got to fix that.

Now I know that the early glue and mmu SHOULD be compatible with the -20 versions as we've discussed earlier in this topic BUT after fixing other issues with the ST I finally got the white border with black foreground, ie memory fault.

I swapped out the -38 mmu and glue for the originals and the machine booted up just fine. So it appears there are differences between the old and current version. No idea what yet though.