Full motherboard recap?

General discussions or ideas about hardware.
fenarinarsa
Posts: 27
Joined: Mon Dec 18, 2017 4:03 pm

Full motherboard recap?

Post by fenarinarsa » Sun Nov 15, 2020 11:00 pm

Hello,

I currently own two STEs, one Mega STE and a Falcon 030.

All PSUs have been recapped except for one STE (it's planned, but exxos doesn't offer a capkit for this one).

However there is also a lot of capacitors on the motherboards, and I'm wondering if a full recap is something to be considered.

I thought about this because I also have one Amiga 1200 that must absolutely be recapped because of the many CMS caps used.

To be honest, I'm not afraid of replacing the caps, but there's really a lot and I can't find any caps list so that means I need to unsolder them all to get the references (since they're radial, the refs can't always be read). On the first STE I opened I can see something like 30 capacitors in all, so that would take time.

What's your opinion? And is there somewhere a list of all capacitors for every motherboard revision? (two STEs, two revisions :p)

Thanks.

User avatar
exxos
Site Admin
Site Admin
Posts: 13159
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Full motherboard recap?

Post by exxos » Sun Nov 15, 2020 11:23 pm

I don't think anyone has done a list other than IIRC the falcon motherboard. I could be wrong.

It should probably be done, the PSU is a must. The video circuit suffers from bad caps, so no doubt the rest of the system does.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

fenarinarsa
Posts: 27
Joined: Mon Dec 18, 2017 4:03 pm

Re: Full motherboard recap?

Post by fenarinarsa » Sun Nov 15, 2020 11:42 pm

Thanks for the quick reply :)

So unsolder and making a reference list it is, then.

I've always had video issues on my STE (French, RGB), even back in the 90s. There's echoes in the video signal that you can see when there's high contrats, like a moving bright 3D object on a dark (but not black) background. I assumed that all STEs had this defect by design, but maybe that was only mine?

I didn't really check on the other STE that I just got this week.

User avatar
exxos
Site Admin
Site Admin
Posts: 13159
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Full motherboard recap?

Post by exxos » Sun Nov 15, 2020 11:54 pm

Like this ?

https://www.exxoshost.co.uk/atari/last/ ... /index.htm


But there have been mentions of french STE's having this issue worse than other machines. I think it was @Steve who mentioned it.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

fenarinarsa
Posts: 27
Joined: Mon Dec 18, 2017 4:03 pm

Re: Full motherboard recap?

Post by fenarinarsa » Mon Nov 16, 2020 12:29 am

Yup, exactly! Thanks for pointing me to the fix, I guess I will do this mod as well.

I also plan to fix the -12dB audio mixer issue ;)

BTW I recapped my Falcon and STE with your PSU upgrade kits and one capacitor was missing for the Mitsumi SR98 PSU (C206). No big deal, I'm going to add it to the batch of components I will order.
Else than that they worked perfectly :mrgreen:

User avatar
exxos
Site Admin
Site Admin
Posts: 13159
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Full motherboard recap?

Post by exxos » Mon Nov 16, 2020 1:13 am

Is that the tiny cap ? Its not in the kit as after investigation its better just to leave it alone..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

fenarinarsa
Posts: 27
Joined: Mon Dec 18, 2017 4:03 pm

Re: Full motherboard recap?

Post by fenarinarsa » Mon Nov 16, 2020 7:53 am

exxos wrote:
Mon Nov 16, 2020 1:13 am
Is that the tiny cap ? Its not in the kit as after investigation its better just to leave it alone..
Yes it is.

Some caps aren't worth changing?

User avatar
exxos
Site Admin
Site Admin
Posts: 13159
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Full motherboard recap?

Post by exxos » Mon Nov 16, 2020 8:22 am

fenarinarsa wrote:
Mon Nov 16, 2020 7:53 am
Some caps aren't worth changing?
Unless its physically damaged then there is no point. If I find no advantages in changing something then I don't change stuff. Sometimes people change caps and make things worse. I've known people change PSU csps with cheap ones which make the PSU worse and can even explode. Nobody has done a proper analysis on motherboard csps like on the falcon either. Generally there shouldn't be a issue and its good to change old caps, but nobody tests before and after on various parts of the circuit to see if they actually made things worse or not. I do such tests and document on my site.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Steve
Trusted Guru
Trusted Guru
Posts: 683
Joined: Fri Sep 15, 2017 11:49 am

Re: Full motherboard recap?

Post by Steve » Mon Nov 16, 2020 10:51 am

@fenarinarsa the last machine I experienced this video issue with was an NTSC STE. I did a full recap with the best quality capacitors and also did the video fix above, but the video quality didn't improve as expected. I have a theory it is to do with the RF modulator circuitry causing the interference. But it is just a hunch.
Repairs & Servicing for Atari & Amiga machines (and any other retro computers) Located in the West Midlands UK. PM me if you require assistance.
www.solidstatesociety.co.uk

fenarinarsa
Posts: 27
Joined: Mon Dec 18, 2017 4:03 pm

Re: Full motherboard recap?

Post by fenarinarsa » Mon Nov 16, 2020 5:22 pm

Steve wrote:
Mon Nov 16, 2020 10:51 am
I have a theory it is to do with the RF modulator circuitry causing the interference. But it is just a hunch.
Okay, I'll let you know as soon as I do the patch. I only have RGB STEs without RF modulators so we'll see :)

Post Reply

Return to “HARDWARE DISCUSSIONS”