Page 3 of 5

Re: Suska board

Posted: Tue Apr 17, 2018 10:05 am
by Gargoyle
I'll second that :) so cool to see this happening, much of what Chris wants to achieve very much echoes what I would have wanted to see within a new ST motherboard too. But this time, hopefully a really rock solid piece of engineering!

Re: Suska board

Posted: Tue Apr 17, 2018 12:11 pm
by exxos
troed wrote:
Mon Apr 16, 2018 11:38 pm
Cheers Chris for all the investment you're doing into our community :)

Gargoyle wrote:
Tue Apr 17, 2018 10:05 am
I'll second that :) so cool to see this happening, much of what Chris wants to achieve very much echoes what I would have wanted to see within a new ST motherboard too. But this time, hopefully a really rock solid piece of engineering!

Main goal is to always have backwards compatibility with a stock system. Is the main problem with any "clone" currently.

Wolfgang says he is working on a 68010 55Mhz core, even so this could be a long time away and I think it will be better just stick to the original CPU. Then at least for the timings are as original and we can easily switch back to it.

Of course if the MMU can just be overclocked with the suska core, or timings altered somehow to run faster, then we can hopefully stick to original timings and faster timings and hopefully add video modes future.

I got an email saying it has been shipped, so really need to know what programs we can throw at thing stands.. Of course timing dependent stuff like fullscreen demos etc are not going to run correctly.. But we shall be able to throw some software at it still...

Re: Suska board

Posted: Tue Apr 17, 2018 2:53 pm
by dhedberg
exxos wrote:
Mon Apr 16, 2018 6:04 pm
I just purchased the Suska III :shock:
Great! Thanks Exxos!

I really want one myself but I'm hesitant as I don't want something that basically only runs GEM applications.
Please keep us updated on how it performs. Would really appreciate if you could try and run some demos on it. I understand that full-screen demos will most likely not work, but for the rest it would be interesting to know what they look like.

Re: Suska board

Posted: Thu Apr 19, 2018 3:22 pm
by exxos

IMG_2439.JPG (5.46 MiB) Viewed 2645 times
IMG_2441.JPG (5.94 MiB) Viewed 2645 times
IMG_2442.JPG (5.96 MiB) Viewed 2645 times

Re: Suska board

Posted: Thu Apr 19, 2018 6:17 pm
by rpineau
oooooh .... shiny ! ! :D

Re: Suska board

Posted: Thu Apr 19, 2018 7:57 pm
by PhilC
No, mustn't be tempted...... have too many toys already....

Re: Suska board

Posted: Thu Apr 19, 2018 7:59 pm
by exxos
rpineau wrote:
Thu Apr 19, 2018 6:17 pm
oooooh .... shiny ! ! :D

So far I am not really having much luck :( I was trying with my normal monitor with the RGB port and the best I could get was a really out of sync image. So I plugged in my multisync monitor and I just said no signal detected. I was messing about for about two hours and I was about to give up so I unplugged the RGB connector and then my multisync monitor came on!! So obviously suska does not like two monitors been plugged in at the same time. I think the problem also is that suska defaults to high resolution, and I am not even sure if my normal monitor will accept that resolution.

Then I spent another hour trying to get the mouse to work. I tried 2 PS2 mice, there is a LED on the board which shows when a mouse is connected or not, and this lights up showing it has detected a mouse, but the mouse simply refuses to move on desktop. I was emailing Wolfgang and the said I can use a regular Atari mouse with a adapter cable he supplied, I tried that, still no luck, I still cannot get the desktop mouse to move :(

I don't actually have a PS2 keyboard spare to try that out, so I will try and get one either tomorrow or very soon and see if the keyboard will work..

Wolfgang does not really have anything to suggest as to why the mouse does not work.. I know they can be a pain as while I'm working on the PeST stuff there was a much variation with mice is unbelievable, some would work and some would not, it was chaos. But the mouse which worked with PeST is the one I tried in suska, so it should be a really good mouse anyway.. I think I have a different mouse at my girlfriends house, so I'll bring that back then try that one in Suska..

Re: Suska board

Posted: Fri Apr 20, 2018 10:57 am
by exxos
Wolfgang suggested Atari keyboard.. I was little confused about this as there was no place for a Atari keyboard to plug-in.. But he actually meant the MEGA ST keyboard :roll: so I put that in and now I am finally working with keyboard and mouse :D

The next problem is I am stuck in high resolution and perhaps absolutely no idea how to get into medium resolution.. Currently waiting for Wolfgang to reply on how it is supposed to be done.. :shrug:

Re: Suska board

Posted: Fri Apr 20, 2018 3:55 pm
by exxos
Sometime later, Wolfgang replied with use switch 2 & 3 near the battery to change the resolution... So messed around and eventually managed to get the monitor to almost behave... The other settings it is like images shifted 50% to the right and wrapped around again on the left... This was as good as I could get..

s1.jpg (88.05 KiB) Viewed 2580 times

The manual does not really seem to be very helpful :( but only mentioning there is a bank of switches, it does not say what any of the switches are actually for from what I can see. It does mention a lot about other switches on the board though...

Next problem is the CF card is not on a PC compatible format :roll: I did a sector dump to another CF card and tried to get HD driver to change the partition type to PC compatible... But for some reason it is coming up with some error message.. Basically it will not do it for some reason.. But the problem is this is all in German not really help either :roll:

I did try formatting the card and it did seem to format for a couple of minutes, then it just seemed to freeze and not go any further, and the hard drive light stop flashing and then nothing really happened then.. I could still move the mouse but something was stuck.. I don't know this was a hardware or software bug..

I tried putting in a USB stick and try running detect hard drives to see if it would recognise it, but I have had no luck there either. It does not mention anything in the manual about using the board I think, there is many pages telling you all about it.. At this point I am really missing my floppy drive, I knew where I was floppy's and I could just swapping change and easily. Suska does seem to have a floppy connector but it is not the standard one and I do not have a cable to hook it up.

Also finding there is some odd reset bug somewhere, as when I initially power up nothing happens until I press the reset button. I can't imagine this is by design, sometimes I have to power down and power up and press the reset button a couple of times to get the image to come up..

So I need to work out how to get a regular PC formatted USB drive to work so I can actually copy some software to try out.. Of course I do also need to actually figure out how to flash it with a English TOS..

Of course this is a new computer will take some getting used to.. Though I'm getting a little bit annoyed with it currently :(


Got this reply just..
The USB is prepared
in hardware but not supported yet. Also Ethernet. All this is documented
in the manual. Ethernet requires a person which is willing to work hand
in hand with a guy (me for example) to adapt the Ehernet software stack
to the core. USB is a topic i am working on. The best solution to
exchange files with PCs is the GigaFile or the formatted CF-card and a
driver software (with HDDRIVER for example).
I did buy Gigafile a long time ago, but the SD card socket broke away from the PCB so I cannot use that :( Does not seem to be a proper ASCI connector either, so I cannot try ultra Satan.. So basically I have no way to get files onto this thing :(

Re: Suska board

Posted: Fri Apr 20, 2018 8:28 pm
by exxos
From what I can tell, the CF card Wolfgang supplied as a demo version of HD8 on it. I can do a 1MB partition with TOS box selected, and Suska will boot to desktop that way..BUT..

If I format as DOS & TOS , still doing the same 1MB partition, Suska just comes up with four bombs after the Atari logo appears..

Does anyone know this is normal behaviour for TOS206 or not ? Or some bug in HD8 or something ?

I have emailed Wolfgang again and asked if he can create a CF image which is DOS compatible...