It's taken a while, but...

Show us what you got ;)
Post Reply
User avatar
Cosmic Puppet
Posts: 224
Joined: Fri Aug 02, 2019 1:03 am
Location: West Yorkshire
Contact:

It's taken a while, but...

Post by Cosmic Puppet » Mon Oct 21, 2019 3:19 pm

I have managed to get my old Atari music setup back, with a new machine and the added bonus of an Ultrasatan.
20191021_145808smaller.jpg
20191021_145808smaller.jpg (262.3 KiB) Viewed 568 times
20191021_150947smaller.jpg
20191021_150947smaller.jpg (170.18 KiB) Viewed 568 times
Found this and couldn't resist :D
20191021_154016smaller.jpg
20191021_154016smaller.jpg (197.5 KiB) Viewed 559 times
Atari 520 STFM (C070523-001 REV.D1) 4MB, TOS 1.04 (now using EmuTos), Ultrasatan with 14x 511MB gemdos drives, Original Floppy Drive.

User avatar
exxos
Site Admin
Site Admin
Posts: 9327
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: It's taken a while, but...

Post by exxos » Mon Oct 21, 2019 4:55 pm

:bravo: :coolpics:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Cosmic Puppet
Posts: 224
Joined: Fri Aug 02, 2019 1:03 am
Location: West Yorkshire
Contact:

Re: It's taken a while, but...

Post by Cosmic Puppet » Mon Oct 21, 2019 5:05 pm

exxos wrote:
Mon Oct 21, 2019 4:55 pm
:bravo: :coolpics:
Thank you. Communities like this have been instrumental in making it happen for me!
Atari 520 STFM (C070523-001 REV.D1) 4MB, TOS 1.04 (now using EmuTos), Ultrasatan with 14x 511MB gemdos drives, Original Floppy Drive.

Maximilian
Posts: 111
Joined: Thu Feb 28, 2019 5:02 pm

Re: It's taken a while, but...

Post by Maximilian » Mon Oct 21, 2019 5:13 pm

Damn, now I want my old set back also :D

Nice work!!

User avatar
Cosmic Puppet
Posts: 224
Joined: Fri Aug 02, 2019 1:03 am
Location: West Yorkshire
Contact:

Re: It's taken a while, but...

Post by Cosmic Puppet » Mon Oct 21, 2019 5:28 pm

Maximilian wrote:
Mon Oct 21, 2019 5:13 pm
Damn, now I want my old set back also :D

Nice work!!
Thank you! It's never too late. :)
Atari 520 STFM (C070523-001 REV.D1) 4MB, TOS 1.04 (now using EmuTos), Ultrasatan with 14x 511MB gemdos drives, Original Floppy Drive.

User avatar
IngoQ
Site Admin
Site Admin
Posts: 939
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: It's taken a while, but...

Post by IngoQ » Tue Oct 22, 2019 10:25 am

Very nice :) But I am not hearing a soundcheck :-P
Ingo :geek:

| Atari 1040STE@32MHz | Amiga 1200 (ACA1220) | Atari 800XL (U1MB, SIDE2) | Atari 130XL (Sophia DVI) | C64 (1541 Ultimate II, Rev3 RFMod Replacement) | TI 99/4A (F18A, 32k, FlashROM 99) | Sinclair ZX Spectrum 128 (Stereo, DivMMC) | Amstrad CPC664 (512k, M4 Wifi) | ... |

User avatar
Cosmic Puppet
Posts: 224
Joined: Fri Aug 02, 2019 1:03 am
Location: West Yorkshire
Contact:

Re: It's taken a while, but...

Post by Cosmic Puppet » Tue Oct 22, 2019 11:51 am

IngoQ wrote:
Tue Oct 22, 2019 10:25 am
Very nice :) But I am not hearing a soundcheck :-P
I'd post a clip if I could. :)
Atari 520 STFM (C070523-001 REV.D1) 4MB, TOS 1.04 (now using EmuTos), Ultrasatan with 14x 511MB gemdos drives, Original Floppy Drive.

Post Reply

Return to “SHOW US YOUR COLLECTIONS”