Resistor exploded in my monitor

Tool suggestions, soldering tips, general useful electronics knowhow.
User avatar
sandord
Trusted Guru
Trusted Guru
Posts: 596
Joined: Mon Aug 13, 2018 10:08 pm
Location: The Netherlands
Contact:

Re: Resistor exploded in my monitor

Post by sandord » Sun Jan 27, 2019 4:16 pm

I replaced the power regulator with a brand new one (the previous one was salvaged from a broken monitor) and the PSU is perfectly stable again.

User avatar
exxos
Site Admin
Site Admin
Posts: 10496
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Resistor exploded in my monitor

Post by exxos » Sun Jan 27, 2019 4:26 pm

:bravo:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1279
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Resistor exploded in my monitor

Post by PaulJ » Sun Jan 27, 2019 4:31 pm

Congrats!!!

User avatar
sandord
Trusted Guru
Trusted Guru
Posts: 596
Joined: Mon Aug 13, 2018 10:08 pm
Location: The Netherlands
Contact:

Re: Resistor exploded in my monitor

Post by sandord » Sun Jan 27, 2019 4:36 pm

exxos wrote:
Sun Jan 27, 2019 4:26 pm
:bravo:
Thanks, I'm pretty happy with it!

The only thing that remains (and this was an issue right after the recap, before the regulator broke down) is that when adjusting the horizontal position, the screen jumps down a few lines when in a specific part of the adjustment range. I also notice a bent pattern in the upper corners.

IMG_20190127_172227.jpg
IMG_20190127_172227.jpg (84.47 KiB) Viewed 1131 times
IMG_20190127_172245.jpg
IMG_20190127_172245.jpg (63.14 KiB) Viewed 1131 times

Also, under certain circumstances (a specific program running with specific screen contents), the screen jumps down like a half a screen. The jump happens only once, the screen stays stable in the new position until I close the program (GFA basic with a specific source code loaded). Very strange isn't it?

I've looked at the adjustment instructions in the service manual but I can't seem to find anything that helps. I don't a have a pattern generator so I can't perform all of the instructions, sadly.

I can image that the replaced caps caused an unbalance somewhere that needs to be corrected.

User avatar
exxos
Site Admin
Site Admin
Posts: 10496
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Resistor exploded in my monitor

Post by exxos » Sun Jan 27, 2019 5:09 pm

Sounds a bit like a supply rail is unstable to the frame generator circuit.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “ELECTRONICS”