Undeletable objects in Eagle ?!

Tool suggestions, soldering tips, general useful electronics knowhow.
Post Reply
User avatar
exxos
Site Admin
Site Admin
Posts: 7577
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Undeletable objects in Eagle ?!

Post by exxos » Thu Jan 24, 2019 8:51 pm

At some point I must have added in some squares to stop the autofill filling areas I didn't want it to go.. only.. they seem to be on the top and bottom layers now, and "hashed" and I can't delete the fekers ?!

I moved the whole layout over a bit to get them off the PCB. Though its like they are there, but not there, I can't delete them or move them..

Anyone else run into this problem ?!

wtf.jpg
wtf.jpg (99.95 KiB) Viewed 982 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7577
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Undeletable objects in Eagle ?!

Post by exxos » Thu Jan 24, 2019 8:55 pm

OK nevermind...

Oddly after I closed the files and reloaded them, the problem objects vanished :shrug:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
dhedberg
Posts: 89
Joined: Tue Sep 12, 2017 8:21 pm
Contact:

Re: Undeletable objects in Eagle ?!

Post by dhedberg » Thu Jan 24, 2019 9:05 pm

exxos wrote:
Thu Jan 24, 2019 8:55 pm
OK nevermind...

Oddly after I closed the files and reloaded them, the problem objects vanished :shrug:
Hopefully just some kind paint artifact but scary. It freaks me out when things like that happens in PCB software.
Daniel, New Beat - http://newbeat.atari.org. Like demos? Have a look at our new Falcon030 demo and feel the JOY.

User avatar
exxos
Site Admin
Site Admin
Posts: 7577
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Undeletable objects in Eagle ?!

Post by exxos » Thu Jan 24, 2019 9:09 pm

dhedberg wrote:
Thu Jan 24, 2019 9:05 pm
Hopefully just some kind paint artifact but scary. It freaks me out when things like that happens in PCB software.
Yeah, oddly though the autorouter was actually seeing those objects as it was failing to route near them.. They had been there the past few versions of my PCB, but didn't really bother about them as I wasn't doing much routing.. but I did a total rip-up and then they became a problem.

I did have them on the resist layers to stop the autofill, but Eagle somehow thought they were on the top layer instead.. bizzare...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

ube
Posts: 60
Joined: Mon Aug 21, 2017 11:34 am

Re: Undeletable objects in Eagle ?!

Post by ube » Fri Jan 25, 2019 7:39 am

Re-running a DRU will make them go away. I used to get these when I drew a ground plane using too thin lines after setting a thickness on the power net class.
master of the bare pcb

User avatar
exxos
Site Admin
Site Admin
Posts: 7577
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Undeletable objects in Eagle ?!

Post by exxos » Fri Jan 25, 2019 10:13 am

Running DRC is what is making them appear and they all get hilighted as warnings.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rpineau
Site Admin
Site Admin
Posts: 488
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: Undeletable objects in Eagle ?!

Post by rpineau » Fri Jan 25, 2019 3:15 pm

This means some clearance are not respected. Check your DRC rules, re-run DLC until you either fix the rules or the clearance and they'll go away.
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 7577
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Undeletable objects in Eagle ?!

Post by exxos » Fri Jan 25, 2019 3:39 pm

Its not the highlight areas which the DRC shows as clearances issues. The blocks are stuff which I drew on layer 42 ages ago. They somehow ended on layer 1 as blocks I cannot delete. The autorouter sees them as a layer and it doesn't route by them, so its a physical block on the top layer. But also they are not solid red like top layer stuff is. Its "hashed" like layer 42 should be. So its like has all properties of layer 42, but its actually drawn on layer 1.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rpineau
Site Admin
Site Admin
Posts: 488
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: Undeletable objects in Eagle ?!

Post by rpineau » Fri Jan 25, 2019 4:46 pm

I see, I miss-understood what you were saying (mainly that they were now on layer 1).
I they have still been on layer 42 you could have edited the file by hand as it's all XML and the layer values for each element is easy to find.
But now that they are on layer 1 it's going to be harder.
Can you check see if they are locked ? If they are that would explain why you can't delete them, in which case you can unlock them and delete them.
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 7577
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Undeletable objects in Eagle ?!

Post by exxos » Fri Jan 25, 2019 5:01 pm

I cant do anything with them, not even do a info on them. Its like they are not there in some cases.

I did fix the issue anyway by moving the whole board then saving, and reopening the board. If I just saved and reopened, the problem would remain. So moving the board away from the problem areas seems to fix the issue.

I'm not sure what triggered the issue even.. I did update the connector, but I don't know if the problem was there before that or not.. I guess I could check the older versions of the board, but either way doesn't really matter now I guess.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply