Page 2 of 2

Re: Advice on fixing an Amiga 500+

Posted: Sun Jun 02, 2019 1:49 pm
by Steve
Maximilian wrote:
Sun Jun 02, 2019 12:45 pm
Steve wrote:
Sat Jun 01, 2019 8:31 pm
Today on this lovely Saturday I decided to give it another crack.
The coating looks very good indeed, what did you use?
https://uk.farnell.com/chemtronics/cw25 ... dp/1663186

It's really good stuff. I had already covered the back side of the logic IC and wondered how it would come off for me to add the trace wires. Luckily on contact with the solderion iron it basically turns to powder and you brush it off. Expensive stuff but damn it's good :)

Re: Advice on fixing an Amiga 500+

Posted: Wed Jun 05, 2019 7:29 pm
by Steve
Update: FIXED! :D

After re-soldering some of the through hole solder dots (completely cleaning up, sucking out with wick, fresh solder in) And removing the long patch cable I previously installed from the ROM, the machine came to life :) I've put my epoxy over my patch trace wires to keep them safe, since all my traces were on the back it has turned out to be a very neat job.

I will be selling this machine once I put it back together, I've also upgraded the rom to 3.1.4 (since originally I thought the rom could have been faulty)
IMG_20190605_192142.jpg
IMG_20190605_192142.jpg (378.96 KiB) Viewed 615 times
IMG_20190605_183915.jpg
IMG_20190605_183915.jpg (97.97 KiB) Viewed 615 times

Re: Advice on fixing an Amiga 500+

Posted: Thu Jun 06, 2019 2:02 am
by Maximilian
+1 for not giving up!

Looks like a job well done!