DEVPAC 68881 required error

News,announcements,programming,fixes,game patches & discussions.

Moderator: troed

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

DEVPAC 68881 required error

Post by exxos » Wed Jun 19, 2019 11:16 pm

So my first try to compile my own GB6 ASM code isn't going well..

In the code it has..

OPT P=68040,P=68881
OPT O+

Fair enough..

But trying to compile I get a error...
huh.jpg
huh.jpg (63.53 KiB) Viewed 556 times

Do I need a FPU lib or something for it to compile ?
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

czietz
Posts: 115
Joined: Sun Jan 14, 2018 1:02 pm

Re: DEVPAC 68881 required error

Post by czietz » Thu Jun 20, 2019 6:55 am

Not that I have much experience with Devpac, but the syntax of the OPT P line should be different according to the manual:
devpac.png
devpac.png (35.9 KiB) Viewed 537 times

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: DEVPAC 68881 required error

Post by exxos » Thu Jun 20, 2019 9:49 am

Thanks, tried it, but still get the same error message :(
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

czietz
Posts: 115
Joined: Sun Jan 14, 2018 1:02 pm

Re: DEVPAC 68881 required error

Post by czietz » Thu Jun 20, 2019 9:52 am

What is the statement in line 423, then?

EDIT: Also I wonder if the combination of 68040/68881 is even allowed in Devpac, considering that the 68040 has a builtin FPU.

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: DEVPAC 68881 required error

Post by exxos » Thu Jun 20, 2019 10:06 am

czietz wrote:
Thu Jun 20, 2019 9:52 am
What is the statement in line 423, then?

EDIT: Also I wonder if the combination of 68040/68881 is even allowed in Devpac, considering that the 68040 has a builtin FPU.
Capture.JPG
Capture.JPG (123.28 KiB) Viewed 515 times

Its the ASM routines for GB6.. d.m.l wrote them, and of course it compiled.. So I don't think the source is wrong, unless he used some other compiler. Will have to see if I can find his email address and ask him about it.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1804
Joined: Fri Mar 23, 2018 8:22 pm

Re: DEVPAC 68881 required error

Post by PhilC » Thu Jun 20, 2019 10:11 am

Could it be that to compile the code, you need to have an FPU of the correct type installed in the computer?
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: DEVPAC 68881 required error

Post by exxos » Thu Jun 20, 2019 10:15 am

PhilC wrote:
Thu Jun 20, 2019 10:11 am
Could it be that to compile the code, you need to have an FPU of the correct type installed in the computer?
I tried compiling in Hatari , as a 030 with FPU already.. I thought maybe steem was being moody, but have same issue on Hatari.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

czietz
Posts: 115
Joined: Sun Jan 14, 2018 1:02 pm

Re: DEVPAC 68881 required error

Post by czietz » Thu Jun 20, 2019 10:30 am

OK, so the assembler needs a FPU on the development machine to handle floating point constants. WTF! They could have easily done that entirely in software. I know why I don't like Devpac much.

The particular line...
FMOVE.S #1.001,FP0
... compiles fine under Hatari with 68030 + FPU, if I use the 68030 version of the Devpac assembler, i.e., GEN030.TTP. I guess the regular 68000 version does not recognize the FPU if interfaced to a 68030.

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: DEVPAC 68881 required error

Post by exxos » Thu Jun 20, 2019 10:46 am

ah so there is a 030.ttp in there, but just swapping the files gives another problem..

Capture.JPG
Capture.JPG (43.51 KiB) Viewed 503 times

So back to Hatari then... see what happens...


EDIT:

Ah here we go then...
Capture.JPG
Capture.JPG (33.14 KiB) Viewed 503 times

So this file should match the GB6 asm file... lets see...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: DEVPAC 68881 required error

Post by exxos » Thu Jun 20, 2019 11:31 am

So the only file it compiles to anything similar is "Lattice Linkable".. But the end of the file is different :shrug:

1.JPG
1.JPG (181.31 KiB) Viewed 496 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “SOFTWARE PROGRAMMING & DISCUSSION”