DEVPAC 68881 required error

News,announcements,programming,fixes,game patches & discussions.

Moderator: troed

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: DEVPAC 68881 required error

Post by exxos » Thu Jun 20, 2019 11:37 am

OK I figured it out.. Seems to be I have to put NONE for debug symbols..

Capture.JPG
Capture.JPG (59.63 KiB) Viewed 372 times

Now the files match 100% :D :D

Its taken so long to figure the compiler out that I can't remember why I wanted to do all this in the first place :lol:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

mrbombermillzy
Posts: 73
Joined: Sun Jun 03, 2018 7:37 pm

Re: DEVPAC 68881 required error

Post by mrbombermillzy » Thu Jun 20, 2019 5:28 pm

czietz wrote:
Thu Jun 20, 2019 9:52 am
EDIT: Also I wonder if the combination of 68040/68881 is even allowed in Devpac, considering that the 68040 has a builtin FPU.
I've got a feeling that what czietz touched on here may cause some problems due to the 040 having a subset of, or emulating some 68881/2 commands.

Watch out! ;)

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: DEVPAC 68881 required error

Post by exxos » Thu Jun 20, 2019 5:35 pm

No idea, d.m.l wrote the code. It works on the Falcon (030) and CT60 with FPU's. Though its the same code as used in GB6 for the past 3 years and not aware of any issues yet.. I know doug wrote a lot of FPU routines and let me decide which to use. So I went with the most compatible ones, so likely it could already be sorted out.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

mikro
Posts: 159
Joined: Mon Aug 28, 2017 11:22 pm

Re: DEVPAC 68881 required error

Post by mikro » Fri Jun 21, 2019 6:34 am

czietz wrote:
Thu Jun 20, 2019 9:52 am
EDIT: Also I wonder if the combination of 68040/68881 is even allowed in Devpac, considering that the 68040 has a builtin FPU.
I guess it's harmless - there isn't a 68881/2 instruction which isn't allowed on the 040 (natively or via emulation). IIRC there is only one or two opcodes which have the same syntax but are different on 030 and 040/060 CPUs and none of them is an FPU instruction.

Post Reply

Return to “SOFTWARE PROGRAMMING & DISCUSSION”