Page 2 of 2

Re: EMUTOS & ULTRASATAN & SEC BOOSTER CRASHES

Posted: Tue Jan 21, 2020 8:31 pm
by BlankVector
This is once again the proof that EmuTOS rulez for debugging hardware :mrgreen:
Thanks to everyone involved.

Re: EMUTOS & ULTRASATAN & SEC BOOSTER CRASHES

Posted: Tue Jan 21, 2020 8:36 pm
by exxos
BlankVector wrote:
Tue Jan 21, 2020 8:31 pm
This is once again the proof that EmuTOS rulez for debugging hardware :mrgreen:
:bravo:


So does anyone know whats going on at address FA2E26 in the diagnostic cart ? I keep cranking the speeds of my booster hence keep running into new errors ;)


EDIT:
EMUTOS and TOS206 doesn't even try to start, but TOS104 mostly tries, or row of bombs.

EDIT2:
On power up TOS104 accesses the floppy (I hear it spin up) then I get 3 bombs... if I reset I get a row of bombs. Happens each time.

Re: EMUTOS & ULTRASATAN & SEC BOOSTER CRASHES

Posted: Tue Jan 21, 2020 9:02 pm
by czietz
exxos wrote:
Tue Jan 21, 2020 8:36 pm
So does anyone know whats going on at address FA2E26 in the diagnostic cart ?
Nothing spectacular or crash-worthy: Just preparing a video counter access that will happen a bit later. (EDIT: Phrased wrong before: even though it's the video counter, the registers are not in the Shifter but in the MMU.)
fa2e26.png
fa2e26.png (99.5 KiB) Viewed 934 times

Re: EMUTOS & ULTRASATAN & SEC BOOSTER CRASHES

Posted: Tue Jan 21, 2020 9:08 pm
by exxos
Thanks.. I think that time it was a iffy connection on my board :roll:

Still the same problem though that TOS104 tries to boot, but get 3 bombs. just no way to really know what is tripping up now.