Page 1 of 2

Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Fri Jul 06, 2018 8:41 am
by Gargoyle
Hi guys, a question mainly for Peter! I have been trying to get Turrican 2 (also the first Turrican game as well) working on my 4mb STE, TOS 1.62UK setup with CosmosEx unit using either SD HDD, or translated drive and have had no luck whatsoever in getting either of them to work correctly. No floppy image works either, no menu disks etc., I have tried several.

Every time I start a new game, then push upwards to jump, Brent explodes and I am taken back to the main title screen. Over and over I try, even with different save states made near the start, HD Driver, ICD (haven't tried your own driver yet though I admit), I try booting by just booting up CosmosEx auto prog with an .ST disk image I made up (which is handy, as you still can get translated drive working to use Drive P, but can free up low ram, and I have gotten some more games working that way). But still after all that, no luck.

What is your exact config. to get either of these games working? Is there any way you could ever patch it to work on the STE setup I describe?

Re: Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Fri Jul 06, 2018 9:37 am
by Petari
Translated drive is not enough compatible with normal TOS hard disk system. It should work with SD card as hard disk and usual drivers. In case of Seimet Hddriver problem is usually that it reserves too much RAM for buffers - especially if there is 4MB RAM.
And because you say that even menu disks work not, it may be HW problem. Age of machine, or bad STE DMA chip case ? Some games are more sensitive, and Turricans push ST to limit pretty much.
But it's worth to try my driver:
Get that image - write on SD card as image, then it will autoboot on Atari. You can add there Turricans easily as is TOS/DOS compatible.
To add that it was tested on STE, STs, Falcon . TOS version matters not, really.

Re: Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Fri Jul 06, 2018 11:18 am
by Gargoyle
Ok, I gave that a try! I burnt the image to a spare SD Card with Etcher, then booted in CosmosEx. It gets to desktop fine and I can open everything to view each folder. But, I load Turrican 2 and still the same problem. He explodes, every time I push upwards. If you move along and get to the pit area, it scrolls down ok when you fall (I tested this just in case activation of vertical scrolling was an issue?), so that was fine, but, joystick/jump up is when the issue happens.

I don't know how many other users are experiencing my exact same problem of course, but a couple of people on the facebook Atari ST and STe users group are having issues trying to get any form of it running too. Both with STE's, one with TOS 1.62 and one with TOS 2.06, 4mb ram each. Still problems, one person has bombing and unstable running with 2.06 apparently. I'm trying to verify if one person can get your 1gb image working with T2 with his 1.62UK 4mb setup and actually play it. I actually remember trying this with my STFM, TOS 1.02UK and it happened with that one too (the jump/explode problem). So I don't know, totally true that it definitely pushed the ST to it's absolute limit, but maybe this game is worth revisiting, just in case anything more can be done to fix/patch it further? A shame for me currently because this is a great game (all time favourite!).

Re: Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Fri Jul 06, 2018 2:11 pm
by Petari
I checked it again on my Mega STE and Falcon - it is over 6 years old now. Could not check on my STE because it is dead currently - so, your STE is in better condition than mine. But not flawless. Ah, both Turricans worked well on both - Falcon and Mega STE. And if it works on Mega STE it must work on STE too. TOS versions, RAM size are not relevant. Min 1MB and it works.
"patch it further?" - it is patched as much needs. You can not patch SW to work on bad HW. Your STE is almost 30 years old, so you can do following:
Bring to someone to fix it. Buy another STE. Play what works, until it will work not anymore - and that's what happens sooner or later.
I took time to check it, I hope that was not waste, and you will understand what I explained.

Re: Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Fri Jul 06, 2018 6:40 pm
by stephen_usher
I'm trying to understand what you mean by "he explodes".

From your description the character in the game explodes and takes you back to the start or menu.

From what I read of Petari's replies it seems that he thinks that the program bombs and crashes.

If the weather is cool enough for me to go up to my hobby room this weekend I'll try to download the games and try them on my TT (the STE is in the loft and too hot to go into at the moment.

Re: Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Fri Jul 06, 2018 8:27 pm
by stephen_usher
OK, tested both games on the TT:

Turrican: Crashes with four bombs after (mostly) displaying the "Turrican" banner graphics after the publisher splash screen.

Turrican II: Runs but status panel at bottom of the screen is corrupted. The character did explode quite often but that's probably because I'm absolutely terrible at platform games.

I'll see if the weather is cool enough in the morning for me to get the STE down from the loft (and put a few other things up there).

Re: Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Fri Jul 06, 2018 11:10 pm
by Gargoyle
Stephen, yes you read correctly the actual character/player sprite blows up and he effectively dies and you go back to the title screen, this is right after you push the joystick upwards (well in my case, gamepad, as I have an 8Bitdo gamepad connected to my CosmosEx). It happens with Turrican 1 as well as Turrican 2. Very strange error, it doesn't happen with any other HDD adapted game I've tried from what I recall, not an error like that. It would be great if you can test it out with your STE when you have the time, the HDD adapted version of Peter's just to see if you get this exact same problem as mine.

Peter I know what you mean re. ageing hardware, luckily I do have 2 other STE's here of my brother's I could test sometime (one even has the 32mhz mod!). I do wonder if I should try Chris's DMA fix with my own STE, sometime I'll buy his kit as I'm pretty sure I am hearing those noises you get with that issue. Also apparently having a much cleaner power supply (like connect an ATX power supply unit directly to STE) can help with the noise issue too, my brother does that with his 32mhz STE. Thank you for taking the time to check though.

Obviously an emulator is always there if I want it, just be nice having it on my actual STE. If absolute worst comes to worst I could try my original copies if they still work, lol but I'm not that desperate to plug in a disk drive just for that currently!

Re: Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Fri Jul 06, 2018 11:32 pm
by Neffers
This may not be directly related to your issue, but, pressing ESC on Turrican games basically nukes you and returns you to the main menu (from memory). Could it be some form of conflict? I really do not know the ins and outs, but maybe that games code with your config and upgrades is causing something funky to happen - it's rare that Esc is used in games, can you think of any others that do so you could try my silly theory (because I can't).

Re: Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Sat Jul 07, 2018 12:39 am
by Gargoyle
That's a good point re. the Escape key Neffers, in fact I think ages back I did consider that as one possibility (but abandoned trying this game for a while, since I had so many others I wanted to play - and have already completed T2 with no cheats more than 20 times anyway, ahem!). I do wonder if you're onto something there, hard to say though.

So I tried a few more things, CosmosEx can map joystick functions to a USB keyboard via IKBD. So I tested that out, to see whether pushing upwards on my keyboard (to trigger joystick up) did the same thing and it still does it. So you die straight away as if you have hit the escape key in-game, even with IKBD on.

This even happens with D-Bug's HDD adapted version of Turrican 1. So now this is probably ruling out anything to do with Peter's adaptations whatsoever!

The trouble is, I have no idea how to work out whether "joystick up" using CosmosEx also silently triggers the escape key in Turrican 1 or 2 somehow. When I am at the desktop, I hit the Esc key and it clicks as normal. When I push the joystick up, or hit arrow key up when IKBD mapping is activated, theres no click at desktop. So if CosmosEx is somehow producing an Esc key trigger, its not exactly very direct/apparent. Either that or, something else is triggering an exit game routine when you push joy up.

I don't know, I might have to put this on the too-hard pile for a while, like I said not a biggie lol. Back to STOS programming!

Re: Turrican 1&2 not working with 4mb STE, TOS 1.62UK & CosmosEx

Posted: Sat Jul 07, 2018 1:21 am
by stephen_usher
OK. I got my STE down from the loft and both the games work from the UltraSATAN though Turrican does show a few display glitches as it's loading the level at the bottom of the screen.

I've noticed from this that on the TT the developer splash screen is wrong and has a colour palette issue in both games. Turrican doesn't show the game intro splash screen before going into the on where it asks to press the fire button, at which point it crashes with 4 bombs after drawing the top image on the screen.