A little bit of 8 Bit: 65XE upgrade to 128k RAM

Any 8bit repairs, images, cool things, upgrades etc.
ChaoticBiker
Posts: 5
Joined: Mon Jun 08, 2020 2:24 pm

Re: A little bit of 8 Bit: 65XE upgrade to 128k RAM

Post by ChaoticBiker » Wed Jun 10, 2020 1:37 pm

Thank you all for responding to this.
As another update - well it wasn't the +5v that was causing the problem.
It was the Mitsumi 56-3217 keyboard mylar that apparently decided it had enough of being pulled in and out of the slot.
The joys of working with >30 year old electornics :D
Also this is now the 3rd Atari of mine where the power led stopeed working (suspected for same reason - worn/cracked mylar)

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2499
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: A little bit of 8 Bit: 65XE upgrade to 128k RAM

Post by rubber_jonnie » Wed Jun 10, 2020 2:33 pm

Another fault diagnosed :)
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

JGroth
Posts: 1
Joined: Fri Jun 26, 2020 7:32 am

Re: A little bit of 8 Bit: 65XE upgrade to 128k RAM

Post by JGroth » Fri Jun 26, 2020 7:48 am

tfhh wrote:
Thu Aug 31, 2017 12:26 pm

Code: Select all

CHIP    XE_320k    GAL16V8    SIMPLE_MODE

A14    A15   pb2   pb3      pb4      cas     pb6    pb7  mode  GND
mhalt  ra8   map   casbank  casmain  fa_14   fa_15  pb5  phi2  VCC

 fa_15        = A15
              + A14 & pb3 & /pb4 & mode & mhalt
              + A14 & pb3 & /pb5 & mode & /mhalt;

 /fa_14       = /A14
              + /A15 & /pb2 & /pb4 & mode & mhalt
              + /A15 & /pb2 & /pb5 & mode & /mhalt;

 casmain      = /phi2
              + cas
              + /A15 & A14 & /pb4 & mode & mhalt
              + /A15 & A14 & /pb5 & mode & /mhalt;

 /casbank     = /A15 & A14 & phi2 & /pb4 & /cas & mode & mhalt
              + /A15 & A14 & phi2 & /pb5 & /cas & mode & /mhalt;

 /map         = pb4 & pb5 & /pb7;

 ra8          = /phi2 & pb6 & mode
              + phi2 & pb7 & mode;

The LS7495 must be placed at the positon of U35. The GAL - bent pin 7, 8, 9,12 and 13 up - will be placed in U34. Connect pin 7 of the GAL to pin 16 of PIA and pin 8 of the GAL to pin 17 of PIA. Pin 9 can be left open (expansion enabled) or closed by switch to ground to disabled the expansion. Pin 12 via 33 Ohm resistor to the pin 1´s of the 8 DRAMs (memory addressline A8) and pin 13 to the pin 6 of MMU. This pin must be also bended, so better is to desolder the MMU, fit it into a socket and replace it with pin 6 bend up.

I make several years ago an article for the ABBUC magazine no. 95. You can download it here, but the text is only in german - sorry.

Jurgen
Sorry to resurrect an old post but I'm curious on which 65XE motherboard this expansion works? I'm particularly puzzled by the connection between GAL pin 7 (PB6) and PIA pin 16 (PB6) as on my mother board that PIA pin isn't connected to anything. So what is that connection supposed to do?
I just wonder because I'm considering upgrading my 65XE using this. The motherboard I've got is a CO70067, exactly the same mother board used in a 130XE with 128k of memory.

Regards,
JGroth

User avatar
tfhh
Posts: 21
Joined: Sat Aug 26, 2017 5:31 pm
Location: Germany

Re: A little bit of 8 Bit: 65XE upgrade to 128k RAM

Post by tfhh » Fri Jun 26, 2020 9:11 am

Hi,

sorry beeing late to the party. I read you already fixed the problem ;)
ChaoticBiker wrote:
Wed Jun 10, 2020 1:37 pm
As another update - well it wasn't the +5v that was causing the problem.
It was the Mitsumi 56-3217 keyboard mylar that apparently decided it had enough of being pulled in and out of the slot.
The joys of working with >30 year old electornics :D
Also this is now the 3rd Atari of mine where the power led stopeed working (suspected for same reason - worn/cracked mylar)
Yes, these is "usual" with the XE keyboards. Don´t know if somebody point it out, but new (really new - not "NOS") mylars are availible from Retronics and some other sellers, just search at eBay for "atari membrane" and you should get it.

User avatar
tfhh
Posts: 21
Joined: Sat Aug 26, 2017 5:31 pm
Location: Germany

Re: A little bit of 8 Bit: 65XE upgrade to 128k RAM

Post by tfhh » Fri Jun 26, 2020 9:20 am

Hi,
JGroth wrote:
Fri Jun 26, 2020 7:48 am
Sorry to resurrect an old post but I'm curious on which 65XE motherboard this expansion works? I'm particularly puzzled by the connection between GAL pin 7 (PB6) and PIA pin 16 (PB6) as on my mother board that PIA pin isn't connected to anything. So what is that connection supposed to do?
I just wonder because I'm considering upgrading my 65XE using this. The motherboard I've got is a CO70067, exactly the same mother board used in a 130XE with 128k of memory.
This expansion worked that way in all XE versions where an unpopulated U35 is found. By default all XE models are possible, which have the places for 16 pieces of DRAM. Some rare XE mainboards have only one column with 8 DRAMs, these are models where "900XLF" is found on the solder side of the PCB and they have no ECI - only a cartridgeport.

Some XE mainboards have only 4 resp. 2 DRAMs in place, these are 4-Bit DRAMs. My solution would work here, too - but Atari didn´t include the location U35 on these mainboards. If you have such model, I can modify the GAL code, but you need then a 22V10 instead of a 16V8 and two more wires.

But, just to have say it, there are much easier ways to get 512 KB expansion memory based on SRAM instead of the DRAM expansions. Removal of the eight 4164 DRAMs at the 2nd bank, de-soldering/empy the holes, install new sockets, the 41256 DRAMs, a GAL... it´s a nice way to tinker around, sure, but more effective are SRAM based expansions today.

Post Reply

Return to “8 BIT CORNER”