2600 Composite mod

Any 8bit repairs, images, cool things, upgrades etc.
Post Reply
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 1258
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: 2600 Composite mod

Post by rubber_jonnie » Fri Apr 26, 2019 11:31 am

exxos wrote:
Fri Apr 26, 2019 11:27 am

Modulator causes a lot of interference, so you really have no choice but to remove it. It's one reason my design tapped directly into the TIA itself ( then every component after it relating to the video gets removed and replaced) .
Cool, makes sense to me, thanks.
Collector of old Atari things:
800XL + Ape Warp mod, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg) + Gotek, 1040STFM + Vortex ATOnce + Gotek, 1040STF long button floppy, 4160 STE with Gotek and ROM switcher, 4160STE with 32Mhz booster, ROM switcher and CosmosEx, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 7172
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 2600 Composite mod

Post by exxos » Fri Apr 26, 2019 11:59 am

Dinnertime now :lol:

IMG_4084.JPG
IMG_4084.JPG (110.73 KiB) Viewed 408 times

IMG_4085.JPG
IMG_4085.JPG (143.78 KiB) Viewed 408 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7172
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 2600 Composite mod

Post by exxos » Fri Apr 26, 2019 12:46 pm

Well we have video, kind of :lol:

IMG_4086.JPG
IMG_4086.JPG (117.4 KiB) Viewed 405 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7172
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 2600 Composite mod

Post by exxos » Fri Apr 26, 2019 12:52 pm

Okay so that resistor I wasn't sure was needed or not, is actually needed then :lol:

2.JPG
2.JPG (157.3 KiB) Viewed 404 times

IMG_4087.JPG
IMG_4087.JPG (143.68 KiB) Viewed 404 times

Now to start dismantling the motherboard video circuit to rule out all this interference, hopefully..


EDIT:

Back to pole position as my "test game"..

IMG_4089.JPG
IMG_4089.JPG (213.6 KiB) Viewed 403 times
IMG_4090.JPG
IMG_4090.JPG (173.74 KiB) Viewed 403 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7172
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 2600 Composite mod

Post by exxos » Fri Apr 26, 2019 1:52 pm

So this seems to be picking up a lot of interference somehow, somewhere... But I'm not really sure of this interference is a problem with my monitor or not, as I see interference issues when my ST is connected..

So really it needs other people trying this out to see what video quality they get ;)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7172
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 2600 Composite mod

Post by exxos » Fri Apr 26, 2019 2:16 pm

OK so, added the caps on the bottom... :lol:

oops.jpg
oops.jpg (105.61 KiB) Viewed 399 times

Picture quality has now dramatically improved..

IMG_4099.JPG
IMG_4099.JPG (152.6 KiB) Viewed 399 times
IMG_4100.JPG
IMG_4100.JPG (175.41 KiB) Viewed 399 times

I am basically at the point I was originally,Where the black seems too bright, but if I reduce the brightness level, obviously the colours go darker as well, and then I think it is too dark overall so there does not really seem to be a solution for this :roll:

I will start probing about to see if I can increase it any better...Though I think some of the vertical banding on the blue, is actually my monitor...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 1258
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: 2600 Composite mod

Post by rubber_jonnie » Fri Apr 26, 2019 2:25 pm

exxos wrote:
Fri Apr 26, 2019 1:52 pm
So this seems to be picking up a lot of interference somehow, somewhere... But I'm not really sure of this interference is a problem with my monitor or not, as I see interference issues when my ST is connected..

So really it needs other people trying this out to see what video quality they get ;)
My own comp mod has some interference too, not dissimilar to what you see, even with the tin back on.

Will get it done on my other 2600, see what comes out. Have you tried yours with the shield back on?
Collector of old Atari things:
800XL + Ape Warp mod, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg) + Gotek, 1040STFM + Vortex ATOnce + Gotek, 1040STF long button floppy, 4160 STE with Gotek and ROM switcher, 4160STE with 32Mhz booster, ROM switcher and CosmosEx, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 7172
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 2600 Composite mod

Post by exxos » Fri Apr 26, 2019 2:30 pm

rubber_jonnie wrote:
Fri Apr 26, 2019 2:25 pm
Will get it done on my other 2600, see what comes out. Have you tried yours with the shield back on?
Not yet, it may well help, im just trying to improve the colour.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7172
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 2600 Composite mod

Post by exxos » Fri Apr 26, 2019 3:28 pm

My findings so far...

Grounding the oscillator seems to help tiny bit with colour and interference..

I also have a pot which is actually set to 660R In series with a 100pf (2x47pf) capacitors to ground.. This is odd as it seems be acting as a filter, as there seems to be a sweet spot when the black is at its most black point, but if you turn the black down too much, interference on the blue really starts to come back and starts to lose sync etc.

I'm now thinking towards cutting the MHz feed to the TIA and adding in some 33R to see the interference reduces or not...

IMG_4101.JPG
IMG_4101.JPG (312.43 KiB) Viewed 391 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1552
Joined: Fri Mar 23, 2018 8:22 pm

Re: 2600 Composite mod

Post by PhilC » Fri Apr 26, 2019 3:36 pm

Looks pretty cleaar as it is though
If it ain't broke, test it to Destruction.

Post Reply