Page 1 of 3

STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 4:38 pm
by PaulJ
Starting a upgrade of a stock mega4 I pick up for $150.00 with no keyboard. I plan on building some enhancements of my own and the expansion slot seems to be just what the doctor ordered. So at this point I have changed the 5 sips that are 4.7 and 10k as the doctor has directed. I have also built the mega fast rom card and the clock un-fu*k board with GAL.

Issues so far.

The previous owner built some 32 to 28 pin rom adaptors so he could run TOS 1.4 in eprom. This is ok but he used the big header pins that basically stretched the socket connections which make the sockets a bucket of loose connections.

Exxos's clock un-fu*k it clock board does not have enough room, the power supply is infringing on its space. Its not a lot so I will grind or nibble the excess power supply area off so it can be seated without impacting the clock un-fu*k it board. I have run the card installed with the supply off to the side and it works fine.
UG_1000.jpg
UG_1000.jpg (321.18 KiB) Viewed 1324 times
Heres a shoot of the prior upgrade for the roms that will hit the trash can.. Notice the size of the socket destroying pins in relation to the properly sized pins in the foreground. When I received the machine they were floating free in side along with the floppy drive. Its amazing there was no real damage other that the rom sockets and the floppy spacers. Floppy screws had fallen out.

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 4:42 pm
by PhilC
Will be reading with interest as I've got 2 Mega's that I've been playing with.

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 4:42 pm
by exxos
Yeah, those wider pins destroy sockets :(

The problem with the buffer board, which I did not realise until much later, I think it is down to revisions of the motherboard, where the shifter is located more to the left on some boards than others.. It could also be the PSU PCB itself could be fractionally larger on some machines than others.

I never looked into it much but it is only a problem in certain machines. I think the buffer PCB was actually low enough to miss the PSU anyway ? but I cannot remember if that was installing without a socket...

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 4:46 pm
by PaulJ
Just to document our starting point here is a bench6 run in this state without the Booster. Picture sucks but it much better on the screen. All the cutting has caused the artifacts. :(

UG_1002.jpg
UG_1002.jpg (124.01 KiB) Viewed 1318 times

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 4:51 pm
by PaulJ
exxos wrote:
Fri Nov 16, 2018 4:42 pm
Yeah, those wider pins destroy sockets :(

The problem with the buffer board, which I did not realise until much later, I think it is down to revisions of the motherboard, where the shifter is located more to the left on some boards than others.. It could also be the PSU PCB itself could be fractionally larger on some machines than others.

I never looked into it much but it is only a problem in certain machines. I think the buffer PCB was actually low enough to miss the PSU anyway ? but I cannot remember if that was installing without a socket...
Ya the buffer board tucks under the power supply board but the power supply board lands at chip levels and it tries to pop the shifter up out of the socket so theres some g10 there without traces so i'll remove enough to clean the chip.. I could soldered the shifter in but in this case I'm choosing to use the socket. :) :) :)

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 5:04 pm
by PaulJ
Next step is the painful one. I'm going to remove the 68k which means I'll clip all the 68k pins and remove one at a time with solder wick.. Rubber Jonnie's getting excited already.. no its not a doner board!! Rubber Jonnie, this is a keeper, you can keep your iron cold, just look at the quality caps.. the only thing missing is a QC passed sticker from Exxos. tell ya what.. I'll send them to ya when I replace them.
UG_1003.jpg
UG_1003.jpg (42.9 KiB) Viewed 1313 times

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 5:05 pm
by exxos
wow thats a new brand!

:WTF: :lolbig:

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 5:10 pm
by PaulJ
Forgottenmyname wrote:
Fri Nov 16, 2018 4:42 pm
Will be reading with interest as I've got 2 Mega's that I've been playing with.
Ya I have two also.. I like the form factor and the fan is quite. I also really like the expansion slot. So Exxos.. that daughter unfu*k cart by Atari that sits on top of the 68k. I plan to eliminate it as per your discussions concerning it. If I have issues I'll put it back in. Sound like a plan?

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 5:12 pm
by PaulJ
exxos wrote:
Fri Nov 16, 2018 5:05 pm
wow thats a new brand!

:WTF: :lolbig:
Yup machine has "Joe Master" caps. Doesn't get any better than that.. Probably means this was a master computer at some point in its life!!

Re: STOCK MEGA4 16MHZ V1.5 BOOSTER INSTALL

Posted: Fri Nov 16, 2018 5:14 pm
by PhilC
I've deleted that add-on too PaulJ, I've got a 2.2 booster in one of mine so far, buffer board still to do but seems ok.