C100167 MEGA ST REV 4

MEGA ST motherboards.
Post Reply
User avatar
exxos
Site Admin
Site Admin
Posts: 10396
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

C100167 MEGA ST REV 4

Post by exxos » Thu Jan 11, 2018 4:44 pm

Image
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2353
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: C100167 MEGA ST REV 4

Post by rubber_jonnie » Sat Oct 12, 2019 1:39 pm

My REV 4 showing the grubbiness on the PCB and the missing sound chip.
IMG_20191011_145311.jpg
IMG_20191011_145311.jpg (562.23 KiB) Viewed 2033 times
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1273
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: C100167 MEGA ST REV 4

Post by PaulJ » Sat Oct 12, 2019 2:14 pm

Jon, looks like the glitter is gone. :dizzy: Wonder what other issues it has?

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2353
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: C100167 MEGA ST REV 4

Post by rubber_jonnie » Wed Oct 16, 2019 7:15 pm

Former owner said he had problems with the Glitter, something I intend to rectify 😁

Once the RAM and Floppy are sorted, glitter is next. Sound chip is already done, but not tested.

I was hoping to get a KB wired up temporarily, but a problem with our central heating not working diverted my attention!
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2353
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: C100167 MEGA ST REV 4

Post by rubber_jonnie » Sat Oct 19, 2019 5:05 pm

Here's the after pic:

IMG_20191019_161452.jpg
IMG_20191019_161452.jpg (500.64 KiB) Viewed 1938 times

Glitter fitted, sound chip fitted, new floppy plug fitted and header fitted for new RTC power lead. Not to mention fixing the bent ROM pins!

Mostly running fine, got to run Gembench and see what's going on.

TOS says 2MB, Diag cart says 4MB, so that's odd, but otherwise much better than when it arrived.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

stephen_usher
Trusted Guru
Trusted Guru
Posts: 562
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: C100167 MEGA ST REV 4

Post by stephen_usher » Sat Oct 19, 2019 5:23 pm

:dualthumbup:
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

Post Reply

Return to “MEGA ST”