BOOSTER 2.2 REVISITED

Help & information about the V2.X series boosters.
User avatar
exxos
Site Admin
Site Admin
Posts: 7647
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: BOOSTER 2.2 REVISITED

Post by exxos » Mon Dec 10, 2018 5:41 pm

16MHz CPU working..

IMG_3683.JPG
IMG_3683.JPG (129.22 KiB) Viewed 895 times

Next up to get 16MHz ROM working...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7647
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: BOOSTER 2.2 REVISITED

Post by exxos » Mon Dec 10, 2018 6:44 pm

16MHz ROM access working :)

Next I need to build the new ROM board and get TOS206 running..

IMG_3684.JPG
IMG_3684.JPG (130.07 KiB) Viewed 888 times

The bars which hold the PCB are pretty high up off the heater, so the heat on the PCB is about 100C when the bed is 400C. So I put the PCB directly on the heater, now its about 200C. Solder melting fine now... just takes a long time to cool down on its own. At least the PCB oven has a fan to cool down quicker.. but at least its looking like I can solder these SMT sockets without melting them, so that's the main thing :)

IMG_3685.JPG
IMG_3685.JPG (120.94 KiB) Viewed 883 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7647
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: BOOSTER 2.2 REVISITED

Post by exxos » Mon Dec 10, 2018 8:52 pm

TOS104/206 decoding now in place and working at 16MHz :)

IMG_3686.JPG
IMG_3686.JPG (70.08 KiB) Viewed 873 times
IMG_3687.JPG
IMG_3687.JPG (555.43 KiB) Viewed 873 times

Next up I need to check this all works with blitter....
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7647
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: BOOSTER 2.2 REVISITED

Post by exxos » Mon Dec 10, 2018 10:08 pm

Blitter working :)

blitter.jpg
blitter.jpg (83.17 KiB) Viewed 854 times
16b.jpg
16b.jpg (99.03 KiB) Viewed 854 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7647
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: BOOSTER 2.2 REVISITED

Post by exxos » Tue Dec 11, 2018 3:16 pm

I am building 8 of the new ROM boards (thats all the PCBs I have) With the intention of them being sold with the booster.

I have hit a small brick wall in terms of the GAL's again :roll: (ran out of GALs!) . Currently even though pin 4 (powerdown) is configured as a IO pin, the chips do not function in the booster board. But I had this problem before anyway. I think my programmer is somehow enabling the powerdown feature even though it is not supposed to be. I was talking to Atmel support a few years ago about this problem, and they pretty much thought my programmer was causing the issue. So I have ordered a new programmer, to see if I have better luck.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7647
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: BOOSTER 2.2 REVISITED

Post by exxos » Wed Dec 12, 2018 9:35 pm

Only just got home, but new programmer waiting for me :)

I got the same one as Icky...

www.amazon.co.uk/gp/product/B07B985LBS

111.jpg
111.jpg (179.61 KiB) Viewed 801 times

Quick program of the ATF and the booster is working. So my old TOP3000 programmer doesn't seem to support the ATF properly it seems :roll:

Now to order a stock of the Atmel chips... :)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1727
Joined: Fri Mar 23, 2018 8:22 pm

Re: BOOSTER 2.2 REVISITED

Post by PhilC » Wed Dec 12, 2018 9:42 pm

Is that a TL86? If so it works really well and very easy.
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7647
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: BOOSTER 2.2 REVISITED

Post by exxos » Wed Dec 12, 2018 9:43 pm

Forgottenmyname wrote:
Wed Dec 12, 2018 9:42 pm
Is that a TL86? If so it works really well and very easy.
www.amazon.co.uk/gp/product/B07B985LBS
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1727
Joined: Fri Mar 23, 2018 8:22 pm

Re: BOOSTER 2.2 REVISITED

Post by PhilC » Wed Dec 12, 2018 9:44 pm

exxos wrote:
Wed Dec 12, 2018 9:43 pm
Forgottenmyname wrote:
Wed Dec 12, 2018 9:42 pm
Is that a TL86? If so it works really well and very easy.
www.amazon.co.uk/gp/product/B07B985LBS
Yes that's the one. Very happy with it here.
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7647
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: BOOSTER 2.2 REVISITED

Post by exxos » Thu Dec 13, 2018 3:49 pm

Been busy past couple of days building up some V2.3 booster and dualtos boards...

Waiting for the new GAL's & ROM's to arrive now (will be here tomorrow).

1.jpg
1.jpg (96.81 KiB) Viewed 765 times
2.jpg
2.jpg (167.22 KiB) Viewed 765 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply