V2.6 under design (supersedes the V2 .2) - project now abandoned

Help & information about the V2.2 booster.
User avatar
exxos
Site Admin
Posts: 1414
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.6 under design.

Post by exxos » Wed Dec 27, 2017 9:53 pm

Only just got home again, but had the idea to try my plug-in prototype STE booster into this problematic board..

IMG_2140.JPG
IMG_2140.JPG (119.32 KiB) Viewed 100 times

Lo and behold...

IMG_2141.JPG
IMG_2141.JPG (71.96 KiB) Viewed 100 times

It is still running down and just passed 31 ram test cycles..

So I think this is still the socket problems :roll:

It is difficult to test the connection in between CPU and the socket itself. I did try testing the power rails as there is more than one connection on the CPU, and this seemed fine. So would assume all the pins would be fine as well, but it seems not :roll: all the sockets I use previously all seem to be basically fine, so I doubt this would affect any kits currently on sale in my store such as the STE booster.. Problem with sockets only seems to be more recently when I ran out of sockets during the last batch of STE boosters.

I emailed the company who claims to have invented the PLCC socket in 1965 or something.. And ask them about this issue.. So far no reply.. But then again it could be due to the holiday break..

But I think it really does not matter, I think the conclusion is that much just forget totally using PLCC sockets for the processor at least. For older chips like the blitter etc, there is unlikely to be issues with those. I never really had problems with older chips and sockets of any kind as previously mentioned in my socket thread. But I think the time is here to totally avoid using them in any new booster builds..

... And this means yet again, I have to design yet another booster PCB before I can continue with this work any more :roll:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Maeke
Posts: 171
Joined: Thu Aug 17, 2017 3:09 pm

Re: V2.6 under design.

Post by Maeke » Thu Dec 28, 2017 8:44 am

This also means you'll have to use smt cpu, and thus probably sell the boosters with cpu presoldered as not everyone is skillfull enough to do it or have appropriate tools.
If i take too long to reply, sorry my cat is sleeping on my laps.

User avatar
exxos
Site Admin
Posts: 1414
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.6 under design.

Post by exxos » Thu Dec 28, 2017 1:40 pm

Maeke wrote:
Thu Dec 28, 2017 8:44 am
This also means you'll have to use smt cpu, and thus probably sell the boosters with cpu presoldered as not everyone is skillfull enough to do it or have appropriate tools.
The PLCC CPU can be solder direct to the board, but like you say, a lot of people wouldn't be able to solder this.. The problem is also, I do not have time to solder kits together either :roll:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Posts: 1414
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.6 under design.

Post by exxos » Thu Dec 28, 2017 1:47 pm

I managed to get the GAL into the circuit today. But I am having problems getting it running at 16Mhz. Everything looks fine signal wise, so I'm not sure what is going on here. It is all stable at 8 MHz. I think it may be an issue to do with /DTACK arriving fractionally too early again :roll:

I think on the original the 2.2 design the signals are cleaned up and actually slightly harder to drive than this new circuit which is actually altering the timings just enough for it not to function. On my the 2.5 design, I had to re-sync /DTACK by the PLD in order for it to work at all. I cannot do this with the current GALs or design :( so I think I'm just going to abandon this series totally now.

Originally I thought it will be relatively straightforward and simple to create a lower cost V2.2 booster design where I could produce it in lower quantities. Considering this is turned into a total nightmare, I think it is just better to abandon this design totally and move on with the v2.5 design is listed here.

viewtopic.php?f=7&t=45

With that design I use a larger PLD, where I rooted a lot of signals via the PLD so I have better control of timings and can fix potential errors. There is honestly no use in trying to fix this current design, when the fixes basically to use larger PLD, which I've already started in another V2 variation.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
IngoQ
Posts: 395
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: V2.6 under design.

Post by IngoQ » Thu Dec 28, 2017 5:43 pm

exxos wrote:
Thu Dec 28, 2017 1:40 pm
The problem is also, I do not have time to solder kids together either :roll:
New hobby of yours? :mrgreen:

Sorry, couldn't resist ;)
Ingo :geek:

“Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.” - Antoine de Saint-Exupéry

User avatar
exxos
Site Admin
Posts: 1414
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.6 under design.

Post by exxos » Thu Dec 28, 2017 5:52 pm

IngoQ wrote:
Thu Dec 28, 2017 5:43 pm
New hobby of yours? :mrgreen:

Sorry, couldn't resist ;)
ahh, voice recognition doesn't always get it right, and I don't always notice :lol:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Posts: 1414
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.6 under design.

Post by exxos » Thu Dec 28, 2017 6:56 pm

Project abandoned.

As mentioned previously, I am abandoning the 2.6 design altogether and concentrating on the 2.5 design is stated in the thread below.

I am also officially discontinuing the 2.2 design also.

viewtopic.php?f=7&t=45

This topic is now locked as there will be no more posts relating to this design.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Locked