V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Help & information about the V2.X series boosters.
User avatar
rpineau
Site Admin
Site Admin
Posts: 491
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by rpineau » Tue Jan 08, 2019 11:19 pm

The blitter access the ROM.
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Wed Jan 09, 2019 5:18 pm

Had a thought just, it shouldn't matter about LDS,LDS,RW being isolated because the CPU has given up the bus anyway... Unless I'm missing something ?
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

BlankVector
Posts: 50
Joined: Fri Sep 15, 2017 10:51 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by BlankVector » Wed Jan 09, 2019 5:48 pm

exxos wrote:
Tue Jan 08, 2019 10:04 pm
Hey! Yes, but we both made some progress...
Oh, good news! This was a weird problem.
Feel free to ask if you have another strange problem, EmuTOS with debug traces can be very useful to debug things.
Subscribe to my Vretrocomputing channel on YouTube and Facebook. Latest video: Emulators.

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Wed Jan 09, 2019 6:13 pm

BlankVector wrote:
Wed Jan 09, 2019 5:48 pm
exxos wrote:
Tue Jan 08, 2019 10:04 pm
Hey! Yes, but we both made some progress...
Oh, good news! This was a weird problem.
Feel free to ask if you have another strange problem, EmuTOS with debug traces can be very useful to debug things.
Actually still have same problem :cry:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

BlankVector
Posts: 50
Joined: Fri Sep 15, 2017 10:51 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by BlankVector » Wed Jan 09, 2019 9:22 pm

exxos wrote:
Wed Jan 09, 2019 6:13 pm
Actually still have same problem :cry:
Oh. So please start trying EMUTOSUK.PRG as I advised to see what happens.
Subscribe to my Vretrocomputing channel on YouTube and Facebook. Latest video: Emulators.

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Wed Jan 09, 2019 9:31 pm

BlankVector wrote:
Wed Jan 09, 2019 9:22 pm
Oh. So please start trying EMUTOSUK.PRG as I advised to see what happens.
OK will do that now and see what happens...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Wed Jan 09, 2019 9:36 pm

exxos wrote:
Wed Jan 09, 2019 9:31 pm
BlankVector wrote:
Wed Jan 09, 2019 9:22 pm
Oh. So please start trying EMUTOSUK.PRG as I advised to see what happens.
OK will do that now and see what happens...
I just get this after loading the PRG.. nothing else..

IMG_3747.JPG
IMG_3747.JPG (104.43 KiB) Viewed 665 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

BlankVector
Posts: 50
Joined: Fri Sep 15, 2017 10:51 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by BlankVector » Wed Jan 09, 2019 10:14 pm

exxos wrote:
Wed Jan 09, 2019 9:36 pm
I just get this after loading the PRG.. nothing else..
Oh. That's very unexpected.
Did you see the EmuTOS welcome screen before the crash?
Note that some AUTO/ACC programs may not be compatible with EmuTOS. Be sure to press Control (just once) at the welcome screen to avoid loading any AUTO/ACC program, hence avoiding trouble.
Subscribe to my Vretrocomputing channel on YouTube and Facebook. Latest video: Emulators.

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Wed Jan 09, 2019 10:25 pm

BlankVector wrote:
Wed Jan 09, 2019 10:14 pm
Did you see the EmuTOS welcome screen before the crash?
Nope, nothing, just white screen while loading PRG, then that error dump. What is at that address ?? Says undefined in the Atari memory map docs...
BlankVector wrote:
Wed Jan 09, 2019 10:14 pm
Note that some AUTO/ACC programs may not be compatible with EmuTOS. Be sure to press Control (just once) at the welcome screen to avoid loading any AUTO/ACC program, hence avoiding trouble.
Blank floppy with TOS104 loaded from ROM... Only emutos on the floppy nothing else at all.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

BlankVector
Posts: 50
Joined: Fri Sep 15, 2017 10:51 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by BlankVector » Wed Jan 09, 2019 10:38 pm

exxos wrote:
Wed Jan 09, 2019 10:25 pm
Blank floppy with TOS104 loaded from ROM... Only emutos on the floppy nothing else at all.
I have just tested the very same setup with Hatari and it works fine.
It also worked fine on my real STe (TOS 1.62 + EMUTOSFR.PRG)

How can it fail for you??
Maybe CPU, RAM, or other hardware issue??

PS: About the strange address, I suspect a jump to a bogus address (wrong RAM, buffer overflow...), then execution of a bogus instruction.
Subscribe to my Vretrocomputing channel on YouTube and Facebook. Latest video: Emulators.

Post Reply

Return to “ST 16MHz V2.X SERIES BOOSTERS”