CURRENT PROTOTYPE STATUS (SEC 64MHz 68000)

Information and news about the 68SEC000 64MHz booster.
User avatar
PhilC
Moderator
Moderator
Posts: 2883
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC » Fri Jan 25, 2019 4:36 pm

Well good luck then. Just ordered myself some Atmel Gals as my PAK still doesn't work and I know everything else on it does.

Hope you have better luck that I have so far.
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 10378
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jan 25, 2019 7:20 pm

Now to see if the PLD is found.. then onto doing some simple test firmware (pinout is different than last build so have to do some tweaked firmware :roll: )

IMG_3756.JPG
IMG_3756.JPG (144.56 KiB) Viewed 833 times



.. and some capacitor soldering voodoo...

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 10378
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jan 25, 2019 9:40 pm

:cheer: :cheer: :cheer: :cheer: :cheer: :cheer: :cheer: :cheer: :cheer:

40MHz this test.. 40MHz CPU & 40MHZ Fast-rom with TOS206 :D :D

40mhz.jpg
40mhz.jpg (111 KiB) Viewed 817 times

Now to bring back up 50MHz speeds.....
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 2883
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC » Fri Jan 25, 2019 9:48 pm

Looking great. Isn't that already faster than the 40mhz v1.5 ste booster that I have? Looking forward to seeing 50mhz
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 10378
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jan 25, 2019 9:51 pm

Forgottenmyname wrote:
Fri Jan 25, 2019 9:48 pm
Looking great. Isn't that already faster than the 40mhz v1.5 ste booster that I have? Looking forward to seeing 50mhz
Its probably a bit faster yes. Though this isn't running with the blitter, so its not exactly a fair comparison to the STE booster speeds on this benchmark... Will add the blitter and re-test once I have 50MHz running again.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 2883
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC » Fri Jan 25, 2019 10:01 pm

And once you're finished I can break it by putting it in my Mega :lol:
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 10378
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jan 25, 2019 10:19 pm

Oddly (again) TOS104 works at 50MHz but TOS206 does not...

.. and yet, TOS206 works at 40MHz.. bizzare...

Also my highest score of 506% on int-div!

50.jpg
50.jpg (124.61 KiB) Viewed 800 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 10378
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jan 25, 2019 11:04 pm

Not been able to figure out TOS206 not working at 50MHz, but some progress made at least today!

Oddly I still get that I7 bus error thing with the diagnostic cartridge :shrug:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 2081
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by Icky » Fri Jan 25, 2019 11:17 pm

exxos wrote:
Fri Jan 25, 2019 11:04 pm
Not been able to figure out TOS206 not working at 50MHz, but some progress made at least today!

Oddly I still get that I7 bus error thing with the diagnostic cartridge :shrug:
Keep up the good work that elusive stable 50MHz will be there soon.

User avatar
exxos
Site Admin
Site Admin
Posts: 10378
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jan 25, 2019 11:25 pm

I don't get the I7 error when running 8MHz...

I wonder if when the CPU sees BERR from the GLUE, it does whatever it normally does to fast, then re-reads BERR and locks up totally.. Or for some reason ST_DTACK is still low when GLUE issues BERR and it confuses the CPU... But that would be tricky to figure out.. I guess I will have to read up on how BERR all works again..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “SEC 64MHZ BOOSTER”