V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Help & information about the V2.X series boosters.
User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Fri Jun 14, 2019 10:00 pm

Progress :)

Oddly the original SEC worked fine with the blitter.. and yet this new SEC version is basically the same, only didn't play nice with the blitter.

So I added a CLK8 delay to BR, and then it loaded GB6 but did this...

IMG_4335.JPG
IMG_4335.JPG (66.83 KiB) Viewed 539 times

But it was actually repeatable that GB6 did load each time, but it was the graphics side which was going wonky...

So then I added another CLK8 delay to ST_BG... and...

IMG_4337.JPG
IMG_4337.JPG (110 KiB) Viewed 539 times

I dare not turn it off in case it does not turn back on again :lol:


Current setup..

IMG_4336.JPG
IMG_4336.JPG (150.48 KiB) Viewed 539 times

So oddly the bus grant needed some delays, when in all my testing on the previous booster did not need this.. Bizarre... I need to look into this some more...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Tue Jun 18, 2019 9:07 pm

I have been running the SEC at 50MHz as much as possible the past days.. it seems to get around 25 passes then 2 bombs to desktop. I've repeated this a few times now. I think the SEC is overheating after a while. Oddly the 50MHz osc is getting rather hot as well. So earlier I put in a 40MHz osc (doesn't get warm at all) and its just passed loop 33. So run time wise, its been going a bit longer than 50MHz.

My previous booster could run all day, so I think its likely the SEC will need some cooling if running at 50MHz. Of course not all CPU's are going to overclock as good as others. I will keep doing tests over the next few days, and of course add a heatsink onto the CPU and re-test at 50MHz.

At 40Mhz.. I'm taking the shifter can as ambient temp, 28c.. the CPU is at 38c at the top, and 33c at the bottom (as looking at it on the motherboard) :shrug:

EDIT:

It died again, I didn't see the results for a while, but it easily passed 40 loops. So its ran a lot longer than before, almost double I guess... heatsink time...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1809
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC » Tue Jun 18, 2019 10:07 pm

Sorry, I've forgotten by what was the original speed of the CPU but regardless of speed, it's an achievement to make any stable kind of increase on a chip as old as a 68000.
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Tue Jun 18, 2019 10:20 pm

PhilC wrote:
Tue Jun 18, 2019 10:07 pm
Sorry, I've forgotten by what was the original speed of the CPU but regardless of speed, it's an achievement to make any stable kind of increase on a chip as old as a 68000.
Original was 8MHz... The SEC has pretty much always run at 50MHz. The SEC itself says 20MHz on it.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Tue Jun 18, 2019 10:21 pm

I think I have 2.2K resistors on this motherboard (I put them in sockets thankfully so can change them easy)...

I mean 2.2K with 23 address lines , 16 datalines.. 39 pins.. 2.2K @ 5V = 0.0023A x 39 = 0.0897A. So with some other pins might as well round up to 100mA. 0.1A x 5v = 0.5watts. But of course with this thing running in MHz range, there will be RF heating aswell.

So basically if I moved to 4.7K, it should half the power going though the CPU and it may well sustain overclocking better as it will be running cooler. So I need to experiment with the pull-ups to see what I can get away with.

EDIT:
50MHz crashed after just 7 loops this time, with a heatsink on the CPU.. Something is definitely overheating somewhere.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1809
Joined: Fri Mar 23, 2018 8:22 pm

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by PhilC » Tue Jun 18, 2019 10:25 pm

2.5 times its rated speed is pretty good :D
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Tue Jun 18, 2019 10:28 pm

Yep.

10K's in... pretty much as expected.. Can't find 4.7K at the moment :(

IMG_4386.JPG
IMG_4386.JPG (101.99 KiB) Viewed 483 times

EDIT:

Found 4.7K.. so will leave it on for a bit before exxos powers down for the day.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Wed Jun 19, 2019 9:56 am

4.7K crashed after 16 passes. I will test 4.7K again now (from cold) to see what happens. Its possible 4.7K isn't enough, or could have just been a fluke it died at 16 as it was warmed up anyway.

It seems to crash around 20 passes (about 100mins run time) but reset and its off again for another 20 passes. But of course the number isn't consistent it varies. So the crash can happen between 1 and 2 hours. I'm assuming there is some random noise on the bus causing the issue.. but with it only happening after a hour or 2, it's pretty impossible to track down where the issue is :(

Running 40MHz changes nothing either. So I can't accept its overheating, or some timing issue somewhere as it would improve with a slower clock..

I have put another 2.2K on DTACK. Possible its slow edge could be confusing things now and then.. more testing needed....
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Wed Jun 19, 2019 10:00 pm

DTACK didn't help :(. I am currently trying 999 loops in the diagnostic cart for RAM & ROM to see if it trips up at any point.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: V2.5 BOOSTER CURRENT PROTOTYPE STATUS (SEC BOOSTER)

Post by exxos » Thu Jun 20, 2019 11:47 am

I left it running YAART all night and all morning, so its had a straight 12 hour run...

IMG_4387.JPG
IMG_4387.JPG (131.45 KiB) Viewed 421 times

So its not like the booster isn't stable... :shrug:

Will load up the diagnostic cart and do a few hours of ROM checksum test see if the ROM glitches at any point...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “ST 16MHz V2.X SERIES BOOSTERS”