WIP Atari ST ScummVM-lite

Our top picks of ST games!
User avatar
Darklord
Posts: 137
Joined: Wed Sep 20, 2017 1:41 pm

Re: WIP Atari ST ScummVM-lite

Post by Darklord » Thu Aug 20, 2020 6:46 pm

I'm assuming it will work with any accelerated ST model? Thanks.

PS Does Scumm take advantage of things like math co-processors?

<edit> Sorry, just went back through the earlier posts and figured it out. Thanks.

PSS Need to try this on my 40mhz Pak 68/3 board. :)
Welcome To DarkForce! www.darkforce.org "The Fuji Lives.!"
Atari SW/HW based BBS-Telnet:darkforce-bbs.dyndns.org 520

User avatar
agranlund
Posts: 331
Joined: Sun Aug 18, 2019 10:43 pm
Location: Sweden
Contact:

Re: WIP Atari ST ScummVM-lite

Post by agranlund » Tue Sep 08, 2020 8:31 pm

Marsupilami wrote:
Tue Aug 18, 2020 8:14 pm
Hi,
I tried DOT on my MegaSTE running @16Mhz with cache on, TOS206fr, 4Mb RAM, a MT-32 and a CosmosEx 3.0.
And it works really well.(ScummST, build 200709)

- The DMA sound is way too loud compared to the MT32 sound. If you want to hear the MT-32 music in the game, you have to push the volume to a really high level.
I noticed that the midi files on the games are playing lower than a standard midi file within TOS.
In the video i had to lower/raise the sound really often to be able to ear the MT-32 music.

So...Maybe there is a sound adjustment to do somewhere ?
Nice! Thanks for posting the video. It runs surprisingly well on the Mega STE :)

I figure sound/music volume adjusters should be added to the todo list (as well as an actual options UI instead of the temporary options select at startup).

User avatar
GadgetUK164
Posts: 198
Joined: Fri Jan 04, 2019 2:26 pm

Re: WIP Atari ST ScummVM-lite

Post by GadgetUK164 » Tue Sep 08, 2020 8:35 pm

On the Falcon I noticed I just get little clicks for the PCM sound. I did copy all the files across from my STFM, and then deleted some of the files it generates, it then "installed" again but the same issue. Any ideas?
My YouTube Channel - www.youtube.com/GadgetUK164

User avatar
agranlund
Posts: 331
Joined: Sun Aug 18, 2019 10:43 pm
Location: Sweden
Contact:

Re: WIP Atari ST ScummVM-lite

Post by agranlund » Tue Sep 08, 2020 9:10 pm

GadgetUK164 wrote:
Tue Sep 08, 2020 8:35 pm
On the Falcon I noticed I just get little clicks for the PCM sound. I did copy all the files across from my STFM, and then deleted some of the files it generates, it then "installed" again but the same issue. Any ideas?
Falcon PCM sound should have been fixed with version 200706. I can't verify it myself but it was reported to make sound work on at least one Falcon :)
If you already have this or a later version you could try running FPATCH.PRG / FPATCH2.PRG first and see if that helps - I don't think it will since I'm already duplicating what this program is doing inside ScummVM but it's worth a shot in case I missed something.

User avatar
GadgetUK164
Posts: 198
Joined: Fri Jan 04, 2019 2:26 pm

Re: WIP Atari ST ScummVM-lite

Post by GadgetUK164 » Tue Sep 08, 2020 11:17 pm

agranlund wrote:
Tue Sep 08, 2020 9:10 pm
GadgetUK164 wrote:
Tue Sep 08, 2020 8:35 pm
On the Falcon I noticed I just get little clicks for the PCM sound. I did copy all the files across from my STFM, and then deleted some of the files it generates, it then "installed" again but the same issue. Any ideas?
Falcon PCM sound should have been fixed with version 200706. I can't verify it myself but it was reported to make sound work on at least one Falcon :)
If you already have this or a later version you could try running FPATCH.PRG / FPATCH2.PRG first and see if that helps - I don't think it will since I'm already duplicating what this program is doing inside ScummVM but it's worth a shot in case I missed something.
Thanks! I thought I was on the latest version, but looking at the file dates I am a few versions behind! I will update it tomorrow - will lose my saves but not the end of the world.
My YouTube Channel - www.youtube.com/GadgetUK164

User avatar
GadgetUK164
Posts: 198
Joined: Fri Jan 04, 2019 2:26 pm

Re: WIP Atari ST ScummVM-lite

Post by GadgetUK164 » Wed Sep 09, 2020 4:04 pm

DMA speech working fine on the Falcon using latest version =D It runs so very well on the Falcon, feels just like playing the original!
My YouTube Channel - www.youtube.com/GadgetUK164

User avatar
agranlund
Posts: 331
Joined: Sun Aug 18, 2019 10:43 pm
Location: Sweden
Contact:

Re: WIP Atari ST ScummVM-lite

Post by agranlund » Wed Sep 09, 2020 4:25 pm

GadgetUK164 wrote:
Wed Sep 09, 2020 4:04 pm
DMA speech working fine on the Falcon using latest version =D It runs so very well on the Falcon, feels just like playing the original!
Nice! I'm glad it's working, you got me scared there for a while :)

User avatar
Steve
Posts: 541
Joined: Fri Sep 15, 2017 11:49 am

Re: WIP Atari ST ScummVM-lite

Post by Steve » Wed Sep 09, 2020 4:54 pm

agranlund wrote:
Wed Sep 09, 2020 4:25 pm
Nice! I'm glad it's working, you got me scared there for a while :)
agranlund the work you've done on these games & opendune are some of the best software contributions to the Atari community in many years. Honestly I think you deserve some kind of trophy :)
Repairs & Servicing for Atari & Amiga machines (and any other retro computers) Located in the West Midlands UK. PM me if you require assistance.
www.solidstatesociety.co.uk

User avatar
agranlund
Posts: 331
Joined: Sun Aug 18, 2019 10:43 pm
Location: Sweden
Contact:

Re: WIP Atari ST ScummVM-lite

Post by agranlund » Wed Sep 09, 2020 8:49 pm

Steve wrote:
Wed Sep 09, 2020 4:54 pm
agranlund wrote:
Wed Sep 09, 2020 4:25 pm
Nice! I'm glad it's working, you got me scared there for a while :)
agranlund the work you've done on these games & opendune are some of the best software contributions to the Atari community in many years. Honestly I think you deserve some kind of trophy :)
Thank you Steve!
I'm only really doing it for my own fulfillment (and to have a reason to use my Atari) but it is really rewarding to see people enjoy the results so far! :)

User avatar
Steve
Posts: 541
Joined: Fri Sep 15, 2017 11:49 am

Re: WIP Atari ST ScummVM-lite

Post by Steve » Wed Sep 09, 2020 9:14 pm

If you ever feel like looking at another Atari port that could benefit from your wisdom, the open source Flashback engine REminiscence barely runs on an 030 Atari, it runs okay on an 060 but there must be lots of unoptimised code. Anyway just throwing it out there :)
Repairs & Servicing for Atari & Amiga machines (and any other retro computers) Located in the West Midlands UK. PM me if you require assistance.
www.solidstatesociety.co.uk

Post Reply

Return to “GAME ZONE”