Forgottenmyname - Progress

Where Alpha builders can post pics and progress etc
Post Reply
Forgottenmyname
Trusted Guru
Trusted Guru
Posts: 422
Joined: Fri Mar 23, 2018 8:22 pm

Forgottenmyname - Progress

Post by Forgottenmyname » Tue Sep 18, 2018 2:55 pm

Hi All,

As of today I still get the rolling screen after applying the sync mod on U51.
The Glue is still sending out 15khz on 37 and 60hz on 38.

I do have a lot of activity on /AS /R/W on the CPU, Rom data lines are active on the Eprom but all activity stops after about 10 seconds. BUT this is only from a cold start, never warm start.

/Halt and /Reset are both high (ready to run)

I did have a row of bombs early on today whilst scoping around the eprom but wasn't looking at the TV at the time to know exactly where.

Does anyone know what will cause all activity to pause after 10 seconds after a cold start?

User avatar
exxos
Site Admin
Site Admin
Posts: 4089
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Forgottenmyname - Progress

Post by exxos » Tue Sep 18, 2018 2:59 pm

What does BERR do all this time ?

CPU would normally wait for DTACK (should arrive within about 8 clocks of /AS going low).. if it doesn't then something hasn't responded on the bus.. in which case, BERR normally gets set and the CPU gets HALted.

If something is wrong with the address bus, then during startup it could be trying to access a invalid area of RAM, but again BERR should be set then anyway.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Forgottenmyname
Trusted Guru
Trusted Guru
Posts: 422
Joined: Fri Mar 23, 2018 8:22 pm

Re: Forgottenmyname - Progress

Post by Forgottenmyname » Tue Sep 18, 2018 3:54 pm

BERR is 5v from startup.

ok, trying to describe what I see, the signals on the databuses, /AS etc all start off with a low value mean but you can clearly see the pulses, then the mean voltage increases and after about 10 seconds its flat lined at 5v.

incomming voltage is steady.

User avatar
exxos
Site Admin
Site Admin
Posts: 4089
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Forgottenmyname - Progress

Post by exxos » Tue Sep 18, 2018 4:04 pm

Have you checked the clocks on the MFP ?

Also may help if you can post a capture of V&H sync..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

troed
Trusted Guru
Trusted Guru
Posts: 400
Joined: Mon Aug 21, 2017 10:27 pm

Re: Forgottenmyname - Progress

Post by troed » Tue Sep 18, 2018 4:05 pm

Forgottenmyname wrote:
Tue Sep 18, 2018 2:55 pm
As of today I still get the rolling screen after applying the sync mod on U51.
The Glue is still sending out 15khz on 37 and 60hz on 38.
What do you have on the monitor port then? If HSYNC and VSYNC are steady at 15kHz and 60Hz you should not have a rolling screen ... unless your TV cannot handle 60Hz and then it would be predictably vertical rolling only :)

Forgottenmyname
Trusted Guru
Trusted Guru
Posts: 422
Joined: Fri Mar 23, 2018 8:22 pm

Re: Forgottenmyname - Progress

Post by Forgottenmyname » Tue Sep 18, 2018 4:15 pm

MFP has 4Mhz on pin 35, 2.45753 on 17 & 18

will check the scart lead before i post a video. wheres the best place to upload vids?

User avatar
exxos
Site Admin
Site Admin
Posts: 4089
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Forgottenmyname - Progress

Post by exxos » Tue Sep 18, 2018 4:17 pm

Forgottenmyname wrote:
Tue Sep 18, 2018 4:15 pm
MFP has 4Mhz on pin 35, 2.45753 on 17 & 18

will check the scart lead before i post a video. wheres the best place to upload vids?
I guess YouTube is best place, failing that if you can compress the video to a few MB then can be uploaded here..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 4089
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Forgottenmyname - Progress

Post by exxos » Tue Sep 18, 2018 4:19 pm

BTW does your cable use the separate syncs or the composite sync ?
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Forgottenmyname
Trusted Guru
Trusted Guru
Posts: 422
Joined: Fri Mar 23, 2018 8:22 pm

Re: Forgottenmyname - Progress

Post by Forgottenmyname » Tue Sep 18, 2018 4:25 pm

It uses this minus the resistors
Attachments
Atari_SCART_cable.png
Atari_SCART_cable.png (55.62 KiB) Viewed 258 times

User avatar
exxos
Site Admin
Site Admin
Posts: 4089
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Forgottenmyname - Progress

Post by exxos » Tue Sep 18, 2018 4:36 pm

Probably the thing to do is check composite sync on a working ST and then the STF... it could just be the voltage is a fraction lower than the TV likes or something silly...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply