TerribleFire 328/330 Support (CD32)

Help & news on accelerators from TF, Amiga, Atari, CD32 etc

Moderators: terriblefire, Terriblefire Moderator

nicus101
Posts: 5
Joined: Mon Jan 28, 2019 3:57 pm

Re: TerribleFire 328/330 Support (CD32)

Post by nicus101 » Fri Feb 15, 2019 3:05 pm

Hi,
First i'd like to thank you all for brilliant work you guys do for Amiga fans.

I have CD32 with Elsat ProModule so i wasnt much interesed in TF328 but TF330 is simply amazing piece of hardware :D

Questions i'd like to ask are:

1.I have MC68EC030RP40B in PGA i bought two for another project so got one spare Will it work with TF330?
2.Is there any place where i can get on list to buy TF330 when it's get released also without CPU preferably if the above mentioned will work.

User avatar
supaduper
Posts: 138
Joined: Thu Nov 08, 2018 12:05 pm

Re: TerribleFire 328/330 Support (CD32)

Post by supaduper » Fri Feb 15, 2019 3:20 pm

Hi

Yes that cpu should work fine at 50mhz

Don`t need to be on list, when they are ready to ship one of us builders on here can sort you one out

nicus101
Posts: 5
Joined: Mon Jan 28, 2019 3:57 pm

Re: TerribleFire 328/330 Support (CD32)

Post by nicus101 » Tue Feb 26, 2019 8:11 pm

Anyone tested if TF330 works with SD2IDE?

terriblefire
Moderator Team
Moderator Team
Posts: 1145
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: TerribleFire 328/330 Support (CD32)

Post by terriblefire » Tue Feb 26, 2019 8:37 pm

Yes. It does. Same IDE compatibility at all TF cards. There is a wiki page on TF328 github with a list
———
I get cranky when asked to repeat myself.

User avatar
supaduper
Posts: 138
Joined: Thu Nov 08, 2018 12:05 pm

Re: TerribleFire 328/330 Support (CD32)

Post by supaduper » Tue Mar 26, 2019 10:03 pm

Here is a Link to my 8gb Raspberry Pie image to program TF328/ TF330 which has the programming software on it `xc3sprog`
you will need `Winimage` to flash the Sd: here :http://www.winimage.com/download.htm

My Raspberry pi 8gb link here:
https://mega.nz/#!EwYERaJK!J1JPFBySS1lG ... --ofo5Mvns

Useful help thread here:
viewtopic.php?f=70&t=1702

User avatar
supaduper
Posts: 138
Joined: Thu Nov 08, 2018 12:05 pm

Re: TerribleFire 328/330 Support (CD32)

Post by supaduper » Wed Mar 27, 2019 5:47 pm

Here is a zipped `Howto` put together by me with a picture and commands in a text file for you to copy into a terminal so you can use with my image in the previous post. so long as you follow by the letter and have connections correctly configured ( see Stephens Video for Jtag connections) it will work as I have tested it :)

This is For the TF330r3 with jeds provided for the new `Burst` 2 and the earlier slower jed so you can reflash back if your CPU falls over with the speed increase..as this can happen as not all CPU`s are equal

If you break something don`t come crying to me, this is at your own risk, if you`re not sure then ask or send it to one of us builders for an upgrade :)
Attachments
TF330r3RspberryPi Program Howto plus jeds.zip
(360.68 KiB) Downloaded 43 times

go0se
Posts: 72
Joined: Sun Nov 25, 2018 7:55 pm

Re: TerribleFire 328/330 Support (CD32)

Post by go0se » Sun Mar 31, 2019 5:51 pm

Hi All,

Received my TF330 boards yesterday, Cheers TF! I've built two of them and they seem to go together really nicely. The pads on the board seem somehow more forgiving than the 534 and the RAM is a pleasure to work with!

Both boards appeared to work correctly straight away, pass diagrom mem tests etc. However I'm having issues with one not wanting to recognise my CF card. It's not detected in boot options and so can't get much further with it. When I use the same CF and adapter with the other 330 it boots fine and seems happy. I've tried another adapter and CF as well without success. Continuity tested the IDE header in conjunction with the excellent OpenBoardView and all seems happy. Also checked the CPLd and gave it some attention on anything that looked remotely suspicious. Unfortunately nothing seems to allow it to be recognised. I'm using the latest firmware from tfbinaries - tf330_2019_03_18_alpha.zip on both cards.

Have any of you volume builders encountered this issue before or could suggest where I should be focusing my attention?

Cheers.

User avatar
supaduper
Posts: 138
Joined: Thu Nov 08, 2018 12:05 pm

Re: TerribleFire 328/330 Support (CD32)

Post by supaduper » Sun Mar 31, 2019 6:20 pm

have you swapped the CPU`s ( small % of my 030/40 mhz will fall down with the new firmware) as its just pushes some over the edge

alenppc
Moderator Team
Moderator Team
Posts: 264
Joined: Thu Nov 08, 2018 12:59 pm

Re: TerribleFire 328/330 Support (CD32)

Post by alenppc » Mon Apr 01, 2019 4:38 pm

You should reflow your CPLD, there is probably a pin that's not making contact.

go0se
Posts: 72
Joined: Sun Nov 25, 2018 7:55 pm

Re: TerribleFire 328/330 Support (CD32)

Post by go0se » Mon Apr 01, 2019 5:50 pm

Thanks for the replies guys, I think I've resolved the issue. I retested the board under diagrom and to my surprise the fastram was no longer being detected, even though it had been detected and passed test after the initial build.

I re-flowed the ram again and gave the whole board an additional clean and now it's detecting the ram and booting from the CF card. It's been under test in AmigaTestKit for the past hour and looks good so far.

Cheers for the tips.

Also, Am I right in saying the labels for the 5V and GND are the wrong way round on the PCB silkscreen for the 330 power header? I assume this has been pointed out already and I've probably even read it but just in case?

Post Reply