Page 4 of 4

Re: TerribleFire 328/330 Support (CD32)

Posted: Tue May 21, 2019 12:42 pm
by alenppc
wairnair wrote:
Mon May 20, 2019 7:57 pm
I know the whole thing can be turned off with a jumper, am using it.
It's working for you with the current (v2) firmware? For me it only works for a few minutes.

Re: TerribleFire 328/330 Support (CD32)

Posted: Tue May 21, 2019 1:17 pm
by wairnair
alenppc wrote:
Tue May 21, 2019 12:42 pm
It's working for you with the current (v2) firmware? For me it only works for a few minutes.
It does seem to work fine. It was running a demo compilation disk for about an hour with the TF330 off.
Not sure about which version I have though. All I know for 100% is that it DOES have the burst mode feature (makes almost 10 mips in sysinfo).

Re: TerribleFire 328/330 Support (CD32)

Posted: Tue May 21, 2019 1:39 pm
by alenppc
wairnair wrote:
Tue May 21, 2019 1:17 pm
alenppc wrote:
Tue May 21, 2019 12:42 pm
It's working for you with the current (v2) firmware? For me it only works for a few minutes.
It does seem to work fine. It was running a demo compilation disk for about an hour with the TF330 off.
Not sure about which version I have though. All I know for 100% is that it DOES have the burst mode feature (makes almost 10 mips in sysinfo).
That is so weird. I wonder if it depends on the console.

Re: TerribleFire 328/330 Support (CD32)

Posted: Wed May 22, 2019 8:44 pm
by wairnair
alenppc wrote:
Tue May 21, 2019 1:39 pm
That is so weird. I wonder if it depends on the console.
not sure. I have a pal cd32, made in aug '93. I think that's a very typical prod date.
cpu on the TF330 is a full 68030rc50 though, that replaced an ec030rp40 that crashed quite often with the rev3 fw and no heatsink. the full 030 seems stable and lukewarm max.
the issue could be entirely independent of cpu, dont know.

Re: TerribleFire 328/330 Support (CD32)

Posted: Thu May 23, 2019 5:54 pm
by wairnair
alenppc wrote:
Tue May 21, 2019 1:39 pm
That is so weird. I wonder if it depends on the console.
seems like we only need to talk about it.
today I turned the thing on with the TF330 off and voila, it no longer boots. Power led stays dimmed and it's frozen.

Re: TerribleFire 328/330 Support (CD32)

Posted: Thu May 23, 2019 6:09 pm
by alenppc
wairnair wrote:
Thu May 23, 2019 5:54 pm
alenppc wrote:
Tue May 21, 2019 1:39 pm
That is so weird. I wonder if it depends on the console.
seems like we only need to talk about it.
today I turned the thing on with the TF330 off and voila, it no longer boots. Power led stays dimmed and it's frozen.
There we go :)

Yes, it's intermittent, that's what makes it tough to spot. I made another thread about this bug. Stephen will attempt to fix this in the firmware.