Network Tools needed (Remote Amiga Login)

Help & news on accelerators from TF, Amiga, Atari, CD32 etc

Moderators: terriblefire, Terriblefire Moderator

terriblefire
Moderator Team
Moderator Team
Posts: 1849
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: Network Tools needed

Post by terriblefire » Mon Dec 09, 2019 6:38 pm

OK i've been able to replicate this for both telnetd and ttyhandler

However my machine hangs for ages on boot when ttyhandler is in my servers file.
———
I get cranky when asked to repeat myself.

terriblefire
Moderator Team
Moderator Team
Posts: 1849
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: Network Tools needed

Post by terriblefire » Mon Dec 09, 2019 6:46 pm

Ok to summarize in addition to your steps for ttyhandler I

1. Needed to add "wait" to the server file

telnet stream wait Sys:serv/ttyhandler

2. Add an assign for AmiTCP: or i got a requester asking for it when login then a crash.

Not sure what i should add to S:Remote-Startup
———
I get cranky when asked to repeat myself.

terriblefire
Moderator Team
Moderator Team
Posts: 1849
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: Network Tools needed

Post by terriblefire » Mon Dec 09, 2019 7:01 pm

Sample output

Code: Select all

Trying 192.168.0.79...
Connected to 192.168.0.79.
Escape character is '^]'.

Login: root^M
             Password:
                       TTY0
New Shell process 9
Welcome to AmigaOS 3.1.4

9> work:whichamiga/whichamiga
WhichAmiga 1.3.3 (2.5.99)
Written by Harry "Piru" Sintonen. Copyright  1995-1999 PitPlane Productions.

Evaluating system...
 Central Processing Unit: MC68060 62.8 MHz (rev 6)
    Floating Point Unit: 68060fpu
 Memory Management Unit: 68060mmu running
   Custom graphics chip: AGA Lisa 4203 (rev 0)
  Custom animation chip: AGA PAL Alice 8374, rev 3-4
   Other custom chip(s): Paula 8364 (rev 0), Gayle (rev 13)
        Graphics system: Amiga AGA  display bandwidth: 4x
         Hardware Clock: not available
 Max. Chipmem available: 2032 K
 Max. Fastmem available: 131072 K
       ROM chip version: 46.143 (Kickstart unknown)
      Workbench version: 45.194 (Workbench unknown)
       SetPatch version: 43.7
     Expansion board(s):
5080/1: Unknown Man.ID #5080 Unknown Prod.ID #1 (@$40000000 128M)
5080/130: Unknown Man.ID #5080 Unknown Prod.ID #130 (@$00E90000 64k)

 Your computer is an Amiga 1200.
  9>
———
I get cranky when asked to repeat myself.

dalek
Posts: 82
Joined: Thu Nov 08, 2018 11:03 am

Re: Network Tools needed

Post by dalek » Mon Dec 09, 2019 9:45 pm

Nice. S:remote-output can be whatever you want to run at login, like a unix .profile. e.g. you could put your build/run logic here instead of running it remotely, or just leave it empty.

Or you can do the build logic remotely. Personally I'd skip the native build over NFS/Samba if possible, and instead build on linux - then trigger the binary download and run it with an expect. Roadshow gives you wget, so as an example here's a quick expect script generated with autoexpect that retrieves a binary from a webserver and runs it:

Code: Select all

#!/usr/bin/expect -f
#

set timeout -1
spawn $env(SHELL)
match_max 100000
expect "$ "
send -- "telnet 192.168.1.4\r"
expect "Login: "
send -- "root\r"
expect "Password: "
send -- "root\r"
expect "> "
send -- "wget -O RAM:mybin http://192.168.1.3/~dalek/WhichAmiga\r"
expect "> "
send -- "protect RAM:mybin +E\r"
expect "> "
send -- "RAM:mybin\r"
expect "> "
send -- "endcli\r"
expect eof
Then run it like:

Code: Select all

linux$ expect script.exp
spawn /bin/bash
linux$ telnet 192.168.1.4
Trying 192.168.1.4...
Connected to 192.168.1.4.
Escape character is '^]'.

Login: root^M
Password:
TTY0
New Shell process 6
6> wget -O RAM:mybin http://192.168.1.3/~dalek/WhichAmiga
--08:38:48--  http://192.168.1.3/~dalek/WhichAmiga
           => `RAM:mybin'
Connecting to 192.168.1.3:80... connected.
HTTP request sent, awaiting response... protect RAM:mybin +E
200 OK
Length: 20,472 (20K)

 0% [                                     ] 0             --.--K/s             100%[====================================>] 20,472        --.--K/s

08:38:48 (1.63 MB/s) - `RAM:mybin' saved [20472/20472]

6> RAM:mybin
6> endcli
WhichAmiga 1.3.3 (2.5.99)
...
 Your computer is an expanded Amiga 2000+.
6> Process 6 ending
Connection closed by foreign host.

terriblefire
Moderator Team
Moderator Team
Posts: 1849
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: Network Tools needed

Post by terriblefire » Mon Dec 09, 2019 9:49 pm

yeah i may build on Linux but i need to be able to send command line params to my tool.

One curiosity is i cannot get lha to work over ttyhandler. it hangs.
———
I get cranky when asked to repeat myself.

dalek
Posts: 82
Joined: Thu Nov 08, 2018 11:03 am

Re: Network Tools needed

Post by dalek » Mon Dec 09, 2019 10:16 pm

parameters can be passed in to expect (and then on to the run command) or as part of your build generate a run script with the required args and wget that as well.

Weird about lha over ttyhandler - it works for me:

Code: Select all

6> cd RAM:
6> lha x dh2:WhichAmiga
LhA Freeware Version 2.15 68000+
...
Extracting from archive 'dh2:WhichAmiga.lha':
 Extracting: (       0/    1233)  WhichAmiga.info                  1233            1233
...
 Extracting: (       0/    3482)  WhichAmiga/WhichAmiga.info                  3482                  3482
7 files extracted, all files OK.

Operation successful.

6> lha a tmp.lha WhichAmiga
LhA Freeware Version 2.15 68000+
...
Creating new archive 'tmp.lha':
   Freezing: (       0/   20472)  WhichAmiga                 20472     Frozen: ( 41.9%)   20472 =>  11874 : WhichAmiga
...
   Freezing: (       0/    3482)  WhichAmiga.info                  3482     Frozen: ( 44.9%)    3482 =>   1917 : WhichAmiga.info
5 files added, all files OK.

Operation successful.


terriblefire
Moderator Team
Moderator Team
Posts: 1849
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: Network Tools needed

Post by terriblefire » Mon Dec 09, 2019 10:21 pm

which TTY/client are you using?
———
I get cranky when asked to repeat myself.

dalek
Posts: 82
Joined: Thu Nov 08, 2018 11:03 am

Re: Network Tools needed

Post by dalek » Mon Dec 09, 2019 10:24 pm

putty on windows => ssh to debian linux => telnet to winuae

Are you using the same version of LhA (2.15)?

terriblefire
Moderator Team
Moderator Team
Posts: 1849
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: Network Tools needed

Post by terriblefire » Mon Dec 09, 2019 10:33 pm

looks like i have lha 2.2

see the same hanging behaviour if i try and use a ctrl-c or ctrl-d

EDIT: e.g try and stop a ping command.
———
I get cranky when asked to repeat myself.

dalek
Posts: 82
Joined: Thu Nov 08, 2018 11:03 am

Re: Network Tools needed (Remote Amiga Login)

Post by dalek » Tue Dec 10, 2019 12:51 am

Looks like lha 2.2 is old - try http://aminet.net/package/util/arc/lha

Yeah I can't send ctrl+c etc either - looks like ttyhandler doesn't pass it even when sent in raw mode. That's a bummer.

I guess one day recompiling and debugging telnetd2.0 against roadshow is on the cards :?

Post Reply

Return to “Terriblefire's channel”