Total Newbie Thread

TF530 - 63030 + RAM Board

Moderators: terriblefire, Terriblefire Moderator

alenppc
Moderator Team
Moderator Team
Posts: 331
Joined: Thu Nov 08, 2018 12:59 pm

Re: Total Newbie Thread

Post by alenppc » Fri Jan 25, 2019 6:29 pm

That's weird, my TL866 won't program these at all.

User avatar
exxos
Site Admin
Site Admin
Posts: 8485
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Total Newbie Thread

Post by exxos » Fri Jan 25, 2019 6:30 pm

alenppc wrote:
Fri Jan 25, 2019 6:29 pm
That's weird, my TL866 won't program these at all.
Mine didn't when I first got it, but I updated the software and it works fine now.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

alenppc
Moderator Team
Moderator Team
Posts: 331
Joined: Thu Nov 08, 2018 12:59 pm

Re: Total Newbie Thread

Post by alenppc » Fri Jan 25, 2019 6:35 pm

exxos wrote:
Fri Jan 25, 2019 6:30 pm
alenppc wrote:
Fri Jan 25, 2019 6:29 pm
That's weird, my TL866 won't program these at all.
Mine didn't when I first got it, but I updated the software and it works fine now.
Excellent thanks, I am going to try that. I have never updated mine and I bought it 3-4 years ago. Do you know if there is an official source for the updated software?

User avatar
exxos
Site Admin
Site Admin
Posts: 8485
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Total Newbie Thread

Post by exxos » Fri Jan 25, 2019 6:37 pm

alenppc wrote:
Fri Jan 25, 2019 6:35 pm
Excellent thanks, I am going to try that. I have never updated mine and I bought it 3-4 years ago. Do you know if there is an official source for the updated software?
I think there is a update option in the programmer software ?

EDIT:

It goes here...
http://www.xgecu.com/en/

I'm running 8.11 as I updated a few weeks ago.


EDIT2:

Support list..

http://www.xgecu.com/MiniPro/TL866II_List.txt

atf.jpg
atf.jpg (63.39 KiB) Viewed 1104 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

alenppc
Moderator Team
Moderator Team
Posts: 331
Joined: Thu Nov 08, 2018 12:59 pm

Re: Total Newbie Thread

Post by alenppc » Fri Jan 25, 2019 6:41 pm

Looks like you have a TL866-II, mine is a TL866A, I believe. Hopefully it will still support the ATFs.

User avatar
PhilC
Moderator
Moderator
Posts: 2021
Joined: Fri Mar 23, 2018 8:22 pm

Re: Total Newbie Thread

Post by PhilC » Fri Jan 25, 2019 10:07 pm

Bizarre, try that tl866 website with home broadband (sky) and it won't connect. Try with phone on 3 and no problem.
If it ain't broke, test it to Destruction.

User avatar
8 Bit Dreams
Moderator Team
Moderator Team
Posts: 423
Joined: Fri Nov 09, 2018 7:12 am
Location: Germany

Re: Total Newbie Thread

Post by 8 Bit Dreams » Fri Jan 25, 2019 10:16 pm

BE CAREFUL!!!
Latest firmware may kill Your TL866 Programmer (will erase bootloader) if it's fake!
Retro computer repair & hardware in Germany

alenppc
Moderator Team
Moderator Team
Posts: 331
Joined: Thu Nov 08, 2018 12:59 pm

Re: Total Newbie Thread

Post by alenppc » Sat Jan 26, 2019 1:27 am

So it turns out my programmer is a 866CS and it updated to v6.85. On the list of supported devices I now have ATF16V8B and ATF22V10B. Unfortunately the ones I own are ATFxxxC not B. I can't try to see if they program because I lost the damn socket adapters, haven't used them for years...

User avatar
exxos
Site Admin
Site Admin
Posts: 8485
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Total Newbie Thread

Post by exxos » Sat Jan 26, 2019 9:46 am

alenppc wrote:
Sat Jan 26, 2019 1:27 am
So it turns out my programmer is a 866CS and it updated to v6.85. On the list of supported devices I now have ATF16V8B and ATF22V10B. Unfortunately the ones I own are ATFxxxC not B. I can't try to see if they program because I lost the damn socket adapters, haven't used them for years...
It will probably work anyway. I did look into the letter on the end ages ago, I think the only difference I could see was the rise and fall times were like 0.5ns faster from B to C or something stupid like that.

My top3000 programmer only has the C version, I been programming B,C,D chips with that.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 2021
Joined: Fri Mar 23, 2018 8:22 pm

Re: Total Newbie Thread

Post by PhilC » Sat Jan 26, 2019 10:46 am

Mines a CS, so will do the upgrade and try it next week. Otherwise it'll be upgrading to a pro.
If it ain't broke, test it to Destruction.

Post Reply

Return to “TF530”