TF534 on A2000 / memory expansions

TF534 - 68030 + More RAM Board (More compatible with amiga hardware)

Moderators: terriblefire, Terriblefire Moderator

Post Reply
ProfPlum
Posts: 5
Joined: Mon Sep 16, 2019 3:02 am

TF534 on A2000 / memory expansions

Post by ProfPlum » Mon Sep 16, 2019 3:19 am

I recently purchased a TF534 for my Amiga 2000.
It's not playing nice with my AdRam memory card - yellow screen on boot.

If anyone has it setup on their A2000 and is using some other brand of memory card successfully, please post a reply.
It would point me in the right direction as to what brand of card to look for.

Thank-you Stephen for what you're doing. I'm looking forward to the '060 card.

User avatar
8 Bit Dreams
Moderator Team
Moderator Team
Posts: 399
Joined: Fri Nov 09, 2018 7:12 am
Location: Germany

Re: TF534 on A2000 / memory expansions

Post by 8 Bit Dreams » Mon Sep 16, 2019 6:14 am

Stephen tested it with GVP 8HC ll card,
have tested A2000 Combitec card populated with 4MB and 8MB - both setups are recognised and working.
GVP SCSI manual says that caches need to be turned off if You use it with accelerators, im sure this is needed for almost all cards to play well

User avatar
GadgetUK164
Posts: 34
Joined: Fri Jan 04, 2019 2:26 pm

Re: TF534 on A2000 / memory expansions

Post by GadgetUK164 » Wed Oct 09, 2019 1:18 pm

The A2091 seems to play ball, i've yet to test SCSI though. It only provides 2MB of ZII but it does work.
My YouTube Channel - www.youtube.com/GadgetUK164

User avatar
GadgetUK164
Posts: 34
Joined: Fri Jan 04, 2019 2:26 pm

Re: TF534 on A2000 / memory expansions

Post by GadgetUK164 » Tue Oct 15, 2019 2:23 pm

The RAM68K (http://www.mkl211015.altervista.org/ram68k/) - MKL sells them on AmiBay works perfectly with the TF534. Quite cheap and just fits into the CPU slot. You have to run a jumper wire from the cfg_out pin (on the MKL board) to pin 8 of 74LS32 (U606), which is the config in pin of the last Zorro slot (nearest slot 1).

EDIT: And following on from my previous post in this thread - the 2MB on A2091 works fine too with the TF534, but the SCSI seems to hang on boot if autoboot is enabled. The ZRAM board (8MB) from AmigaStore.eu doesn't like the 534 either (just to help save you wasting money if you wanted to try).
My YouTube Channel - www.youtube.com/GadgetUK164

terriblefire
Moderator Team
Moderator Team
Posts: 1362
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: TF534 on A2000 / memory expansions

Post by terriblefire » Tue Oct 15, 2019 5:02 pm

GadgetUK164 wrote:
Tue Oct 15, 2019 2:23 pm

EDIT: And following on from my previous post in this thread - the 2MB on A2091 works fine too with the TF534, but the SCSI seems to hang on boot if autoboot is enabled. The ZRAM board (8MB) from AmigaStore.eu doesn't like the 534 either (just to help save you wasting money if you wanted to try).
This is an OS/Driver bug which will probably have allocated 32 bit fastram for the SCSI buffers.
———
I get cranky when asked to repeat myself.

User avatar
GadgetUK164
Posts: 34
Joined: Fri Jan 04, 2019 2:26 pm

Re: TF534 on A2000 / memory expansions

Post by GadgetUK164 » Tue Oct 15, 2019 11:56 pm

terriblefire wrote:
Tue Oct 15, 2019 5:02 pm
GadgetUK164 wrote:
Tue Oct 15, 2019 2:23 pm

EDIT: And following on from my previous post in this thread - the 2MB on A2091 works fine too with the TF534, but the SCSI seems to hang on boot if autoboot is enabled. The ZRAM board (8MB) from AmigaStore.eu doesn't like the 534 either (just to help save you wasting money if you wanted to try).
This is an OS/Driver bug which will probably have allocated 32 bit fastram for the SCSI buffers.
I did wonder if that was the cause as I remembered you mentioning something similar about the CDTV BIOS, but would that occur before the check for holding down left + right mouse button? ie. it's not possible to get into that boot menu at all, and the drive connected up never gets scanned by the SCSI interface (ie. access LED never lights). It's like it dies in its tracks very early on - no flashes on the power LED or anything.
My YouTube Channel - www.youtube.com/GadgetUK164

Post Reply

Return to “TF534 (OBSOLETE)”