Flashy Clock - Yet another DEV board

Related information and WIP etc
User avatar
Icky
Moderator
Moderator
Posts: 2875
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: Flashy Clock - Yet another DEV board

Post by Icky » Sun Aug 23, 2020 1:34 pm

As @exxos mentioned in the previous post we have been a little distracted from this project but today I found some time to start building one of these V6.2 boards up.

So far the one side has all the SMT components (bar the battery clip as I want to put that on last) soldered using the higher temp solder paste. Again as with the other board I have built today there are a couple of solder bridges needing cleaning up.

IMG_5623.jpeg
IMG_5623.jpeg (153.97 KiB) Viewed 1407 times

User avatar
Icky
Moderator
Moderator
Posts: 2875
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: Flashy Clock - Yet another DEV board

Post by Icky » Sun Aug 23, 2020 2:15 pm

One simple jig designed to help with the keeping the stencil flat and pasting the solder whilst the underside components are recessed. Just need to print it out now.

Screenshot 2020-08-23 at 14.11.08.png
Screenshot 2020-08-23 at 14.11.08.png (1.52 MiB) Viewed 1399 times
Screenshot 2020-08-23 at 14.14.58.png
Screenshot 2020-08-23 at 14.14.58.png (284.99 KiB) Viewed 1399 times
Screenshot 2020-08-23 at 14.15.14.png
Screenshot 2020-08-23 at 14.15.14.png (262.88 KiB) Viewed 1399 times

User avatar
Icky
Moderator
Moderator
Posts: 2875
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: Flashy Clock - Yet another DEV board

Post by Icky » Sun Aug 23, 2020 8:04 pm

Jig made and a little fettling (sharp knife) and it fits. Now to start the other side :)

IMG_5624.jpeg
IMG_5624.jpeg (227.08 KiB) Viewed 1390 times
IMG_5625.jpeg
IMG_5625.jpeg (190.07 KiB) Viewed 1390 times

User avatar
Icky
Moderator
Moderator
Posts: 2875
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: Flashy Clock - Yet another DEV board

Post by Icky » Sun Aug 23, 2020 10:25 pm

And now the other side is done.

IMG_5626.jpeg
IMG_5626.jpeg (150.13 KiB) Viewed 1379 times

User avatar
Icky
Moderator
Moderator
Posts: 2875
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: Flashy Clock - Yet another DEV board

Post by Icky » Sat Dec 12, 2020 6:13 pm

Well this project is still on the go and we have been using our dev versions of Flashy Clock in a lot of testing.

Now we are looking at an H5 3V3 bus version that will cost less due to reduced components and provide the current features of:
  • ALT-RAM 8MB
  • Realtime Clock based on the Falcon clock including NVRAM
  • FlashROM - Software loading and selection of 4x banks of ROM. Including being able to boot from onboard ROM.
Screenshot 2020-12-12 at 15.46.04.png
Screenshot 2020-12-12 at 15.46.04.png (894.12 KiB) Viewed 964 times
Screenshot 2020-12-12 at 15.47.33.png
Screenshot 2020-12-12 at 15.47.33.png (858.54 KiB) Viewed 964 times


User avatar
exxos
Site Admin
Site Admin
Posts: 14826
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Flashy Clock - Yet another DEV board

Post by exxos » Tue Feb 02, 2021 11:37 am

6.3 Starting to get assembled :)


IMG_6177.JPG
IMG_6177.JPG (318.37 KiB) Viewed 758 times


EDIT:

Capture.PNG
Capture.PNG (1.08 MiB) Viewed 754 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
exxos
Site Admin
Site Admin
Posts: 14826
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Flashy Clock - Yet another DEV board

Post by exxos » Tue Feb 02, 2021 7:40 pm

Now for the fun job of continuity checking it all...

IMG_6183.JPG
IMG_6183.JPG (333.99 KiB) Viewed 743 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
exxos
Site Admin
Site Admin
Posts: 14826
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Flashy Clock - Yet another DEV board

Post by exxos » Wed Feb 03, 2021 2:36 pm

Progress finally! Looks like I started the v6.3 firmware a while back, so after doing a few more tweaks I got it booting TOS206 from the motherboard ROM. I've flashed emtos but cannot boot from flash as I forgot this uses 3.3v parts and I soldered in a 5v RTC chip :roll: as the bank selection is held in the NVRAM, its basically corrupted..

As the RTC is "dead" its also causing flashy RTC menu to hang as its waiting for the RTC to respond..which it never does... So added a timeout so it doesn't get stuck again..

So if I get chance later tonight, I'll fit a 3.3v RTC chip then it should be functional then!

I've also grown to hate those 4 headers under the 68k socket! It took a good half hour to get all the pins lined up.. So I will probably try and relocate them to the edge of the PCB.. Which means a tweak on the next H5 revision as well..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
exxos
Site Admin
Site Admin
Posts: 14826
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Flashy Clock - Yet another DEV board

Post by exxos » Thu Feb 04, 2021 1:11 pm

In relating to the "DMA bus conflict" viewtopic.php?f=100&t=3654&p=57417#p57417


Basically this is conflicting with flashy clock which cannot load settings because the DMA bus is basically shorting it out :roll:

So what I did was to power down the H5's IO translators on the databus during reset... Which then means the pins were floating on flashy clock hence all the bodged pull-up resistors... And yet it still did not work :roll:

However, even though it does not boot, I measured the 2 bank select lines on flashy and they were actually loaded correctly from the NVRAM... But it would not boot with the diode in place which is basically zeroing the power to the I/O buffer during reset... Removing the diode and the machine boots but then goes back to loading incorrect values.. The workaround was to just short out system reset to ground or seconds after the machine came out of actual reset.. Then it booted to the correct flash bank...

IMG_6191.JPG
IMG_6191.JPG (283.22 KiB) Viewed 720 times

So I'm currently confused as to why the diode prevents the machine from booting up , as when the machine comes out of reset, the diode is basically allowing the buffer to power up again anyway... :stars:

Capture.PNG
Capture.PNG (42.42 KiB) Viewed 718 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

Post Reply

Return to “H4 MONGREL EDITION DEVELOPMENT & INFO”