exxos IDE interface (untested)

Related information and WIP etc
User avatar
PhilC
Moderator
Moderator
Posts: 1819
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos IDE interface (untested)

Post by PhilC » Sun Dec 09, 2018 8:33 pm

That looks really cool, good luck, hope it works etc :-)
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7873
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos » Sun Dec 09, 2018 9:57 pm

Icky wrote:
Sun Dec 09, 2018 8:28 pm
A big mess-o-wires
Wow indeed! Who would have thought such a "simple" circuit would end up like that, I'm starting to appreciate PLD's a whole lot more all of a sudden :lol: Though I also really hate PLD's :lol:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: exxos IDE interface (untested)

Post by Icky » Thu Dec 27, 2018 12:13 am

Ever so slowly getting there. Christmas has definitely got in the way.

Have ran out of test hooks to help with the setup and also need to finish off a few grounding of unused pins on some of the chips.

Hoping to power up tomorrow after crafting a few more wires to add to the mess.

exxos wrote:
Sun Dec 09, 2018 9:57 pm
Icky wrote:
Sun Dec 09, 2018 8:28 pm
A big mess-o-wires
Wow indeed! Who would have thought such a "simple" circuit would end up like that, I'm starting to appreciate PLD's a whole lot more all of a sudden :lol: Though I also really hate PLD's :lol:
Also appreciating that this, although simple, is one wiring nightmare. Roll-on PLD version if this one works.

IMG_3459.png
IMG_3459.png (671.52 KiB) Viewed 974 times

User avatar
exxos
Site Admin
Site Admin
Posts: 7873
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos » Thu Dec 27, 2018 12:18 am

Icky wrote:
Thu Dec 27, 2018 12:13 am
Ever so slowly getting there. Christmas has definitely got in the way.
Same here. I learned eating 6 satsumas gives me stomach ache! :lol:

Icky wrote:
Thu Dec 27, 2018 12:13 am
Also appreciating that this, although simple, is one wiring nightmare. Roll-on PLD version if this one works.
Now that's a proper prototype! Yeah, it will all come together in the end and be the worlds first stable IDE solution ;)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: exxos IDE interface (untested)

Post by Icky » Thu Dec 27, 2018 12:30 am

exxos wrote:
Thu Dec 27, 2018 12:18 am
Same here. I learned eating 6 satsumas gives me stomach ache! :lol:
Ouch - too much citric acid :(

User avatar
exxos
Site Admin
Site Admin
Posts: 7873
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos » Thu Dec 27, 2018 2:06 pm

I had a brainstorm that my old development board would be a ideal thing for the IDE project.

It already has the PLD wired up and a few spare IO pins for the IDE control lines. The address bus and bus control lines are already wired up to the PLD. It also has most of the CPU lines on header pins to make wiring up / testing, external stuff a lot easier.

IMG_3722.JPG
IMG_3722.JPG (459.2 KiB) Viewed 937 times

So once I get it to behave as a stock system, I will send it to Icky for the IDE project.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: exxos IDE interface (untested)

Post by Icky » Thu Dec 27, 2018 9:30 pm

exxos wrote:
Thu Dec 27, 2018 2:06 pm
So once I get it to behave as a stock system, I will send it to Icky for the IDE project.
Thanks Exxos that will make things a little simpler.

Ok. I had first power on. ST worked fine no smoke or explosions. Went to desktop.

HDD hasn’t spun up there isn’t enough voltage. I know something is not quite right so am just tracing all the connections.

User avatar
exxos
Site Admin
Site Admin
Posts: 7873
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos IDE interface (untested)

Post by exxos » Thu Dec 27, 2018 10:18 pm

hopefully its something simple.


The dev board has been running for a few hours ... So it seems OK . will try and send it Wednesday...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: exxos IDE interface (untested)

Post by Icky » Sat Dec 29, 2018 6:04 pm

exxos wrote:
Thu Dec 27, 2018 10:18 pm
hopefully its something simple.


The dev board has been running for a few hours ... So it seems OK . will try and send it Wednesday...
Looks like it was something simple but painstakingly annoying to find. The IDE 40 - 44 convertor block is broken it was not providing power correctly and a few other pins were not working.

Am currently rewiring another IDE cable in place. I probably will find something else wrong with it knowing my luck.

terriblefire
Moderator Team
Moderator Team
Posts: 1362
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
Contact:

Re: exxos IDE interface (untested)

Post by terriblefire » Sat Dec 29, 2018 6:07 pm

We went through enormous pain on the TF328 to make every CF card work. You can use the code for that

https://github.com/terriblefire/tf328/b ... /rtl/ata.v
———
I get cranky when asked to repeat myself.

Post Reply

Return to “MONGREL EDITION DEVELOPMENT & INFO”