Page 5 of 12

Re: exxos IDE interface (untested)

Posted: Wed Feb 06, 2019 1:07 pm
by redhawk668
Oh my, that looks nice!

Re: exxos IDE interface (untested)

Posted: Sat Feb 09, 2019 1:31 am
by Icky
We have been doing a lot of testing and finding out some interesting things around the PIO modes and driver interactions with IDE devices at initialisation.

However the tests we are performing to check the interface and devices are working have been captured in this video.



This is our definition of a working IDE Interface and Device as test steps. If we can get to the bottom of the list then the IDE interface and Device is working. Definition of Device is SD IDE Adaptor with card or CF IDE Adaptor with card:
  1. Boot up ST
  2. Boots off of Floppy with HDDriver 10.14
  3. Driver sees IDE interface and Device. Device is displayed correctly
  4. Load HDDUtil from floppy
  5. Partition Device into 9 partitions that are <500MB as TOS partitions
  6. Reboot after partitioning
  7. Boots off of Floppy with HDDriver 10.14
  8. Driver sees IDE interface and Device. Device is displayed correctly
  9. Partitions are recognised by the driver
  10. Once at desktop go to preferences and change res to medium, install devices and make sure all partitions are present and save desktop
  11. Open C: and create a folder called HDD and go into it
  12. Open A: which is still the HDDriver 10.14 files and copy all files and folders from A: into C:\HDD
  13. Go to C:\HDD and run HDDUtil to see if it loads correctly from HDD
  14. Once in HDDUtil install HDDriver on C:
  15. Go back to C: and copy C:\HDD to D:, E: & F:
  16. Delete the folder HDD from D;, E: & F:
  17. Reset ST and it should boot directly from Device and not floppy

Re: exxos IDE interface (untested)

Posted: Tue Feb 12, 2019 7:28 am
by Icky
Update: We have ROM.

This is the latest version of the board which has a few tweaks and inclusion of ROM so you can select which version of TOS to run.

C74D3BFF-99B4-429B-82B3-C51272351385.jpeg
C74D3BFF-99B4-429B-82B3-C51272351385.jpeg (198.07 KiB) Viewed 1523 times

We now need to send off to get a few boards made so we can test further before looking at the final version of this board.

Re: exxos IDE interface (untested)

Posted: Tue Feb 12, 2019 7:52 am
by tuxie
did you test the Transferspeed of your IDE Interface ?

Re: exxos IDE interface (untested)

Posted: Tue Feb 12, 2019 8:35 am
by PhilC
Let me know if you need another Guinea pig.

Re: exxos IDE interface (untested)

Posted: Tue Feb 12, 2019 9:54 am
by dhedberg
Looks awesome! Great work! How much space does the board require? Will it still be possible to use the internal keyboard in its regular position?

Re: exxos IDE interface (untested)

Posted: Tue Feb 12, 2019 10:18 am
by exxos
dhedberg wrote:
Tue Feb 12, 2019 9:54 am
Looks awesome! Great work! How much space does the board require? Will it still be possible to use the internal keyboard in its regular position?
This is just a test board for us to beta test. Likely a final board will be smaller.

Re: exxos IDE interface (untested)

Posted: Tue Feb 12, 2019 11:59 am
by tuxie
Any tests with xferrate ?

Re: exxos IDE interface (untested)

Posted: Tue Feb 12, 2019 12:00 pm
by rubber_jonnie
Forgottenmyname wrote:
Tue Feb 12, 2019 8:35 am
Let me know if you need another Guinea pig.
Also volunteering to be a guinea pig, I have a couple of boards that would be ideal for testing this.

Re: exxos IDE interface (untested)

Posted: Tue Feb 12, 2019 12:02 pm
by exxos
tuxie wrote:
Tue Feb 12, 2019 11:59 am
Any tests with xferrate ?
We haven't done any benchmarks because we need to build a proper prototype first. Transfer rate is based on CF card more than interface anyway.