TF1260 stuff

News & updates for the upcoming 68060 accelerator

Moderators: terriblefire, Terriblefire Moderator

User avatar
supaduper
Posts: 352
Joined: Thu Nov 08, 2018 12:05 pm

Re: TF1260 stuff

Post by supaduper » Fri Jun 04, 2021 10:29 am

For those using the Starstruck-Final..don`t it`s buggy use the Starstruck-partyV, I have put a link below

https://mega.nz/file/ItZl3Sxa#3Ky6wEjds ... gMGHJypti8

neilshak123
Posts: 4
Joined: Fri Jun 04, 2021 12:09 am

Re: TF1260 stuff

Post by neilshak123 » Fri Jun 04, 2021 10:31 am

Re: starstruck-final. I've moved the card to my 1D4 board and changed clock speed to 75Mhz and the glitching is gone for me.

neilshak123
Posts: 4
Joined: Fri Jun 04, 2021 12:09 am

Re: TF1260 stuff

Post by neilshak123 » Fri Jun 04, 2021 10:48 am

Plus it works fine on my 2B at 75Mhz (I must have forgotten to up the speed previously). Anyway I'm sick of that demo now! 😂 Back to work... or a cheeky game of Kick Off 2 🤔

wmsteele
Posts: 1
Joined: Sat Dec 22, 2018 1:13 pm

Re: TF1260 stuff

Post by wmsteele » Fri Jun 04, 2021 5:38 pm

A big thanks you to Superduper for the quality build and to Stephen for designing such a wonderful accelerator.

Rocking a 060 LC @ 62Mhz on the new Workbench 3.2 release, with fresh Kichstart roms burned yesterday.

Just need to sort out some cooling and I'm done, many thanks to all involved.

hjnxv8Xm.jpg
hjnxv8Xm.jpg (24.63 KiB) Viewed 236 times
uEq9LpYm.jpg
uEq9LpYm.jpg (19.63 KiB) Viewed 236 times

terriblefire
Moderator Team
Moderator Team
Posts: 4131
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
YouTube: terriblefire
Contact:

Re: TF1260 stuff

Post by terriblefire » Fri Jun 04, 2021 5:46 pm

Excellent...

Let me clear up something... This card was really only meant for me and a few friends... so Speed Limit 106Mhz... Air do shocair.. is a teuchter joke and a reference to



Really do not expect anything but sarcasm on my silkscreens. Like everyone was told when they bought it.. you'll get maybe 75 to 80mhz out of the card max.
———
"It is not necessarily a supply voltage at no load, but the amount of current it can provide when touched that
indicates how much hurting you shall receive."

ekalkici
Posts: 7
Joined: Thu May 27, 2021 6:31 pm

Re: TF1260 stuff

Post by ekalkici » Sat Jun 05, 2021 6:23 am

terriblefire wrote:
Wed Jun 02, 2021 8:34 am
Well it says you have specified PHASE and CRYSTAL when you have not.

cpuspeed.c

If anyone wants to fix it... knock yourself out.
Hi Stpehen. Yesterday a friend of mine worked on these cpuspeed codes and assembled a newer one. He'll post details and new verison of cpuspeed. I wanted to be sure it's stable and as far as i tested it doesn't give 4294 mhz error. On startup , after TBL demos , after reset or after manually make system crash by overclocking too much i tested every possible cause of this 4294 mhz error and didnt get one. Thanks for sharing codes, as i said he will post deatils and newer version.

Alpyre
Posts: 2
Joined: Sat Jun 05, 2021 6:53 am

Re: TF1260 stuff

Post by Alpyre » Sat Jun 05, 2021 7:30 am

terriblefire wrote:
Wed Jun 02, 2021 8:34 am
Well it says you have specified PHASE and CRYSTAL when you have not.

cpuspeed.c

If anyone wants to fix it... knock yourself out.
Challenge accepted.

I do not own a TF1260 but I've looked at the code by request. It looks quite straightforward. I refactored it to compile with gcc6.5.0 and added some control routines for the problems my friend ekalkici reported. He is happy with this version so far. For those who face similar issues, here it is.
Attachments
cpuspeed.zip
(10.44 KiB) Downloaded 36 times

trixster
Posts: 27
Joined: Fri Mar 22, 2019 3:25 pm

Re: TF1260 stuff

Post by trixster » Sun Jun 06, 2021 2:52 pm

Tested, seems to work fine for me, no crashes so far, speed is reported correctly, can still clock to 80mhz ok.

@Alpyre What are the differences between this version of cpuspeed and the original from Stephen?

Alpyre
Posts: 2
Joined: Sat Jun 05, 2021 6:53 am

Re: TF1260 stuff

Post by Alpyre » Sun Jun 06, 2021 5:03 pm

trixster wrote:
Sun Jun 06, 2021 2:52 pm
Tested, seems to work fine for me, no crashes so far, speed is reported correctly, can still clock to 80mhz ok.

@Alpyre What are the differences between this version of cpuspeed and the original from Stephen?
This one is compiled with gcc 6.5.0, so it should have better soft-float routines hopefully. Also it is linked with the native version of printf() and these two only are probably solving the reported issues.

But to be more reliable, I've added this routine that checks the status of the card after the new values are set. And if they do not match it will try 2 more times before returning an error message. Older code just used to report the values from the card status.

And finally this one also carries a version tag.

User avatar
GadgetUK164
Posts: 310
Joined: Fri Jan 04, 2019 2:26 pm

Re: TF1260 stuff

Post by GadgetUK164 » Sun Jun 06, 2021 9:48 pm

That new compiled version works OK here too! Stephen - Are the clock speed increments related to the board design btw or the FPGA code?
My YouTube Channel - www.youtube.com/GadgetUK164

Post Reply

Return to “TF360”