Limited TF536 Run - Sort of Sales (All gone)

68030 + SDRAM + IDE

Moderators: terriblefire, Terriblefire Moderator

dalek
Posts: 82
Joined: Thu Nov 08, 2018 11:03 am

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by dalek » Sun Feb 02, 2020 1:38 pm

Tested TF536 okay in A500 R6, R8A and A2000 R6. Not sure if I'll find the A2000 R4 anytime soon. Only tested SD cards not CF.

Strangely with mufastrom my IDE speed is 2.6MB/sec which is less than others seem to be reporting. I did think I had a 2mm 44pin IDE header but I only had a female one, so had to stuff some pin headers in there to get the cable to attach - could be noise from the extra connections?

Oh, and CPLD gets hot in all three systems - so I guess normal?

User avatar
arkadiusz.makarenko
Posts: 264
Joined: Wed Jun 19, 2019 7:36 am
Location: Edinburgh

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by arkadiusz.makarenko » Sun Feb 02, 2020 3:44 pm

dalek wrote:
Sun Feb 02, 2020 1:38 pm
Tested TF536 okay in A500 R6, R8A and A2000 R6. Not sure if I'll find the A2000 R4 anytime soon. Only tested SD cards not CF.

Strangely with mufastrom my IDE speed is 2.6MB/sec which is less than others seem to be reporting. I did think I had a 2mm 44pin IDE header but I only had a female one, so had to stuff some pin headers in there to get the cable to attach - could be noise from the extra connections?

Oh, and CPLD gets hot in all three systems - so I guess normal?
I have similar results on SD card.
600k vanilla or 2.4-2.8MB with fastrom.
Do not trust people. They are capable of greatness.
~ Stanislaw Lem

dalek
Posts: 82
Joined: Thu Nov 08, 2018 11:03 am

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by dalek » Sun Feb 02, 2020 11:01 pm

So your CPLD gets hot too?

I wonder if it's only those with cool CPLDs that have the 3.5MB/sec IDE speeds.

Not complaining about it, just trying to head off all the queries that come when the board goes in to mass production.

PaulJ_2.0
Posts: 229
Joined: Sat May 11, 2019 11:32 pm

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by PaulJ_2.0 » Sun Feb 02, 2020 11:02 pm

I get around 2.5 and stay cool.

dalek
Posts: 82
Joined: Thu Nov 08, 2018 11:03 am

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by dalek » Sun Feb 02, 2020 11:03 pm

Well there goes that theory :?

User avatar
arkadiusz.makarenko
Posts: 264
Joined: Wed Jun 19, 2019 7:36 am
Location: Edinburgh

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by arkadiusz.makarenko » Sun Feb 02, 2020 11:11 pm

dalek wrote:
Sun Feb 02, 2020 11:01 pm
So your CPLD gets hot too?

I wonder if it's only those with cool CPLDs that have the 3.5MB/sec IDE speeds.

Not complaining about it, just trying to head off all the queries that come when the board goes in to mass production.
My cpld is cool. It may be related to my sd2ide
Do not trust people. They are capable of greatness.
~ Stanislaw Lem

dalek
Posts: 82
Joined: Thu Nov 08, 2018 11:03 am

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by dalek » Sun Feb 02, 2020 11:22 pm

I'm using sd2ide as well and hot cpld - so there goes that theory too :)

EDIT: It's not my mufastrom, SD Card, or SD2IDE adapter, as if I move the exact same card/adapter over to the TF534 it's 3.6MB/sec there.

User avatar
PhilC
Moderator
Moderator
Posts: 2370
Joined: Fri Mar 23, 2018 8:22 pm

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by PhilC » Mon Feb 03, 2020 5:25 pm

Finally got mine built and flashed.

I've got it booting Diagrom on the H4 now, will give it a go in an Amiga later on.
If it ain't broke, test it to Destruction.

adam
Posts: 20
Joined: Sat Feb 02, 2019 6:01 pm

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by adam » Tue Feb 04, 2020 8:13 pm

My build works like a charm with latest firmware. Tested on A500 rev.6A. With original firmware from github I was getting unexpected crashes exactyly like allenppc and others.

This is now my ultimate A500 Turbo card. Photos will follow, I need to clean it properly, add missing caps and sd2ide.

TF keep up the great work and thanks for your effort!
When you're ready to sell I will definately order some more boards and maybe at some point in time we'll test 128 MB version just for fun:)

Adam

Crumb
Posts: 3
Joined: Mon Sep 16, 2019 3:56 pm

Re: Limited TF536 Run - Sort of Sales (All gone)

Post by Crumb » Wed Feb 05, 2020 12:08 pm

terriblefire wrote:
Thu Jan 30, 2020 7:38 pm
any major changes requested?
Good job! In case there's some space in the cpld/pcb:

-2 extra pins for IDE signals (just like tf530), just to have future option of faster ide speeds (although 2.5MB/s is good for me). Even if you didn't prepare a firmware for that maybe someone with experience does (Matze?).

-SPI for vampire-like ethernet, or spi stuff like audio cards that play mp3, usb...? CPLD seems big enough to handle SPI and with all that extra ram running tcp/ip stack and some network apps/games like "Dynamite" could be fun. You already wrote code for that for TF530, perhaps some parts could be re-used.

PS: I would be very happy even with 0 changes. Thank you for your efforts.

Post Reply

Return to “TF536”