Page 2 of 5

Re: Turrican II intro music

Posted: Wed Jul 29, 2020 10:33 am
by terriblefire
I'll take a look at this when i get a chance. Think there is a clock glitch involved but i need to think of a way to see it on the LA.

Re: Turrican II intro music

Posted: Wed Jul 29, 2020 11:35 am
by FluffyRedLobster
I wish I had a CD32 and a 330 I could test with :lol: I'm glad go0se stepped in :D

My testing on the 536 was using WHDLoad 18.5 and a few different slave versions. The newer versions of the slave from this year (2.0+) actually seemed to behave worse to me. That's the point I switched to testing with floppies.

Thanks TF for taking a look at some point! :)

Re: Turrican II intro music

Posted: Wed Jul 29, 2020 8:46 pm
by FluffyRedLobster
I don't know how helpful this is (if at all) but just in case I repeated a couple of tests using the same Workbench install (same SD card) on my 534 and 536 (would have tested a 330 if I could! :( )

WHDLoad 18.5.5948

Slave v1.8 (15/07/09)
TF534 - Perfect
TF536 - As go0se described - intermittent slow downs after the first few bars. Music selection screen pretty slow from the get go.

Slave v2.1 (17/06/20)
TF534 - Perfect
TF536 - More noticeable slow down in the intro music, cuts in earlier and more frequently. Music selection screen is crazy slow.

My guess is this fix http://mantis.whdload.de/view.php?id=0002993 in the slave has exacerbated the problem. It talks about adding delays writing to DMACON, but that's all getting a bit above my pay grade :D

Anyway, not a big deal as it's only the intro but hopefully this helps a bit TF if you ever fancy taking a look :)

Re: Turrican II intro music

Posted: Thu Jul 30, 2020 9:58 pm
by CrashMidnick
JST version is also affected but far less than the WHDLOAD version, you can give it a try.

Re: Turrican II intro music

Posted: Sat Aug 01, 2020 9:26 am
by FluffyRedLobster
Thanks, CrashMidnick. JST is new to me, I've given it a go though.

For me, 1.8 slave is (very) marginally better. 2.1 slave is quite a bit worse. Make of that what you will!

Looks like JST is a little more geared toward the CD32 with it's keyboard substitution stuff - I was testing on an A500 obviously.

Re: Turrican II intro music

Posted: Sat Aug 01, 2020 9:31 am
by terriblefire
Does a plain ADF version show the issue?

Re: Turrican II intro music

Posted: Sat Aug 01, 2020 9:52 am
by go0se
I've just tried some ADF versions, same music slowdown issue present.

Although one of the versions had the entire intro sequence ripped out to fit the game on a single disk, which I suppose is one workaround! :lol:

Re: Turrican II intro music

Posted: Sat Aug 01, 2020 12:12 pm
by terriblefire
go0se wrote:
Sat Aug 01, 2020 9:52 am
I've just tried some ADF versions, same music slowdown issue present.

Although one of the versions had the entire intro sequence ripped out to fit the game on a single disk, which I suppose is one workaround! :lol:
Ok i've just got back from a 3 week vacation so i'll see what happens when i put the tf536 in my A500 to start with

Re: Turrican II intro music

Posted: Sat Aug 01, 2020 12:34 pm
by FluffyRedLobster
Same for me - ADFs (those with the intro!) were closer to the 1.8 slave performance but still noticeably slow. But they were good on the 534.

At the risk of confusing things (sorry - not sure if this helps shed any light or the opposite) I think I have another slight 536 timing oddity... In the intro to Damocles, the text ticker e.g. "Capital City Spaceport Ahead" goes out of sync with the 3D view for me. I get the "Landing Completed" text a good 20 seconds or so before you actually land. All syncs up correctly with the 534. Latest WHDLoad slave (1.3), and tried with the EXPLOCAL switch which I believe stops it using fast mem - no difference though.

Still loving the 536 though! :D

Re: Turrican II intro music

Posted: Sat Aug 01, 2020 12:36 pm
by FluffyRedLobster
Ok i've just got back from a 3 week vacation so i'll see what happens when i put the tf536 in my A500 to start with
Cheers for taking a look TF! :cheers: