DMA port "update" ideas..

All information relating to the Alpha plus all the WIP threads etc.
Post Reply
User avatar
Icky
Moderator
Moderator
Posts: 2222
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: DMA port "update" ideas..

Post by Icky » Mon Oct 22, 2018 11:44 pm

exxos wrote:
Mon Oct 22, 2018 11:40 pm
Icky wrote:
Mon Oct 22, 2018 11:34 pm
Nope its booted - The 16MHz needed to be buffered so I took it from the 16MHZ_BUFFERED_1 that was spare on IC900 pin 12
oh sweet! benchmark time then ;)
Spoke to soon its temperamental. Went to put in the HDD and it did not boot. No signal this time.

Put it back to 8MHz and its working again.

User avatar
exxos
Site Admin
Site Admin
Posts: 10898
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: DMA port "update" ideas..

Post by exxos » Mon Oct 22, 2018 11:48 pm

Icky wrote:
Mon Oct 22, 2018 11:44 pm
Spoke to soon its temperamental. Went to put in the HDD and it did not boot. No signal this time.

Put it back to 8MHz and its working again.
Assume you going through a 33R resistor to the DMA clock pin ?
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 2222
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: DMA port "update" ideas..

Post by Icky » Tue Oct 23, 2018 12:00 am

exxos wrote:
Mon Oct 22, 2018 11:48 pm
Icky wrote:
Mon Oct 22, 2018 11:44 pm
Spoke to soon its temperamental. Went to put in the HDD and it did not boot. No signal this time.

Put it back to 8MHz and its working again.
Assume you going through a 33R resistor to the DMA clock pin ?
You assume right :)

It does seem to be temperamental on 16MHz

User avatar
exxos
Site Admin
Site Admin
Posts: 10898
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: DMA port "update" ideas..

Post by exxos » Tue Oct 23, 2018 12:04 am

Icky wrote:
Tue Oct 23, 2018 12:00 am
It does seem to be temperamental on 16MHz
Could be interfacing issues to the MMU, or the DMA might not just cope with it. Up the voltage a bit, see if it helps :P
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 2222
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: DMA port "update" ideas..

Post by Icky » Tue Oct 23, 2018 12:10 am

exxos wrote:
Tue Oct 23, 2018 12:04 am
Icky wrote:
Tue Oct 23, 2018 12:00 am
It does seem to be temperamental on 16MHz
Could be interfacing issues to the MMU, or the DMA might not just cope with it. Up the voltage a bit, see if it helps :P
Will take a better look tomorrow.

User avatar
Icky
Moderator
Moderator
Posts: 2222
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: DMA port "update" ideas..

Post by Icky » Tue Oct 23, 2018 6:55 pm

Icky wrote:
Tue Oct 23, 2018 12:10 am
exxos wrote:
Tue Oct 23, 2018 12:04 am


Could be interfacing issues to the MMU, or the DMA might not just cope with it. Up the voltage a bit, see if it helps :P
Will take a better look tomorrow.
Yep got it stable with a bit more juice :)

However although its running at 16MHz the Gigafile is not recognised @ 16MHz. Drop back down to 8MHz and it sees it

User avatar
exxos
Site Admin
Site Admin
Posts: 10898
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: DMA port "update" ideas..

Post by exxos » Tue Oct 23, 2018 7:07 pm

Icky wrote:
Tue Oct 23, 2018 6:55 pm
Yep got it stable with a bit more juice :)

However although its running at 16MHz the Gigafile is not recognised @ 16MHz. Drop back down to 8MHz and it sees it
Does the floppy still work ?
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 2222
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: DMA port "update" ideas..

Post by Icky » Tue Oct 23, 2018 7:11 pm

exxos wrote:
Tue Oct 23, 2018 7:07 pm
Icky wrote:
Tue Oct 23, 2018 6:55 pm
Yep got it stable with a bit more juice :)

However although its running at 16MHz the Gigafile is not recognised @ 16MHz. Drop back down to 8MHz and it sees it
Does the floppy still work ?
Yes the floppy works fine.

EDIT: @16MHz

User avatar
exxos
Site Admin
Site Admin
Posts: 10898
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: DMA port "update" ideas..

Post by exxos » Tue Oct 23, 2018 7:13 pm

Icky wrote:
Tue Oct 23, 2018 7:11 pm
Yes the floppy works fine.

EDIT: @16MHz
If you can format a floppy fully, it will test the DMA out at the higher speeds better...

Assume gigafile doesn't like the faster port speed :(
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 2222
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: DMA port "update" ideas..

Post by Icky » Tue Oct 23, 2018 7:21 pm

exxos wrote:
Tue Oct 23, 2018 7:13 pm
If you can format a floppy fully, it will test the DMA out at the higher speeds better...

Assume gigafile doesn't like the faster port speed :(
I'll give that a go shortly - need food first :)

Post Reply

Return to “ALPHA DEVELOPMENT INFO”