Icky's H4 Mongrel edition build x 2

Topic for users to share their building progress.
Post Reply
User avatar
PhilC
Moderator
Moderator
Posts: 3271
Joined: Fri Mar 23, 2018 8:22 pm

Re: Icky's H4 Mongrel edition build x 2

Post by PhilC » Sat Dec 07, 2019 10:05 pm

At least yours works, I've probably a whole load to find.
If it ain't broke, test it to Destruction.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1319
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Icky's H4 Mongrel edition build x 2

Post by PaulJ » Sat Dec 07, 2019 11:02 pm

Icky wrote:
Sat Dec 07, 2019 10:04 pm
exxos wrote:
Sat Dec 07, 2019 8:27 pm
@Icky I did rename FDCS to HDCS but traced it around and nothing different. I can't see anything wrong anywhere. Can only assume there's a bad solder job somewhere causing it all.
If there's a bad solder job to be found its probably mine. :)

Il'll go over the board again.
Unlikely we have two bad solder issues that exhibit the same fault exactly with everything else working.. My money is the board but we won't know until we find something. Hey not complaining, the board was virtually perfect and all signals on the scope look great! :thumbup: :thumbup:

User avatar
exxos
Site Admin
Site Admin
Posts: 11269
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Icky's H4 Mongrel edition build x 2

Post by exxos » Sun Dec 08, 2019 12:42 am

Has me beat.

Other than, as Icky said, I used a NOR as a inverter for the MFP input, swapped a LS04 for a LS06 (hence the pull up on HDRQ). I also renamed FDINT to HDINT, but all points look connected the same as the Alpha.

Aside from the buffers (the DMA buffer was tested on a bodge board and literally copy-pasted over) even so, Icky says it still not working jumpered.

The only thing I can think of is if the propagation delays of the chips I swapped about are the issue.. But there isn't any real different anyway. Both swaps are still inverters, so no logic function changes.

EDIT:

Been around it all again, still don't see anything wrong. compared it to the Alpha and STF diagram, unless I am going blind, just nothing wrong circuit wise that I can see.

The only other difference is the case of the DB19 isn't grounded on the H4 ? I don't have a board here to check.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 11269
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Icky's H4 Mongrel edition build x 2

Post by exxos » Thu Dec 12, 2019 8:30 pm

@Icky You mention the brightness issue earlier, was you using the RGB port or VGA ? TV or Monitor ?
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 2317
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: Icky's H4 Mongrel edition build x 2

Post by Icky » Thu Dec 12, 2019 8:32 pm

@exxos - Am using ST Monitor socket with socket to SCART cable to both a TV and monitor TV.

User avatar
exxos
Site Admin
Site Admin
Posts: 11269
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Icky's H4 Mongrel edition build x 2

Post by exxos » Thu Dec 12, 2019 8:36 pm

Icky wrote:
Thu Dec 12, 2019 8:32 pm
@exxos - Am using ST Monitor socket with socket to SCART cable to both a TV and monitor TV.
So how come bridging the caps originally when we tested it had no effect, but now all of a sudden does ?!

I really need my H4 to come back so I can try it on my monitor :roll:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 2317
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: Icky's H4 Mongrel edition build x 2

Post by Icky » Thu Dec 12, 2019 8:41 pm

@exxos - I remember doing it and it didn't make a difference on the ALPHA, see bridges over caps :)

IMG_3353.jpeg
IMG_3353.jpeg (157.3 KiB) Viewed 635 times

User avatar
exxos
Site Admin
Site Admin
Posts: 11269
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Icky's H4 Mongrel edition build x 2

Post by exxos » Thu Dec 12, 2019 8:55 pm

Icky wrote:
Thu Dec 12, 2019 8:41 pm
@exxos - I remember doing it and it didn't make a difference on the ALPHA, see bridges over caps :)
The circuit is identical, so I don't get what changed in all this :(
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 2317
Joined: Sun Sep 03, 2017 10:57 am
Location: UK
YouTube: https://tinyurl.com/yals4a3k
Contact:

Re: Icky's H4 Mongrel edition build x 2

Post by Icky » Sat Dec 14, 2019 4:35 pm

Finally got round to looking at the video and changing the 75Rs for 100R with caps in series. Below is a pic of the hack to add the 100R and caps.

IMG_4631.jpeg
IMG_4631.jpeg (196.23 KiB) Viewed 599 times

Below is a comparison of the original H4 circuit on the left and the revised 100R with caps in series on the right. As you can see its darker but still not as dark as the original ST. I will get a comparison pic of the original a bit later.

H4-Normal and Caps.png
H4-Normal and Caps.png (989.04 KiB) Viewed 599 times

User avatar
PhilC
Moderator
Moderator
Posts: 3271
Joined: Fri Mar 23, 2018 8:22 pm

Re: Icky's H4 Mongrel edition build x 2

Post by PhilC » Sat Dec 14, 2019 4:55 pm

Looks about the same as the improvement I got. I'm planning on upping the resistor values when I'm back.
If it ain't broke, test it to Destruction.

Post Reply

Return to “MONGREL H4 USER BUILDS”