PaulJ's H4 Mongrel Build x 2

Topic for users to share their building progress.
User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1347
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Sun Dec 08, 2019 3:18 pm

exxos wrote:
Sun Dec 08, 2019 12:47 pm
czietz wrote:
Sun Dec 08, 2019 12:36 pm


BTW: Are you sure that the traces are labeled correctly? I'm surprised by the activity on the RESET line. I don't know about Exxos' board, but in an original ST, this is connected to the system-wide reset line. It should therefore be constantly high during the DMA test.
A good spot. RESET is system wise and should be high all the time after power up like the original ST. The only reason reset may go nuts is if the "flashy clock" jumper is missing, as it breaks the reset line in preparation for the flash-rom booting stuff. If that jumper isn't set, Part of the reset line would be floating.. But I think the LA dump is labeled incorrectly as the machine wouldn't do all that activity with reset going nuts like that.
Yes, totally agree that the label was wrong because it wasn't reseting. I finally found a fair description of the DMA transfer and the cheap LA isn't really capable of capturing all the transitions. Will have to give the HP LA a try.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1347
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Sun Dec 08, 2019 8:23 pm

Well good unexpected news.. I jumpered out IC6 expecting things to still be broke but it now works.. :cheer: :cheer: :cheer: Will do some additional testing but results appear to be solid so far.
WKS1.jpg
WKS1.jpg (246.01 KiB) Viewed 789 times
WKS2.png
WKS2.png (2.49 MiB) Viewed 789 times

User avatar
exxos
Site Admin
Site Admin
Posts: 11799
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: PaulJ's H4 Mongrel Build x 2

Post by exxos » Sun Dec 08, 2019 8:29 pm

:cheer: :cheer: :cheer: :cheer: :cheer:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1347
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Sun Dec 08, 2019 8:49 pm

Heres a bench6 run from the Ultra Satan with NVDI 5.03 installed. (no glitter).
WKS3.jpg
WKS3.jpg (573.52 KiB) Viewed 783 times

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1347
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Tue Dec 10, 2019 11:01 pm

The Exxos IDE dev board is working with TOS 2.06 or TOS 1.04.
5555.jpg
5555.jpg (98.23 KiB) Viewed 755 times

User avatar
exxos
Site Admin
Site Admin
Posts: 11799
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: PaulJ's H4 Mongrel Build x 2

Post by exxos » Wed Dec 11, 2019 12:11 am

Nice! Hopefully I can continue with the new IDE board soon as well :)
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1347
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Wed Dec 11, 2019 12:15 am

Ya, its a nice board and faster that the US. Plus you get availability to TOS 2.06. :bravo:

User avatar
exxos
Site Admin
Site Admin
Posts: 11799
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: PaulJ's H4 Mongrel Build x 2

Post by exxos » Wed Dec 11, 2019 12:33 am

PaulJ wrote:
Wed Dec 11, 2019 12:15 am
Ya, its a nice board and faster that the US.
Odd, it shouldn't be faster than US.. I think by rights IDE should be half the speed of stuff on the DMA port.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1347
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: PaulJ's H4 Mongrel Build x 2

Post by PaulJ » Wed Dec 11, 2019 12:53 am

exxos wrote:
Wed Dec 11, 2019 12:33 am
PaulJ wrote:
Wed Dec 11, 2019 12:15 am
Ya, its a nice board and faster that the US.
Odd, it shouldn't be faster than US.. I think by rights IDE should be half the speed of stuff on the DMA port.
Ya, the UltraS runs @ ~990 -> ~1020 kbytes / sec while the IDE is consistently is 1420. DMA's read cycle / byte is faster but IDE is reading two bytes for each read. I believe its telling us that the software loop reading the words is pretty efficient. In reality its hard to see the differience in speed. I have a number if IDE interfaces.. two of yours and one one the lightning ST. They all run at the same speed. The US is a little pricy. :)

czietz
Posts: 306
Joined: Sun Jan 14, 2018 1:02 pm

Re: PaulJ's H4 Mongrel Build x 2

Post by czietz » Wed Dec 11, 2019 7:26 am

PaulJ wrote:
Wed Dec 11, 2019 12:53 am
Ya, the UltraS runs @ ~990 -> ~1020 kbytes / sec while the IDE is consistently is 1420. DMA's read cycle / byte is faster but IDE is reading two bytes for each read.
Plus, the way IDE is designed for the Atari, the CPU can do two 16-bit IDE reads with a single instruction. Therefore, it takes only 20 CPU clock cycles to transfer 4 bytes. IDE only becomes slow when you start using PC-compatible media, which appear byte-swapped to the Atari over the 16 bit IDE bus and have to be "unswapped" by the CPU. (Unless one uses the Lightning ST, of course; the only IDE interface for the ST that achieves the same fast transfer speed even with byte-swapped media.)

Post Reply

Return to “MONGREL H4 USER BUILDS”