DoG's Hx Mongrel build attempt

Topic for users to share their building progress.
User avatar
DoG
Posts: 384
Joined: Sat Apr 07, 2018 12:26 pm

Re: DoG's Hx Mongrel build attempt

Post by DoG » Sat Dec 28, 2019 5:37 pm

derkom wrote:
Sat Dec 28, 2019 4:55 pm
Looks like your keyboard connector is on backwards. Missing pin should be second from the front, not second from the rear.
Thank you! I just held up the connector from the keyboard. Didn't check that at all. I even have a original motherboard beside me. Clumsy.

User avatar
DoG
Posts: 384
Joined: Sat Apr 07, 2018 12:26 pm

Re: DoG's Hx Mongrel build attempt

Post by DoG » Sat Dec 28, 2019 9:47 pm

exxos wrote:
Sat Dec 28, 2019 4:46 pm
...When will power up be :)?
Now!

Well, it's working... but I got no floppy. I also got very faint red or missing red in display. Have to look into that tomorrow.
No floppy.jpg
No floppy.jpg (8.15 KiB) Viewed 888 times
No red.jpg
No red.jpg (17.31 KiB) Viewed 888 times
Audio is working and Blitter is working. Got 4Mb of ram and it's working. HDD/satandisk is working. External port. So ran GemBench:
GB with blitter.jpg
GB with blitter.jpg (89.2 KiB) Viewed 888 times

User avatar
exxos
Site Admin
Site Admin
Posts: 11845
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: DoG's Hx Mongrel build attempt

Post by exxos » Sun Dec 29, 2019 12:06 am

:bravo:

Looks like you got a bit or 2 in the red line somewhere not contacting.

I assume you did all the fixes to the board and got all jumpers correct ?
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
DoG
Posts: 384
Joined: Sat Apr 07, 2018 12:26 pm

Re: DoG's Hx Mongrel build attempt

Post by DoG » Sun Dec 29, 2019 1:23 pm

exxos wrote:
Sun Dec 29, 2019 12:06 am
Looks like you got a bit or 2 in the red line somewhere not contacting.
You were right about a bit missing. First I checked all my soldering and they seemed fine. So I measured all the stuff on the red side of shifter, DAC and mux. I found that pin 27 (R2) of the shifter didn't have contact with pin 11 on the mux. I found that I got a missing trace on my board so did a little bodge wire and now it is working.


No track.jpg
No track.jpg (21.55 KiB) Viewed 866 times
Bodge wire.jpg
Bodge wire.jpg (21.71 KiB) Viewed 866 times
Bars with red.jpg
Bars with red.jpg (45.22 KiB) Viewed 866 times
Desktop with all colours.jpg
Desktop with all colours.jpg (47.31 KiB) Viewed 866 times

User avatar
exxos
Site Admin
Site Admin
Posts: 11845
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: DoG's Hx Mongrel build attempt

Post by exxos » Sun Dec 29, 2019 1:37 pm

DoG wrote:
Sun Dec 29, 2019 1:23 pm
You were right about a bit missing. First I checked all my soldering and they seemed fine. So I measured all the stuff on the red side of shifter, DAC and mux. I found that pin 27 (R2) of the shifter didn't have contact with pin 11 on the mux. I found that I got a missing trace on my board so did a little bodge wire and now it is working.

Good find! wow those boards are all supposed to be checked for continuity as well.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
DoG
Posts: 384
Joined: Sat Apr 07, 2018 12:26 pm

Re: DoG's Hx Mongrel build attempt

Post by DoG » Tue Feb 18, 2020 2:22 pm

Ordered a few DMA buffer fix pcb from coronaland and some 1 channel converters since @kodak80 have mention it is working now.

I haven't got a chance to check any further, what is faulty with my floppy drive access yet. Measured all of the resistor pack that is 10k around that area. Seems that I got 8k on one of the resistors in RP9. Ordered some new 10k bussed RP. I have also checked continuity of tracks without luck finding anything to get floppy working. I have changed DMA and 1772 chip. No change. Since Satandisk is working I'm hoping that it's the resistor pack that needs changing. I have not soldered in the external port so haven't tried that but I don't see any point of doing that. Anyone got any tip to proceed of finding the fault?

User avatar
exxos
Site Admin
Site Admin
Posts: 11845
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: DoG's Hx Mongrel build attempt

Post by exxos » Tue Feb 18, 2020 3:06 pm

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
DoG
Posts: 384
Joined: Sat Apr 07, 2018 12:26 pm

Re: DoG's Hx Mongrel build attempt

Post by DoG » Tue Feb 18, 2020 4:45 pm

exxos wrote:
Tue Feb 18, 2020 3:06 pm
Have you done this mod ? viewtopic.php?f=78&t=2335&p=31893#p31893
Yes, already done that. Didn't help.

User avatar
exxos
Site Admin
Site Admin
Posts: 11845
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: DoG's Hx Mongrel build attempt

Post by exxos » Tue Feb 18, 2020 4:52 pm

Checked 1772 has 8Mhz clock ?
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
DoG
Posts: 384
Joined: Sat Apr 07, 2018 12:26 pm

Re: DoG's Hx Mongrel build attempt

Post by DoG » Tue Feb 18, 2020 6:17 pm

exxos wrote:
Tue Feb 18, 2020 4:52 pm
Checked 1772 has 8Mhz clock ?
Just bought a LA so haven't checked that. I also thought that I had checked all the traces but when i measured between pin 18 on the 1772 and R905 I had no signal. It was a very small scratch mark on the trace. So solder a small wire and now I got floppy drive access.

So thanks for leading me to check the 8Mhz pin :D

Post Reply

Return to “MONGREL H4 USER BUILDS”