H4 FIXES & KNOWN ISSUES

Topic for users to share their building progress.
User avatar
exxos
Site Admin
Site Admin
Posts: 8614
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

H4 FIXES & KNOWN ISSUES

Post by exxos » Fri Nov 22, 2019 9:12 pm

Thought I would document "issues" as we go along as would help keep track of them all.

BATTERY HOLDER PAD ISSUE

viewtopic.php?f=78&t=2310#p28481

There are no pads for the battery holder, just vias. Just be careful not to "short" the track as you solder it.

IMG_4715.JPG
IMG_4715.JPG (249.49 KiB) Viewed 378 times

FIX done to REV F

f1.JPG
f1.JPG (23.3 KiB) Viewed 378 times


MFP OSC ISSUE

viewtopic.php?f=78&t=2170&start=10#p28950

The osc may need some small bodge wires (yay bodge wires!) to lay it flat as its right under the floppy drive.

IMG_4545.jpeg
IMG_4545.jpeg (314.78 KiB) Viewed 378 times
FIX done to REV F

2.JPG
2.JPG (52.96 KiB) Viewed 378 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 8614
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: H4 FIXES & KNOWN ISSUES

Post by exxos » Sun Nov 24, 2019 12:08 pm

DTACK FIX

There was some last minute changes to the flashy clock integration where DTACK was split via jumpers on the previous design, but it was supposed to be put back "hard-wired", but wasn't :roll: So we need a small bodge wire on the bottom of the PCB (top view shown)

Capture.PNG
Capture.PNG (169.24 KiB) Viewed 322 times

EDIT: Picture of patch in place on the bottom of the board

IMG_4561.jpeg
IMG_4561.jpeg (139.99 KiB) Viewed 307 times

DMA RESISTOR LOCATION ISSUE

Icky found this issue.. viewtopic.php?f=78&t=2170&p=28998#p28984

I swear I fixed that though :roll: (EDIT: though might have been the MFP resistor I moved and didn't notice the DMA one :roll: )

Anyway, More of a "note to self" to fix it on the next board.
dmares.jpeg
dmares.jpeg (122.86 KiB) Viewed 321 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 8614
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: H4 FIXES & KNOWN ISSUES

Post by exxos » Sun Nov 24, 2019 12:42 pm

LOCATION LUG HOLE MISSING

Icky found this small issue. I didn't do any of the location holes (just wasn't enough time in the end) but these are easy to remove with cutters, file, sledge hammer etc.

I am not totally sure if all cases have the location lugs and holes in the same places either (in fact I don't think they do) . I think the screw hole may be in slightly different locations as well, the original STFM boards had a oval hole for some reason. So it may not align in all cases ( pun intended ;) )

hole2.jpeg
hole2.jpeg (104.69 KiB) Viewed 303 times


FLOPPY CONNECTOR MISALIGNMENT

Not sure if there are different connectors, or just never got tweaked...

floppy.jpeg
floppy.jpeg (121.05 KiB) Viewed 303 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1576
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: H4 FIXES & KNOWN ISSUES

Post by Icky » Sun Nov 24, 2019 12:47 pm

exxos wrote:
Sun Nov 24, 2019 12:42 pm
FLOPPY CONNECTOR MISALIGNMENT

Not sure if there are different connectors, or just never got tweaked...
You can get these to fit by gently squeezing the two pins together with some pliers. Once they fit in the hole the connector will fit flush against the board.

User avatar
exxos
Site Admin
Site Admin
Posts: 8614
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: H4 FIXES & KNOWN ISSUES

Post by exxos » Tue Nov 26, 2019 11:24 am

BGACK MISSING PULL UP

So yeah, I did it again :roll: :lol:

There is no BGACK pull up resistor. It needs one adding, anything around 2.2K should be fine.

oopsies.JPG
oopsies.JPG (90.38 KiB) Viewed 254 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1576
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: H4 FIXES & KNOWN ISSUES

Post by Icky » Tue Nov 26, 2019 11:51 am

How the patch looks in place

IMG_4575.jpeg
IMG_4575.jpeg (157.15 KiB) Viewed 247 times

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 853
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: H4 FIXES & KNOWN ISSUES

Post by PaulJ » Tue Nov 26, 2019 2:14 pm

Icky wrote:
Tue Nov 26, 2019 11:51 am
How the patch looks in place
Icky, did you sneeze on your board? :mrgreen: :mrgreen: :mrgreen:

User avatar
Icky
Moderator
Moderator
Posts: 1576
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: H4 FIXES & KNOWN ISSUES

Post by Icky » Tue Nov 26, 2019 2:26 pm

@PaulJ - That is the solder I have. It's a PITA. It spits flux out in little balls and that is the speckled effect you see.

User avatar
exxos
Site Admin
Site Admin
Posts: 8614
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: H4 FIXES & KNOWN ISSUES

Post by exxos » Tue Nov 26, 2019 2:33 pm

Icky wrote:
Tue Nov 26, 2019 2:26 pm
@PaulJ - That is the solder I have. It's a PITA. It spits flux out in little balls and that is the speckled effect you see.
I'm using this one...

https://www.rapidonline.com/warton-meta ... 0g-85-6242

Don't like the note about lead-free though... Maybe we should start stocking up on solder now.. :roll:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 853
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: H4 FIXES & KNOWN ISSUES

Post by PaulJ » Tue Nov 26, 2019 3:45 pm

Icky wrote:
Tue Nov 26, 2019 2:26 pm
@PaulJ - That is the solder I have. It's a PITA. It spits flux out in little balls and that is the speckled effect you see.
Thats pretty disgusting, there's nothing I like about lead free solder! I'll just stick with my ole legacy lead solder. I use some 0.02 stuff from China which I like much better than the 0.032 solder. With the tip TF recommended for SMT work it is the perfect size for me.
IMG_2306.jpg
IMG_2306.jpg (304.03 KiB) Viewed 217 times

Post Reply

Return to “MONGREL H4 USER BUILDS”