Project: HDMI/DVI out for STFM

Progress on our FPGA cores.
User avatar
Smonson
Trusted Guru
Trusted Guru
Posts: 492
Joined: Sat Oct 28, 2017 10:21 am
Location: Canberra, Australia
Contact:

Re: Project: HDMI/DVI out for STFM

Post by Smonson » Thu Aug 30, 2018 9:39 pm

exxos wrote:
Thu Aug 30, 2018 6:47 pm


I'm assuming Smonson did program it before it was sent...
I tested it before sending, but anything can happen with international mail... Just to check, where is the other end of the vsync wire connected?

It definitely seems like vsync is the problem here.

User avatar
Smonson
Trusted Guru
Trusted Guru
Posts: 492
Joined: Sat Oct 28, 2017 10:21 am
Location: Canberra, Australia
Contact:

Re: Project: HDMI/DVI out for STFM

Post by Smonson » Thu Aug 30, 2018 9:45 pm

troed wrote:
Thu Aug 30, 2018 6:54 pm
Is the one towards the DVI connector really bright red without VSYNC? That should be pretty impossible AFAIK. I'll post this and then test on mine :lol: :lol:

edit: test later, forgot I had connected up the original Shifter atm
Yep. There are 3 leds back there, and they correspond to 50, 60, and 71.2Hz being detected. So if vsync isn't working none of them will illuminate. The 5v power LED is always on though.

User avatar
exxos
Site Admin
Site Admin
Posts: 10966
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Project: HDMI/DVI out for STFM

Post by exxos » Thu Aug 30, 2018 9:47 pm

Smonson wrote:
Thu Aug 30, 2018 9:39 pm
I tested it before sending, but anything can happen with international mail... Just to check, where is the other end of the vsync wire connected?
I soldered it to pin 4 of the RF chip.. that is Vsync according to the diagrams..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Smonson
Trusted Guru
Trusted Guru
Posts: 492
Joined: Sat Oct 28, 2017 10:21 am
Location: Canberra, Australia
Contact:

Re: Project: HDMI/DVI out for STFM

Post by Smonson » Thu Aug 30, 2018 11:34 pm

exxos wrote:
Thu Aug 30, 2018 9:47 pm
I soldered it to pin 4 of the RF chip
That's the same signal that comes out of the glue right?

Well. That's a bit of a let-down that it's not syncing.

User avatar
exxos
Site Admin
Site Admin
Posts: 10966
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Project: HDMI/DVI out for STFM

Post by exxos » Thu Aug 30, 2018 11:44 pm

Smonson wrote:
Thu Aug 30, 2018 11:34 pm
That's the same signal that comes out of the glue right?
AS far as I know, its just called VSYNC..
Smonson wrote:
Thu Aug 30, 2018 11:34 pm
Well. That's a bit of a let-down that it's not syncing.
Maybe you could try pin 4 as well and see if that gives any clues ?
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Smonson
Trusted Guru
Trusted Guru
Posts: 492
Joined: Sat Oct 28, 2017 10:21 am
Location: Canberra, Australia
Contact:

Re: Project: HDMI/DVI out for STFM

Post by Smonson » Fri Aug 31, 2018 12:29 am

I can, but not until tomorrow arvo so about 30 hours away... In the meantime here's where I connected it on mine:
IMAG0177.jpg
IMAG0177.jpg (536.75 KiB) Viewed 239 times

troed
Moderator
Moderator
Posts: 614
Joined: Mon Aug 21, 2017 10:27 pm

Re: Project: HDMI/DVI out for STFM

Post by troed » Fri Aug 31, 2018 8:59 am

Here's mine. Bigger pad. Less risk of ripping out a trace when I'm moving the FPGA around ;)
IMG_20180831_084445_0382.JPG
IMG_20180831_084445_0382.JPG (227.05 KiB) Viewed 942 times

User avatar
exxos
Site Admin
Site Admin
Posts: 10966
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Project: HDMI/DVI out for STFM

Post by exxos » Fri Aug 31, 2018 9:22 am

troed wrote:
Fri Aug 31, 2018 8:59 am
Here's mine. Bigger pad. Less risk of ripping out a trace when I'm moving the FPGA around ;)
Should be same line as me then...

I'm on pin 4...
1.JPG
1.JPG (70.19 KiB) Viewed 940 times
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Smonson
Trusted Guru
Trusted Guru
Posts: 492
Joined: Sat Oct 28, 2017 10:21 am
Location: Canberra, Australia
Contact:

Re: Project: HDMI/DVI out for STFM

Post by Smonson » Fri Aug 31, 2018 9:50 am

Looks good to me. Do you have your USB Blaster ready to go? I'll see if I can whip up a video test.

User avatar
exxos
Site Admin
Site Admin
Posts: 10966
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Project: HDMI/DVI out for STFM

Post by exxos » Fri Aug 31, 2018 10:00 am

Smonson wrote:
Fri Aug 31, 2018 9:50 am
Looks good to me. Do you have your USB Blaster ready to go? I'll see if I can whip up a video test.
*somewhere* in a drawer...gosh I couldn't even tell you what software programs the thing, is it in Quartus ? really can't remember :roll:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “FPGA DEVELOPMENT”