Page 28 of 59

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 11:33 am
by exxos
Smonson wrote:
Fri Nov 30, 2018 8:27 am
My observations:
  • The latching behaviour is only level-sensitive, so high-frequency noise around the transitions shouldn't cause glitches
  • The values that are being read seem very non-random, in the sense that either reads the whole word perfectly, or else it reads it with 8-12 wrong bits. It never reads just one wrong bit here and there. The pattern of bits is also very uniform, e.g. 0xb479 comes up a lot (see video and screenshot posted by Icky above)
  • The reason I don't think it's clock related is that both Icky and Troed have the same behaviour, and Troed is using a totally different clock.

Could you get your program to output in binary instead ? Then be easier for people to see if any particular bit(s) are having issues...

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 11:39 am
by Smonson
That's more good evidence that the register read problem isn't related to clock stability :dualthumbup:

The line of Xs is the value in binary.

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 11:44 am
by Smonson
Icky wrote:
Thu Nov 22, 2018 11:01 am
^ This is what it looks like on Icky's machine while running the test program.

Each line represents a read off the resolution register (the whole 16bit word) that differs from the previous value.

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 11:56 am
by exxos
Smonson wrote:
Fri Nov 30, 2018 11:44 am
^ This is what it looks like on Icky's machine while running the test program.

Each line represents a read off the resolution register (the whole 16bit word) that differs from the previous value.
So what motherboard revisions are people using then ?

This is mine..
IMG_3631.JPG
IMG_3631.JPG (1.12 MiB) Viewed 1082 times

Different boards tend to have different "faults".

Is everyone's HDMI board exactly like the one I have ?

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 12:06 pm
by Smonson
Mine's a C103414-001 rev 1.1.

The HDMI boards are all the same, unless I'm misremembering (V4).

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 12:08 pm
by troed
I've tested on both an STFM with SMT chips (the doubleST machine, xx589 or what that MB revision is) as well as with a 520ST rev.B. I don't recall if I tested on another STF as well (I think I did but can redo).

/Troed

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 12:34 pm
by exxos
Looking at the video, I assume like bit0 is failing all the time as it has "X" ?

I would suggest put a 50pF cap on the HDMI board side of the resistors and see if anything changes.. if not.. try 100pF...

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 1:21 pm
by Smonson
But on the scope, it's showing a solid low level - and the moment that matters is the end of the latch enable pulse (plus 20ns) when it's had time to become steady. By the way, usually it reads a full 16-bit zero - if it reads the same value repeatedly, the test program doesn't output a new line. On the video you can see bit 0 is alternating between 0 and 1.

The resolution appears in bit 8-9 by the way, as it's an 8-bit register in the top half of the word.

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 1:28 pm
by exxos
With noise you can get caught out though, it might not always be there, or your scope might be loading it enough to "lie" to you.. It might not be noise.. but have to start somewhere...

Re: Project: HDMI/DVI out for STFM

Posted: Fri Nov 30, 2018 1:37 pm
by Smonson
That's true. Probably the best place to install one for a test would be the underside of the pin header for the ribbon cable. And then if that bit becomes quiet, it'll be proven(ish). I will have to leave it to the mercy of any volunteers.