Page 41 of 59

Re: Project: HDMI/DVI out for STFM

Posted: Fri Jan 04, 2019 6:07 pm
by Icky
exxos wrote:
Fri Jan 04, 2019 5:46 pm
Icky wrote:
Fri Jan 04, 2019 5:44 pm
One thing though is that I am getting a shimmering on the display on the STFM - will look into that next as well.
Thats the issue I had...
At least we are consistent :)

So interestingly from my testing I see the following traits

ST ModelRevisionResettingShimmeringComments
520 STMC070243 REV. EYesNoRock solid display can be seen if you can get it past resetting and playing a game
520 STFMC070789-001 REV. CNoYesShimmering even present playing a game
STF RemakeC070789-001 REV. FYesNoRevision is from the donor STFM that gave the remake most of its parts. Seems to exhibit same behaviour as 520ST

Re: Project: HDMI/DVI out for STFM

Posted: Fri Jan 04, 2019 9:38 pm
by exxos
Icky wrote:
Fri Jan 04, 2019 6:07 pm
At least we are consistent :)

So interestingly from my testing I see the following traits
Very odd..

Add this cap and I bet you be working fine...


viewtopic.php?f=29&t=330&start=270#p14777

Re: Project: HDMI/DVI out for STFM

Posted: Fri Jan 04, 2019 9:59 pm
by Smonson
Thanks for finding this out Icky! Amazing work!

Re: Project: HDMI/DVI out for STFM

Posted: Sat Jan 05, 2019 6:46 pm
by Icky
exxos wrote:
Fri Jan 04, 2019 9:38 pm
Icky wrote:
Fri Jan 04, 2019 6:07 pm
At least we are consistent :)

So interestingly from my testing I see the following traits
Very odd..

Add this cap and I bet you be working fine...


viewtopic.php?f=29&t=330&start=270#p14777
Out of interest what value did you use?

Re: Project: HDMI/DVI out for STFM

Posted: Sat Jan 05, 2019 8:06 pm
by Icky
Icky wrote:
Sat Jan 05, 2019 6:46 pm
exxos wrote:
Fri Jan 04, 2019 9:38 pm


Very odd..

Add this cap and I bet you be working fine...


viewtopic.php?f=29&t=330&start=270#p14777
Out of interest what value did you use?
10nF actually made the board not work - black screen.

47pF works fine.

Screen is now stable on STFM.

EDIT: Just tried the HDMI board back in the STF Remake and 520ST with the 47pF cap in place and its even more temperamental. Some times its just a blank screen like when I used the 10nF when in the STFM and not very often it might try to boot and of course reset. On reset it mostly goes back to blank. I guess the 16MHz line is not so happy in these two machines with the cap on it.

Re: Project: HDMI/DVI out for STFM

Posted: Sat Jan 05, 2019 9:01 pm
by exxos
Icky wrote:
Sat Jan 05, 2019 8:06 pm
10nF actually made the board not work - black screen.

47pF works fine.

Screen is now stable on STFM.

EDIT: Just tried the HDMI board back in the STF Remake and 520ST with the 47pF cap in place and its even more temperamental. Some times its just a blank screen like when I used the 10nF when in the STFM and not very often it might try to boot and of course reset. On reset it mostly goes back to blank. I guess the 16MHz line is not so happy in these two machines with the cap on it.
Anything over about 390pF will squash the signal to much. Its not a good fix, but I still suspect its a clocking issue.

Re: Project: HDMI/DVI out for STFM

Posted: Sun Jan 06, 2019 7:56 am
by Smonson
I used 22pF on the new boards. It's been working fine for my machine. The best place to solder them in is underneath the 34-pin IDC cable pins - pin 1 being the clock, and any of the surrounding pins being ground.

Speaking of the new boards, I have 3 built now (the shifter socket adapter boards, that is) from the Schmitt trigger design, each tested for 30min. I'll be sending these out shortly to the three of you who have given me your postal address. These should hopefully give you a better clock signal.

Re: Project: HDMI/DVI out for STFM

Posted: Sun Jan 06, 2019 10:28 am
by Icky
Smonson wrote:
Sun Jan 06, 2019 7:56 am
I used 22pF on the new boards. It's been working fine for my machine. The best place to solder them in is underneath the 34-pin IDC cable pins - pin 1 being the clock, and any of the surrounding pins being ground.

Speaking of the new boards, I have 3 built now (the shifter socket adapter boards, that is) from the Schmitt trigger design, each tested for 30min. I'll be sending these out shortly to the three of you who have given me your postal address. These should hopefully give you a better clock signal.
Thanks Smonson. I think I will try a lower value 22pF as you have used to see if it still works in the STFM and then see if its effect in the 520ST.

Re: Project: HDMI/DVI out for STFM

Posted: Mon Jan 21, 2019 10:31 am
by exxos
Icky, where did you get up to ?

Are you at a point to send me a not working setup ?

Re: Project: HDMI/DVI out for STFM

Posted: Tue Jan 22, 2019 11:29 am
by Icky
exxos wrote:
Mon Jan 21, 2019 10:31 am
Icky, where did you get up to ?

Are you at a point to send me a not working setup ?
Just to update my table of where we are:

ST ModelRevisionResettingShimmering without capShimmering with 22pFComments
520 STMC070243 REV. EYesNoNoRock solid display can be seen if you can get it past resetting and playing a game. Setting PSU to 4.3V and the ST boots and doesn't reset but there isn't enough power to supply floppy but I could get Gigafile to operate
520 STFMC070789-001 REV. CNoYesNoShimmering even present playing a game. Adding 22pF cap stops the shimmering
STF RemakeC070789-001 REV. FYesNoNoRevision is from the donor STFM that gave the remake most of its parts. Seems to exhibit same behaviour as 520ST including dropping the voltage.

Smonson has kindly sent through a new shifter board which arrived this morning.

IMG_3518.jpg
IMG_3518.jpg (112.83 KiB) Viewed 1198 times

Will give this a go and see what we get.