Amiga 3000 help needed - A3660

General hardware issues and troubleshooting etc

Moderators: terriblefire, Terriblefire Moderator

patracy
Posts: 18
Joined: Mon Jan 25, 2021 3:29 pm

Re: Amiga 3000 help needed - A3660

Post by patracy » Wed Jul 21, 2021 9:03 pm

I believe my issue is with the timing issues from the A3660 and the dmac/ramsey/scsi chip. Today I installed a buddha IDE and ide to sd adapter and it's been running solid in testing. Wish I could have gotten it working with the onboard scsi since the buddha is only showing about 1.5mb transfer speed.

Although a TF4060 would probably solve a lot of issues. ;)

terriblefire
Moderator Team
Moderator Team
Posts: 4216
Joined: Mon Aug 28, 2017 10:56 pm
Location: Glasgow, UK
YouTube: terriblefire
Contact:

Re: Amiga 3000 help needed - A3660

Post by terriblefire » Wed Jul 21, 2021 9:07 pm

Thats v strange as I have no issues with the A3660 or TF4060 and the onboard SCSI.

Do you have the correct clock buffer chip. I believe there is an older version that doesnt work so well?
———
"It is not necessarily a supply voltage at no load, but the amount of current it can provide when touched that
indicates how much hurting you shall receive."

patracy
Posts: 18
Joined: Mon Jan 25, 2021 3:29 pm

Re: Amiga 3000 help needed - A3660

Post by patracy » Wed Jul 21, 2021 9:19 pm

I must confess my ignorance on a clock buffer chip. Not sure what that is? The timing crystal?

The 3000 can be picky on the A3660 and A3640. There's not a lot out there about it, but here's one site talking about at least a 3640.

http://www.l8r.net/technical/t-a3640.shtml

Post Reply

Return to “AMIGA HARDWARE HELP”