R205 100 ohm resistor in SR98 starting to get hot and smell

Repairs & upgrades.
User avatar
Icky
Moderator
Moderator
Posts: 1361
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Tue Nov 06, 2018 12:25 am

Tonight I turned on my STF Remake and the SR98 PSU resistor R205 100 Ohm 3W started to get hot and smell.

Fortunately nothing went bang and checked for shorts etc and there are none.

I notice in the schematic its the resistor on the end of the 12V to GND line.

Screen Shot 2018-11-06 at 00.19.50.png
Screen Shot 2018-11-06 at 00.19.50.png (250.47 KiB) Viewed 1157 times

On the STF remake the 12V line goes to R15 and then to the monitor socket pin only nowhere else.

User avatar
Icky
Moderator
Moderator
Posts: 1361
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Tue Nov 06, 2018 7:07 am

Icky wrote:
Tue Nov 06, 2018 12:25 am
Tonight I turned on my STF Remake and the SR98 PSU resistor R205 100 Ohm 3W started to get hot and smell.

Fortunately nothing went bang and checked for shorts etc and there are none.

I notice in the schematic its the resistor on the end of the 12V to GND line.

On the STF remake the 12V line goes to R15 and then to the monitor socket pin only nowhere else.
So question is what needs to be done to fix / make sure it’s ok. The psu has not been recapped but I had just ordered a recap kit over the weekend.

Think I’ll recap it replace the R205 and then test it out.

User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by exxos » Tue Nov 06, 2018 8:17 am

If you have 12V then its normal... its a dummy load resistors to keep the PSU stable.. normally a few watts resistor.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
frank.lukas
Posts: 122
Joined: Fri Jan 19, 2018 11:52 am

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by frank.lukas » Tue Nov 06, 2018 8:29 am

When the machine has a EPSON SMD diskdrive nothing except the -12V circuit need 20mA or so over the +12V line ...

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 727
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by PaulJ » Tue Nov 06, 2018 3:08 pm

Icky wrote:
Tue Nov 06, 2018 12:25 am
Tonight I turned on my STF Remake and the SR98 PSU resistor R205 100 Ohm 3W started to get hot and smell.

Fortunately nothing went bang and checked for shorts etc and there are none.

I notice in the schematic its the resistor on the end of the 12V to GND line.


Screen Shot 2018-11-06 at 00.19.50.png


On the STF remake the 12V line goes to R15 and then to the monitor socket pin only nowhere else.
As Exxos said its there to load the 12 v supply. At 12 volts its drawing 120 ma which means under normal conditions its disapating 1.44 watts which is well under the 3 watt resisters capability however dissipating 1.5 watts in a resister of that size its going to get hot. It could just be wore out. I'd try just replacing that resister.

User avatar
Icky
Moderator
Moderator
Posts: 1361
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Tue Nov 06, 2018 9:04 pm

Thanks all for suggestions.

Exxos’ recap kit arrived today.

Have decided to replace all the metal film resistors too as that 100R really isn’t looking to good.

I put the unit on load resistors to measure and it was getting really hot. Way too hot.

If you are going to replace one you may as well do the others.

User avatar
Icky
Moderator
Moderator
Posts: 1361
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Mon Nov 12, 2018 10:00 pm

Well I tried to start recapping this PSU over the weekend but got caught up in the STF Remake Reset Circuit fun viewtopic.php?f=19&t=1234

So I thought I would post a pic before this bad boy gets a make over.

Before:
IMG_3270.png
IMG_3270.png (1023.92 KiB) Viewed 1035 times

User avatar
Icky
Moderator
Moderator
Posts: 1361
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Mon Nov 12, 2018 10:03 pm

And here are the bags of fun that are going towards this make over

One Exxos recap kit and a bunch of metal film resistor replacements:
IMG_3271.png
IMG_3271.png (755.51 KiB) Viewed 1034 times

User avatar
Icky
Moderator
Moderator
Posts: 1361
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Tue Nov 13, 2018 9:57 pm

The metal films have escaped

IMG_3272 (1).png
IMG_3272 (1).png (523.19 KiB) Viewed 991 times

User avatar
exxos
Site Admin
Site Admin
Posts: 7846
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by exxos » Tue Nov 13, 2018 10:23 pm

Icky wrote:
Tue Nov 13, 2018 9:57 pm
The metal films have escaped
They do that when your not looking! gotta watch um!
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “PSU (power supplies)”