R205 100 ohm resistor in SR98 starting to get hot and smell

Repairs & upgrades.
User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Tue Nov 13, 2018 10:38 pm

exxos wrote:
Tue Nov 13, 2018 10:23 pm
Icky wrote:
Tue Nov 13, 2018 9:57 pm
The metal films have escaped
They do that when your not looking! gotta watch um!
Well they escaped to the bin. However I caught the younglings and tethered them to the PSU.

PSU sporting new metal film resistors and now awaiting recapping

IMG_3273.png
IMG_3273.png (1.14 MiB) Viewed 945 times

User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Tue Nov 13, 2018 11:10 pm

Power lines under load before metal film resistor replacement:

+5V line= 4.85V
+12V line= 11.26V

Power lines under load after metal film resistor replacement:

+5V line = 4.84V
+12V line = 11.23V

More importantly R205 is not getting really hot and smelling. Thus have solved the heat and smell problem.

User avatar
exxos
Site Admin
Site Admin
Posts: 7873
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by exxos » Tue Nov 13, 2018 11:25 pm

Icky wrote:
Tue Nov 13, 2018 11:10 pm
More importantly R205 is not getting really hot and smelling. Thus have solved the heat and smell problem.
:bravo:


Some boards I used to work on had some wirewound resistors, they always smelled like burning!
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Tue Nov 13, 2018 11:39 pm

exxos wrote:
Tue Nov 13, 2018 11:25 pm
Icky wrote:
Tue Nov 13, 2018 11:10 pm
More importantly R205 is not getting really hot and smelling. Thus have solved the heat and smell problem.
:bravo:


Some boards I used to work on had some wirewound resistors, they always smelled like burning!
Yeah - I know what you mean its a smell I don't forget as I used to work for an electronics firm and they used to make wirewound as well as other resistors.

In fact my wife and I were just talking about the metal film resistors I have been replacing here. She used to work for the sister company I worked for. Picking up one of the load resistors I got from your web store she said that looks like a CGS and low and behold it was.

User avatar
exxos
Site Admin
Site Admin
Posts: 7873
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by exxos » Tue Nov 13, 2018 11:40 pm

Icky wrote:
Tue Nov 13, 2018 11:39 pm
he said that looks like a CGS and low and behold it was.
You need to get service her coming out with geeky stuff like that ;)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Fri Nov 16, 2018 10:42 am

Ah a day of Atari :D

Finally going to get this recapped today

User avatar
exxos
Site Admin
Site Admin
Posts: 7873
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by exxos » Fri Nov 16, 2018 10:49 am

Icky wrote:
Fri Nov 16, 2018 10:42 am
Ah a day of Atari :D

Finally going to get this recapped today
Ain't done that 5min job yet :P
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Fri Nov 16, 2018 10:52 am

exxos wrote:
Fri Nov 16, 2018 10:49 am
Icky wrote:
Fri Nov 16, 2018 10:42 am
Ah a day of Atari :D

Finally going to get this recapped today
Ain't done that 5min job yet :P
Its those 5 min jobs that take days :). Especially when my wife starts talking about resistors.

User avatar
exxos
Site Admin
Site Admin
Posts: 7873
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by exxos » Fri Nov 16, 2018 11:10 am

Icky wrote:
Fri Nov 16, 2018 10:52 am
Its those 5 min jobs that take days :).
Yeah know all about those!
Icky wrote:
Fri Nov 16, 2018 10:52 am
Especially when my wife starts talking about resistors.
Sweet!
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1370
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: R205 100 ohm resistor in SR98 starting to get hot and smell

Post by Icky » Fri Nov 16, 2018 11:14 am

Caps replaced from kit. Only the rectifiers and resistors to go.

Question for Exxos - there is one cap left on the board C206 that does not have a replacement (see cap with dot on top in pic).
Does that also need replacing or is it worth replacing with a new one?

IMG_3279.png
IMG_3279.png (1.12 MiB) Viewed 892 times

Post Reply

Return to “PSU (power supplies)”