New Exxos Red Power Supply

Repairs & upgrades.
Post Reply
User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 615
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

New Exxos Red Power Supply

Post by PaulJ » Fri Nov 30, 2018 3:08 pm

Just installed an Exxos Red Power supply (110v) and inital impressions are very good. If you read where I installed the 1.5 booster in a mega 4 there was an issue with the power supply interfering with 16 mhz clock un-fu*kit board. With the Exxos ps there's no interference issue. However there's an alignment issue with the mega 4 power supply frame and the fourth screw cannot be inserted. My 1040 frame mounted correctly with all four screws.
UG_3002.jpg
UG_3002.jpg (2.55 MiB) Viewed 414 times
One other small issue with the mega 4 power supply is the mounting screws have a larger head. This screw can not be used near the fuse because the screw head hits the fuse holder base and forces the screw to thread at an angle. The 1040 power supply bracket did not have these issues. The holes aligned and the screws had a smaller diameter head. I did use a 1040 screw in the hole next to the fuse holder which allowed it to thread correctly. The thread are the same. :) :)
UG_3001.jpg
UG_3001.jpg (2.22 MiB) Viewed 414 times
The supply runs extremely cool compared to the Atari supply, the transformer is only slightly warm to the touch after a two hour run. It also caused a improvement in the video. There is a noticeable absence of video artifacts. I don't know if the metal shield fit since I have this machine apart most of the time and the shield is more trouble than it's worth.

This supply would be perfect for Icky since it only has one electrolitic cap. :mrgreen: :mrgreen: :mrgreen:

Nice design Exxos. :bravo: :bravo: :bravo:

User avatar
exxos
Site Admin
Site Admin
Posts: 6822
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: New Exxos Red Power Supply

Post by exxos » Fri Nov 30, 2018 3:27 pm

:bravo: :coolpics:

Yeah the hole alignments varies across frames, so its hard to do a "one size fits all".. Though as you got 3 screws in, are you sure the frame isn't slightly bent somewhere ? Those frames are not exactly built to any sort of quality, so even bending the frame post outwards a bit and could be enough to make all the holes line up. I have done that a few times myself.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 615
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: New Exxos Red Power Supply

Post by PaulJ » Fri Nov 30, 2018 3:40 pm

Yes, theres a possibility the frame is bent though looking it appears ok. I got this one off eBay and when I received it the floppy was inside loose and had dislodged the home made eprom adapters. So its possible the floppy was pounding the supply. Its amazing the board wasn't damaged.

I really like the supply. It really runs cool compared to an atari supply.

Are you going to build one for a MSTE? As I recall there a line out of the supply telling the MSTE its ok to commence execution With no internal hard disk and this supply I believe it would be possible to run with a very low volume fan or no fan. I hate the MSTE fan noise.

Nice design Exxos.

PhilC
Trusted Guru
Trusted Guru
Posts: 1412
Joined: Fri Mar 23, 2018 8:22 pm

Re: New Exxos Red Power Supply

Post by PhilC » Fri Nov 30, 2018 3:48 pm

Looking to get one myself soon

User avatar
exxos
Site Admin
Site Admin
Posts: 6822
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: New Exxos Red Power Supply

Post by exxos » Fri Nov 30, 2018 3:52 pm

PaulJ wrote:
Fri Nov 30, 2018 3:40 pm
Are you going to build one for a MSTE?
Short answer no. I did write about this somewhere a while ago..viewtopic.php?f=9&t=764

With some re-cap kits I have in my store, there is no reason the MSTE PSU can't the new to last for a very long time yet anyway.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply