Dead Exxos PSU out of the blue

Repairs & upgrades.
mikro
Posts: 116
Joined: Mon Aug 28, 2017 11:22 pm

Re: Dead Exxos PSU out of the blue

Post by mikro » Tue Aug 14, 2018 10:00 pm

exxos wrote:
Thu Jun 21, 2018 1:16 pm
I do have 1 spare board from the last production I did, I ran out of transformers so it never got finished. So what I will do is transplant the transformer from the power supply and fit it to the new board, then just send the newer board to Mikro..
Success at last. Sorry for the delay but it took some time to actually pick it up at my parents' flat (didn't have a better postal address) and then mount it again:
IMG_20180814_213153.jpg
IMG_20180814_213153.jpg (3.23 MiB) Viewed 137 times
Perhaps you can spot a few imperfections (I just couldn't get the 4th screw to fit), also the PSU isn't "hole compatible" with the previous one, had to drill another two holes in the poor PSU bracket (and then again, it wasn't a perfect job). But in the end...
IMG_20180814_214758.jpg
IMG_20180814_214758.jpg (4.39 MiB) Viewed 137 times
... happy days. :)
Thank you Chris for such a prompt fix!

User avatar
exxos
Site Admin
Posts: 3595
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Dead Exxos PSU out of the blue

Post by exxos » Tue Aug 14, 2018 10:08 pm

:bravo:

Yeah the metal bracket hole locations vary from ST to Falcon or even brands , so it's pretty much impossible to do a "one size fits all" layout. Though I have made the holes in the red boards a fraction larger to try and help with it.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply