Page 16 of 37

Re: TF536 + 68000 relocator and ROM board project.

Posted: Mon Oct 19, 2020 9:58 am
by PhilC
stephen_usher wrote:
Sun Oct 18, 2020 10:40 pm
Thanks!

Would you like any when they arrive or are you happy with the Mk.I?
I dont have a lot of time to test things at the moment. My day job has gone really busy, which means lots of overtime but less Atari time.

Re: TF536 + 68000 relocator and ROM board project.

Posted: Mon Oct 19, 2020 1:56 pm
by stephen_usher
OK, no problem. :) I wasn't asking about testing anyway, just if you were interested. :)

Hopefully it's good busy rather than bad busy.

Re: TF536 + 68000 relocator and ROM board project.

Posted: Mon Oct 19, 2020 5:36 pm
by PhilC
stephen_usher wrote:
Mon Oct 19, 2020 1:56 pm

Hopefully it's good busy rather than bad busy.
Overtime = more atari the next month, so all good :D

And thanks for the offer, if everything checks out OK then you could sell a few to prospective TF536 STFM users perhaps?

Re: TF536 + 68000 relocator and ROM board project.

Posted: Mon Oct 19, 2020 7:58 pm
by stephen_usher
Could do, though I don't like selling things on-line.

I could donate them to people. We'll see.

Re: TF536 + 68000 relocator and ROM board project.

Posted: Thu Oct 22, 2020 2:24 pm
by stephen_usher
DHL are being very slow at shipping the PCBs this time.

The first shipment was dispatched on the Tuesday and by the Thursday was in Europe and on its way to the UK.

This time, again it was dispatched on Tuesday but today it still hasn't managed to leave Shenzhen. The expected delivery of Monday is looking less and less likely.

Re: TF536 + 68000 relocator and ROM board project.

Posted: Fri Oct 23, 2020 11:04 am
by stephen_usher
And the Mk.II boards have arrived!
IMG_2081.jpg
IMG_2081.jpg (380.36 KiB) Viewed 680 times

Re: TF536 + 68000 relocator and ROM board project.

Posted: Sat Oct 24, 2020 9:14 am
by stephen_usher
I've just realised that my idea for the /HALT line switcher is flawed and would deadlock as soon as /HALT went low.

So, does the processor, when in normal operation in an ST, ever assert /HALT?

If not then I only have to worry about unidirectional relay of the signal from the system side to the individual CPU which is currently selected.

Re: TF536 + 68000 relocator and ROM board project.

Posted: Sat Oct 24, 2020 1:14 pm
by stephen_usher
Well, the first test of the board has failed.

I'm guessing that it's due to my idea for trying to reduce the height, pushing the pins through the top of the board, leaving 3mm on them below the board. I'm not getting any clock on the clock pin. Hopefully it's just a bad contact.

So, after lunch it's out with the Hakko and redo the header pins. I'll also remove the 68000 I soldered in as I didn't have a spare socket.

Re: TF536 + 68000 relocator and ROM board project.

Posted: Sat Oct 24, 2020 2:42 pm
by stephen_usher
It boots to diag cart now off the "Accellerator" socket but it's picking up memory errors.

Also the /HALT & Turbo LED GAL is getting *VERY* hot. I'm guessing that my LED circuit design is faulty and it's drawing too much current from the GAL pin.

And somehow I've managed to change the ROM switch sense backwards again so open is high and closed low.

Re: TF536 + 68000 relocator and ROM board project.

Posted: Sat Oct 24, 2020 3:37 pm
by stephen_usher
Those memory errors were due to a bad CPU. Swapped the m68k and the fault went away.

Still, it doesn't seem as stable as the Mk.I board so far.